Home Network driving me bananas. WiFi works perfectly. Connecting router to Mac via Ethernet causes Mac to crash

Setup which has been working seamlessly for many years

I have 2 identical Mac Mini 2018, one runs Catalina, the other runs Monterey, both have always worked perfectly, never repaired. No crashes
File Vault off
Magic Keyboard, Trackpad
lots of space : more than 1TB on primary drive, same with iCloud
high speed Internet works perfectly with other computers (Mac and PC belonging to my family)


Just bought new Orbi Network (1 router and 3 satellites). With WiFi, everything works fine. As soon as I turn off wireless, and connect either the router or a satellite to any one of the Mac Minis via ethernet, everything seems to run normally for a few minutes, then
• when I click on app store icon, usually blank, sometimes (rarely) usual app store GUI. * can’t update apps: “cannot connect to app store” * either can’t sign out of iCloud and App Store, and if sign out works can’t sign back in “There was an error connecting to appleID server”
• after that, Internet becomes slower and slower, apps crash (spinning wheel) in rapid succession, mac freezes and spontaneously, repeatedly, frequently reboots and becomes unusable.
as soon as I disconnect the cable and put the mac back on wifi, everything reverts to normal. I have confirmed this 20 + times (ie it is reproducible)
I bought a thunderbolt 3 dock with an Ethernet port: if I connect the cable into that port and turn the wifi off, everything runs fine and the internet runs at cable (not wifi) speed, which means that the problem is specific to the mac port.

What I tried
I bought a thunderbolt 3 dock with an Ethernet port: if I connect the cable into that port and turn the wifi off, everything runs fine and the internet runs at cable (not wifi) speed, which means that the problem is specific to the mac port.
• multiple reindex and repair of primary drive
• anti virus (Bitdefender OFF permanently ie not relaunched at startup)
• don’t have a VPN
• before the many attempts at OS reinstallation, I deleted apps most likely to cause startup problems, like Karabiner Elements, Stream Deck, Hook and Yoink and repeated the whole install process.
• apple music and TV : not signed in
• I checked the status of local apple servers (Apple Server Status Report) : OK
• Aside from the Mini. both my apple ID s work perfectly in other devices if I access them via the web, my iPhone, my old iPad or the family macbook pro.
• I tried the following many many times (20+ times !) and it does not help
⁃ login Safe mode
⁃ login via another admin account (I always have an extra admin account)
⁃ boot from a Monterey Installer and reinstall the OS. I must have done this 20 times.
⁃ boot from internal recovery and reinstall OS
⁃ boot from Internet ie Internet recovery and reinstall OS
⁃ I tried multiple times a clean install of Monterey ( Monterey installer → disk utility → erase primary HD → install OS → migrate data) and of Catalina
⁃ I wanted to try installing a Monterey Combo update but could not find none. Combo updates seem to stop after Catalina
• regenerate keychain (moved keychain files to another folder → restarted)
• changed cables multiple times
• reset system preferences (procedure: ~LibraryPreferences / and delete 2 files below → shut down → turn ON
⁃ com.apple.systempreferences.plist
⁃ com.apple.desktop.plist
• cable modem works perfectly when accessed via cable or WiFi
• ISP sites and apple servers in working order
• kernel version 19.6.0
• tried to renew DHCP lease on Mac
• I disconnected every other device connected to the router. In other words, the sole connection was my Mac to the router

I have been working on this for a week, and I’m going bananas

thanks very much for your time and help

1 Like

Sounds tricky! Uninformed speculation: could the Orbi hardware be providing power over Ethernet, disrupting the Mac port, which isn’t expecting it? (From a quick bit of reading, seems that PoE has measures to prevent this, but perhaps those measures aren’t 100% reliable.)

1 Like

Were you using Ethernet connections from these Macs before you got the new mesh router set? That would suggest the problem isn’t with the Mac ports alone.

I’ve used a previous version of the Orbi mesh router set with Ethernet connections to several Mac models and system levels for years, though not Mac minis.

You may have received a mesh router set with a firmware load that affects Ethernet connections differentially in a way that triggers something in the Mac mini 2018 port hardware or the software that drives it. It might even be a subtle issue with the hardware design of the Ethernet ports on the new routers, but that seems less likely.

If the Orbi mesh set is new, you may be within the support period. Have you asked Netgear Support if they have heard of the problem?

Other things you might try:
See if some other Mac can connect to those routers by Ethernet and operate successfully.
Do another clean install on one of your Mac minis and test without restoring any apps or data.

I was trying to describe how to reset the network on your mac. Decided to check on the procedure, then i found this: https://www.lifewire.com/reset-network-settings-on-mac-5184072
In the past, I have used both procedures.

1 Like

Did you ever test the systems before migrating your data over? If some setting is causing the problem, when you migrate your data over, it’s probably bringing the corrupt setting over, defeating the purpose of the clean install.

1 Like

thank you.
I can try it, but after that what? I ask because not migrating the data and restarting the installation of my mac from scratch (apps and their settings) would be a gargantuan task.

What did you do when you had the problem ? Which procedure did you follow? Most of the article concern wifi. I could try deleting the settings files.
If I go to network pref and delete my Ethernet with a (-), will I know how to answer all the questions when I want to add it again (+) ?
thank you

It was working fine with the older orbi system which makes a bug caused by migrating data less likely, no?

please keep in mind that all works fine via the thunderbolt docking station Ethernet port connected to a USB-C / Thunderbolt port on the mac.

I will try.

I will try. once again keep in mind the thunderbolt Ethernet which works.

thanks very much

does this procedure using a terminal command make sense ? Is there any risk in trying it ?
thank you

I don’t know. Keep in mind that it all works using the Ethernet port of a thunderbolt docking station.

In the past maybe 10 years ago we had problems where I worked with several macs on ethernet, some solved by the first method, some by the second.

In the Network System Prefs you delete Ethernet instead of Wi-Fi. When you hit + you will get a dropdown where you select Ethernet. No more config as far as I remember.

When deleting the plists I think you can skip the Wi-Fi.

1 Like

thanks very much. Very kind of you. Will do and give you and update.
By chance, i found a USB-A to Ethernet adapter in the mess in my office, and Internet and mac work perfectly with speed of 230 Mbps.

Another thing you can look at is in the System Prefs>Network>Advanced>Hardware. There might be a problem with the communication with the router. To make this less error prone, you can select it manually. The setting will normally be Automatic. Maybe have a look at the interfaces that work (Thunderbolt/USB) and choose the same settings?

Regarding the LifeWire second method, I remember now that we rebooted in Safe Mode (holding down shift while booting) and deleted the Folder /Library/Preferences/SystemConfiguration. I remember that the ethernet problem went away, but there was some additional hassle with configuring some other system settings. Which I do not remember now… All worked well in the end. Today I would try the LifeWire solution first.

1 Like

thanks VERY much. I will follow your instructions and obviously give you an update.

I don’t typically use Migration Assistant, so I may be wrong. I think you can bring stuff over in stages. If a pristine system doesn’t have a problem, then fire up Migration Assistant and try bringing just the apps over. Then test again. And so on.

I’d consider the clean install a last resort, though. I’d first try deleting the ethernet interface in the Network settings, reboot, and then add it back. See if that clears up the problem. (Oh, I see @paalb already suggested that.)

Yes, I did see that. But perhaps the built-in port on the Mac is more sensitive to this than the alternative ports you’ve tried. (I don’t have experience with PoE, but I do know a bit about phantom power - a similar system in audio, and there, certain microphones can be negatively affected by inappropriately enabled phantom power, but other microphones can be fine.) Can you give us make & model for the Orbi hardware? I’d like to have a look at the manuals.

1 Like

The orbi model is RBK853, a kit which includes a router called RBR850 and 2 satellites called RBS850 and I bought an extra satellite (same model ie) RBS850.
WiFi works perfectly.

  • some like apple tv are OK (Internet) when connected to satellite via cable, and a 3rd mini belonging to my wife works fine connected to a satellite via Ethernet (whereas 2 other minis do not). Those which do not are clones of each other, meaning that they have something in common.
    Thank you very much for your time and interest

Some Apple products like the original Homepods seem to have difficulty with the latest “smart” wifi routers that try to optimise wifi settings. Try disabling this feature on the router.
For what it is worth, I tried an Orbi mesh system a few years ago and could not get reliable performance. I gave up and got a refund. I also tried a D-link wifi router in bridge mode but that confused my Homekit devices.
In the end I upgraded my Telstra (Australian ISP) to a more powerful wifi router.

1 Like

This certainly suggests an issue with the Ethernet port of the Mac. It’s not unheard of for these ports to go bad - I’ve seen several but they normally just fail for everything. Have you tried connecting directly to another Mac via Ethernet to see if that works (eliminating the rest of the network)?

1 Like

Inspired by @trilo It might be an idea to connect the two mac minis with each other. Then you know the Orbi is to blame if it works.

1 Like