Why does copy/paste sometimes not work between devices?

One of the main reasons I like the Apple ecosystem is because devices are so well linked together. And one of the features I like best is the ability to copy from one device and paste to another.

But sometimes - often actually - it doesn’t work.

For example, I might want to copy a photo from my iPhone and paste it into Mail on my Mac. Usually it works, but often it doesn’t, and the Mac ends up pasting the last thing I had in the clipboard there. When that happens I can use Air Drop, send it to the Mac, and upload from my Downloads folder. So the devices are connected.

Do others experience this as well? Is there a way to force copy/paste to work when it fails?

Just now I copied a photo of my dog from iPhone Photos and successfully pasted it into a tweet on Twitter on my Mac. I was relieved it worked, and it reminded me of the problem.

Here’s Apple’s documentation:

All devices must be ‘tight’ with one another. Also, the item is out there for only a short period of time. I’ve never tried it after 3 minutes or so. Has anyone researched how short is short?

The devices are within hand’s distance from each other. And this is a copy/paste attempt immediately after copying. So a mystery.

1 Like

I created a Keyboard Maestro macro whose sole purpose is to make a sound then something is copied to the clipboard. That way, I get an audible notification when I copy a one-time passcode from my iPhone, for instance. It’s also handy for knowing if a copy operation has worked or not. I posted this to the KM forums when I created it, but am attaching it here in case anyone wishes to try it.
Audio Feedback When Clipboard Changes.kmmacros (2.2 KB)

But that doesn’t fix the problem of copy/paste often not working between devices, does it? Am I the only person who has that problem?

No, you’re not the only one. It’s not often for me, but occasionally it just doesn’t work even when my phone and laptop are next to each other, on the same network, and unlocked. 98% if the time it’s flawless, like magic, but sometimes the clipboards just don’t see each other.

That’s my experience too. Usually works, but there are times when I simply have to try copying again to get it to take.

I find that when it’s not working that even copying several times doesn’t help. If it’s an image and I’m trying to bring it to the Mac I’ll use AirDrop then. For other things I’ll try other round-about methods.

But then later on the same situation will work just fine.

1 Like

Happens to me but I’m still on an old OS on the laptop. I remember how amazed I was the first time my phone offered to paste something that it saw from the laptop though! I’m not sure I’ve ever tried it the other way. I use a shipment tracker app and it’s so much easier to copy the tracking number from the computer and paste to the phone. Airdrop is really hit or miss even between two current iPhones.


No, you’re not alone in having this happen. Occasionally, a copy-paste between devices doesn’t work the first time, and sometimes it doesn’t work on the one device (my iMac) with certain applications (looking at you, Apple Music).

Having the aubible indicator (or lack thereof) helps me know if the copy operation ‘took’, as it were.

It sounds like it may be just you in that the problem occurs often. Like the others, I find copy-and-paste between devices almost always works. How frequently does it not work for you?

Most days, at least a couple of times.

For those of you for whom inter device copy/paste IS working, is it limited to one machine, or can you use more than one machine (e.g. desktop and laptop)?

I tried that for the first time yesterday. Laptop running Sierra to a Mini running Big Sur. It worked!

I usually do laptop to uptodate iPhone.


I think I found the cause of the blips where I could not hand-off (copy/paste) from my iPhone to my Mac. I noticed that my Mac’s wi-fi sometimes falls back to the 2 G channel of my router, while my iPhone consistently stays connected to the 5 G channel. It seems when that happens the copy-paste between the two doesn’t work right.

But I just tried it. Copy paste from my iPhone to my Mac wasn’t working. I noticed the Mac’s wifi fell back to 2G. I switched it to 5G and it worked.

Which is weird since Air Drop continued to work in either case.


In my case, I have a unified 2.6/5GHz mesh system, and my primary Mac is on Ethernet. For a long time, copy/paste just worked; now, sometimes it does, and sometimes it doesn’t. Sometimes a restart/reboot helps; sometimes it doesn’t. Cannot figure out why. I’m sitting two feet from the base router…

For those of you for whom inter device copy/paste IS working, is it limited to one machine, or can you use more than one machine (e.g. desktop and laptop)?