You do not have permission to open the application

When I try to launch the VPN access app Shimo, I see the following message.
Screen Shot 2022-01-16 at 16.35.27

Get Info tells me I have read and write permissions. Terminal shows me the following in response to “ls -l”.
total 0
drwxr-xr-x@ 11 will admin 352 Nov 18 2020 Contents

I ran Disk Utility’s Disk First Aid and got an almost clean bill of health. There were the following lines in the transcript.
Checking snapshot 3 of 5 (
warning: Cross Check : Mismatch between extentref entry reference count (2) and calculated fsroot entry reference count (1) for extent (1760068 + 4)
warning: Cross Check : Mismatch between extentref entry reference count (2) and calculated fsroot entry reference count (1) for extent (1760140 + 4)
Snapshots 1, 2, 4, and 5 were apparently alright.

Shimo used to run without a problem, but I don’t recall when I last ran it.

Probably unrelated, but in another thread, I reported problems with Time Machine starting when I updated to macOS 11.6.1 and continuing for many weeks, until it simply started working again. Certainly the last time I ran Shimo was before Time Machine started working again. I mention it because in both cases, there were reports of permission issues.

I replaced Shimo with a version from a Time Machine backup from before I updated to 11.6.1 and got the same message.

Any ideas? Thanks for any help.

Never seen this error before but you can try to check if it can be acl settings or by using ls -lae@. You have to do ls -lae@ /Applications/ and scroll back to see the rights of Also check inside Contents with ls -lae@R

Modern versions of macOS perform several rounds of validation before they will let you run an app. Yours is failing at least one of them for this app.

If you can download a new copy/installer of Shimo and reinstall it, I would start there. Ultimately, anything resembling a corrupt installation should be fixed by reinstalling the latest version from a reliable source.

If that isn’t possible, or if it didn’t work…

  • If you had previously denied it permission to run for some reason, go to the General tab of the Security & Privacy preference page and see if there’s a button to click to grant it permission.

  • It is possible that the quarantine flag (applied by various apps to flag downloaded content) is creating problems. Normally, when this flag is present, Gatekeeper tells you that the file was downloaded from the Internet, and will ask you permission.

    If it doesn’t ask, but immediately fails (as you may be observing), it may be because the app doesn’t have a digital signature - unsigned apps are automatically denied. If this is what’s going on, right-click on the app and select “Open” from the popup menu. This will give you the Gatekeeper confirmation dialog even if the app is unsigned.

  • If that fails, you can try manually deleting the quarantine flag, and see if that helps:

    sudo xattr -rd
  • If you’re still not getting any success, you can manually sign the code yourself. This should be done as a last resort, and should only be done if you are 100% certain that the app is genuine and has not been corrupted, because you are explicitly telling macOS to trust the code:

    sudo codesign --force --deep --sign -

    The above line signs everything in the package with the identity “-”.

    You may have to install Xcode (Apple’s developer software) in order to get the codesign utility.

Some of the above advice comes from the following page:


Thank you for that suggestion; I’ve made a note of it for future reference. In the present situation, it was overtaken by events.

That worked; thank you. Thank you for the other suggestions, too; I have recorded a link to this thread for future reference.

FWIW, the fresh download was a newer version. I wonder if there was some checking for an update that went horribly wrong.