watchOS alarms annoyance

So, I’m one of those nerds who sets an alarm on my Apple Watch (Series 3) before I retire for the night, then places it on a charging station on my nightstand. After the early hiccups with alarms, it has worked flawlessly for the past 4 years.

With WatchOS 8.x, an annoyance has crept up with setting alarms. Since I am up at different times on different days, a number of alarms are in the alarm list, and I can easily scroll with a finger or the crown wheel to find the one I need. Then I tap the “on” toggle for that alarm, and all is well.

The 8.x interface appears to have changed so that the entire box containing a given alarm is now a button. The on/off toggle is still there, but it is exceedingly tricky to tap it…because in most attempts the “Edit Alarm” interface for that alarm comes up instead.

Things I’ve tried:

  • Varying the force with which I tap the toggle. Doesn’t seem to matter.
  • Varying the time I hold my finger on the toggle. Doesn’t seem to matter.
  • Varying the curse words I direct at the watch to tell it just to set the alarm. Doesn’t seem to matter.

One thing I’ve noticed is that there seems to be a counter involved; I can reliably try and fail to toggle on the same alarm twice, and it will set the third time I do it.

I’m also filing this with Apple as a bug report, but just wondering (of course) if I’m the only one seeing this…or am I the only one still using my Watch as an alarm clock?

I see what you mean. However, I usually use Siri to set a non-recurrent alarm. I usually do it by pressing and holding the watch stem and say ing"Set alarm for …’. If you use the hands-free “Hey Siri, set alarm…” you risk setting it on another device. If the alarm already exists, it will toggle that one; if not, it will set up a new one.

I can only confirm that it is very irritating. I can not confirm the three times lucky though. To me, it seems like you have to tap precisely inside a tiny space, which is nearly impossible without trying many times. But sometimes I get lucky on the first.

I’m encouraged to see that someone else has been experiencing this exact problem, as nobody else I’ve talked to noticed. Like Alan, I’ve had to resort to asking Siri to “turn on my x:xx alarm” in cases where the alarm already exists.

1 Like

Note that if an alarm does not exist, Siri will create one. I’m not a big fan of Siri, but I do use it for setting watch alarms, changing automated shutdown for the Homepod Mini in my bedroom (“Hey Siri, turn off the music in 30 minutes”, asking random devices “HS, What’s Playing”, inquiring about and changing Homepod volume “HS, set the volume to 50%” or “HS, Louder”, etc.)

I don’t use alarms all that often, but when I do, it’s on the watch (which I wear while sleeping.) I haven’t noticed the problem you’re describing. I just tap the control and it seems to work almost every time for me, even on the smaller watch. Maybe once or twice it’s opened the alarm settings.

But I’ll agree that the control could be better.

1 Like

Works fine as long as someone else isn’t trying to sleep while I have a chat with a very-perky Siri about the alarm-setting topic. :slight_smile: And honestly, I’m not looking for a workaround. Something that worked is now broken, and needs to be fixed.

I’ve sometimes also gotten lucky by keeping my finger on the control for some indeterminate length of time. The whole thing seems to be random, dumb luck.

In general, I’m a big user of both Siri and Alexa. Most of our lighting is now automated in the main part of our smallish ranch-style house. Amazon has done a superb job of adding skills to tie up various manufacturers’ control hubs. We use Lutron Casetá devices for most of the lighting, a Chamberlain hub for our garage door, and some miscellaneous WiFi plugs for on/off lamps. Amazon integrates them all in the Alexa app so they become one seamless array.

I could do the same thing with Siri and the Homekit automations, but haven’t bothered because until xOS 8 I don’t think Siri was good or deep enough to merit a shift. At home Siri has been a handy cooking timer, a short-term forecast delivery system, and an occasional control for (yes) alarms and similar stuff. It also has been handy for quick numeric conversions.

In the truck, on the other hand, Siri and CarPlay are an amazing augmentation. I don’t mind using my voice at all for controlling maps, music, podcasts, or having texts read to me. It makes my longish commutes safer—not just for me but for other users of the road.

But at night, with my spouse already asleep and my vigilant Shelties ready to stand guard at any odd sound, using Siri to set alarms is a non-starter. That’s doubly true when the main method for setting alarms is acting all version-buggy.

I wonder if a newer watch is more sensitive? On my Apple Watch series 5, I have no issue clicking the on/off toggle, even late at night when my eyes are tired.

I’m wondering if it could also be viewing angle.

On my iPhone, for example, I find that the actual location you need to tap on a small object is slightly below the object. I think iOS is compensating for the fact that people usually hold phones at an angle, not perpendicular to their line of sight. Which means that if you are looking straight-down at it (or if it’s on a table and you’re looking from the top or a side), you may need to tap in a non-intuitive location.

If WatchOS is doing the same thing, then maybe tapping a small distance below the button will work better.

Possibly. The issue cropped up with a new version of WatchOS; it is possible that it was tested more against later models. I weigh that against the fact that while my Series 3 is now several years old, it is one of the three models that Apple is selling (Series 3, Series 7, and the Series “SE”). So I would think that if there were a tweak in the interface that they would test it against a model that is currently shipping.

Good thought, but I’ve checked that out thoroughly, in the daytime, when I’m not trying to be done with Apple tasks for the day. Any spot on or near the toggle results in the unwanted behavior.

One additional bit of information: the expected behavior is for the panel containing information for the existing alarm to highlight when it is being tapped (resembling a button push). The expected behavior for the toggle switch is for it to change state (sliding the round “slider” to the right and exposing a green underlay). Tapping the toggle switch is highlighting the entire panel.

I recognize that from HyperCard days, when I got sloppy defining a button region.

This inspired me to experiment. Now I can get it to work nearly every time. Try this: touch lightly and move 2 mm (1/2 inch) horizontal to the left and back again and let go. I have success with moving a bit more than that too. “Lightly” seems to be important as well as movement.

If it works, you get no sign before you let go, but if the alarm time is dimmed to show that you have triggered the “Edit Alarm” menu, you can move upward and out to the right with your finger to abort.

I have not tested this in bed yet. The concentration required to get this to work seems a poor fit for that stage of the day.

I have the Apple Watch Series 4 (GPS) 40mm case. Maybe the 44mm case is more forgiving?

I have the 44mm Series 4 (GPS & Cellular) and nothing you outlined works for me.

I have had some random luck with a light touch; also with a heavy touch, a short touch, a long touch. Your observation about needing to concentrate to get this to work pretty much captures why this is an issue.

The Apple Watch is a masterpiece of engineers sweating the small details, so I’m sure that it’s not Apple’s intention to make its users have to think about how and where and how hard they are tapping to make a basic function happen. Whether it’s a basic model or one of the designer showcase models, they’re all based on the same body, electronics, display, and software.

Just before I purchased my watch, I reviewed an Android-based watch with some kind of mineral name attached to it. (Rock? Bone? Fossil? I don’t remember.) What I do remember is how attractive and solid the watch body was, and how putrid and inscrutable the interface was. It got hot if I tried to look anything up on the display, and the battery barely carried it through a day.

Apple’s practice of letting others make a run at a new market, then introducing what the product should have been all along, is on display with the Watch. That’s why I hate to see small annoyances like this creep into the interface.

1 Like

Pebble?

Lol! Good guess. Turns out I was right the third time. Fossil.

A super light tap works for me on my 40mm Series 6.

1 Like

Matt, I do the same thing and now have the same exact problem on my Apple Watch (Series 4). Because I assumed it was just me, I hadn’t thought about filing a report to Apple… maybe I’ll do that now.

Thanks for writing about it.

1 Like

I use mine for wake up alarms but they’re always on. I don’t turn them off. I wear my watch to bed and charge it during the day when I’m inactive and pinned to my desk anyway.

I also use different alarms for different days so I’m not turning anything on or off regularly. I do turn rare alarms on manually.

I just checked. I see what you mean but I have no trouble whatsoever hitting the toggle instead of the whole-alarm-button. Mine’s a much later model but not the latest.