Surprise! Fujitsu Releases 64-Bit ScanSnap Manager for Older Scanners

OK. But if I’m happy with ScanSnap Manager I imagine that at some point I’ll remove ScanSnap Home.

Yeah, @cwilcox made related comment about this in Oct 2019, see here:


Bummer. I have the S300M, also.

ScanSnap Home didn’t support the S300M, but the new ScanSnap Manager v7 does. I’m actively using it under Mojave and tested it on my MacBook running Catalina. Works as expected on both. From my point of view, everything is the same as it was.

I haven’t tried the new ScanSnap Manager with my S1100 (need to find it first), but I thought someone else in the thread said it worked for them.

There was absolutely no reason to not upgrade to 64bit- other than to fill landfills and make people buy new scanners- or Vue Scan (which I already have- to run a long abandoned Epson flatbed photo scanner).
I’d hooked my S300 up to that computer- which annoyed me.
So happy to be referred to this thread from Macintouch.
Downloaded the driver for the s1300i (it looked the most like the S300) and low and behold- I’ve got a nice little sheet fed scanner again!
Now- I’d even consider buying another Fijitsu product again in the future- which was off the table before. There is no reason to orphan hardware because you don’t want to update your software (datacolor- take note).

1 Like

I got stung by Epson’s unwillingness to update scan software for Catalina. I’ll never buy another Epson product.

I didn’t realize that Epson was also contributing to the 32-bit scanner junk pile.

Hooray! My S510M is now working natively on Catalina after running (admittedly nearly flawlessly under Mojave in VMware) for nearly a year. Now for Big Sur…

Anyone have a direct download link for an updated 5.5 version of ABBYY FineReader for ScanSnap. I can’t seem to get it to download from their site.

1 Like

To clarify: The new version does indeed run under Mojave?

I wondered about testing before making the jump (still held up by transferring my Aperture large library into something usable under Catalina). (Scansnap 1300)

Greetings, Rolf

I am running ScanSnap Manager v7 under Mojave on my Mac mini and I’ve encountered no issues so far. My scanner is older: S300M.