macOS 11.2 Big Sur Improves Bluetooth, Squashes Bugs

Originally published at: macOS 11.2 Big Sur Improves Bluetooth, Squashes Bugs - TidBITS

Apple has released macOS 11.2 Big Sur to stamp out a handful of miscellaneous bugs and close numerous security holes.

Just to say I waited till a couple of days ago and 11.1 had been out for a while to upgrade to Big Sur on my 2014 MB Pro that had been running Catalina. I like the new, much cleaner design. Best feature imho is that you can now re-size the columns again in Mail, something that had been standard in Mail for years but somehow disappeared in Catalina.

even after update, external display is still blank black when connected with USB-C Digital AV Multiport Adapter

No problems with Big Sur when connected from my 2014 MB Pro to a 24" Apple LED Cinema display external monitor, via the monitor’s Mini Display Port cable, and used as an external, second monitor. The external monitor works as it does with earlier Mac OS going back to Snow Leopard, although the display control panels have changed a little over the years. If you’re running an Apple monitor, even an older Cinema Display, this article may help: How to connect your old Apple display to your new Mac | Macworld

1 Like

In my experience, Big Sur is an unstable piece of trash, and my first Mac was an SE/30. Apps refuse to launch because I “don’t have permission” to launch them, and this happens only after a long pause while the OS struggles to figure out what to do. I can usually get them to launch eventually. The OS seems to prefer to launch them when I double-click on the app rather than click on the icon in the Dock but I don’t think that’s always the case. Safari and other apps also spontaneously crash. I often come back to my computer and get a message that some program crashed, most often Safari but it was NetBarrier a minute ago. All this after having no significant problems with Catalina. Oh, and SuperDuper still hasn’t been updated by its developer, who blames Apple for a half-baked roll-out. Big Sur is a grave insult to the Mac community. Disgusting!

TIL - that if you try to use softwareupdate to try to install a system update:

  1. It will show you the update.
  2. It will download the update (slowly, in this case)
  3. When it completes, it will reboot the system.

and here’s the tricky and most important one…

  1. It will not actually install the update, so when you reboot, it will be the same version you had before!

One of my Mac-admin friends informs me that softwareupdate is no longer supported by Apple for system updates.

Yet it still shows the update and downloads it.

(No, my Mac-admin friend couldn’t explain why Apple hasn’t done something to make it so that wouldn’t happen since they made sure that softwareupdate can’t actually do its job anymore.)

Could this be your problem?

OWC is reporting that SoftRAID is incompatible with macOS 11.2 on M1 Macs, so if you use SoftRAID, delay your update.

1 Like

No, that’s not the explanation. I do not have an M1 Mac, I have a 2015 Intel iMac. By the way, none of my Big Sur problems went away after I installed v.11.2. Apple is so busy fixing security problems that it apparently hasn’t had time to address the actual usability of the OS.

The problems you described don’t seem to be shared by a lot of us here running Big Sur, which might suggest that you have a corrupted install. I’d recommend reinstalling Big Sur and seeing if that resolves any of the issues. Another possibility is that your Mac has started suffering from a hardware problem at roughly the same time as you upgraded from Catalina—if it’s related to failing storage, it could even have been triggered by the upgrade.

1 Like

The headline and the article state that is for M1 Macs, not an 11.2 issue with Intel Macs. That said, my iMac Pro has not yet needed my ThunderBay SoftRAID… . ::grin:: I will be testing that eventually.

1 Like

Oops, good catch! I’m still internalizing that I have to keep checking for that sort of thing now.

It is a bit more complicated these days!

I use and support a range of Mac computers (5 or so for personal use and another 5 for family and friends, ranging from 2010 to late 2020) and it is amazing the contemplations I have as I ascertain whether something will work on any given computer with the numerous CPU configurations and multiple OS versions!

I have been watching and reading the SoftRAID forums for months now as I waited and watched to determine when was the right time to upgrade various computers that needed various plugins (mostly audio and generators for FCP) and what would work on my new M1, also based on plugin updates.

There are now (related?) security updates for Mojave (hooray!) and Catlina:

Here are some posts about these problems: Big Sur Problem?: "You do not have… | Apple Developer Forums. I could give more examples. I checked my boot drive twice with Disk Utility and it passed with flying colors. I then reinstalled Big Sur. The problems still exist and are easily replicated.

Try safe boot. Do the problems persist? If not, do they persist after then rebooting again in the regular manner? Do you see the same problems if you log in to a vanilla user account?

There’s now confirmation that the sudo bug is still present in 11.2, as we thought it would be given the lack of mention in Apple’s security notes.

I can’t even boot into safe mode without jumping through hoops. As CNET says in a 2013 article at What to do when a Mac won't boot to Safe Mode - CNET, I’d first have to disable FileVault and remove my firmware password. Ridiculous. I can’t boot into safe mode by holding down the shift key on my iMac or my MacBook Pro because of this. (I’ve tried it many times.) Anyway, the app launching problems have become intermittent. I thought they had perhaps gone away but no, I just got another error message of the same type. I’ll try a different user account but as I showed, other people are posting about this problem. Other people are also posting about Big Sur Mac app crashes. I will never give Apple the benefit of the doubt, not after my experience over many years. Shades of the days of INITPicker.

I just created a new admin user account and tried to replicate the app launching (permissions) problem. No problem replicating it – same error.

I have File Vault enabled too and getting into Safe Mode is not a problem. If the only thing holding you back is the firmware password, I’d just disable it for this test.