M1 Macs and .iso disk images

Can you post a link to the image file so others can test too?

I assume this: https://archive.org/download/acapllig/AppleLogoAndSignatures.iso.zip is the actual link? I downloaded that, unzipped it, and tried to mount the .iso. On Mojave the Finder complained “There may be a problem with this disk image. Are you sure you want to open it?” but when I clicked Open it mounted and operated like a regular disk.

I then tried on Big Sur, and there it told me it had no recognizable file systems. Disk Utility says it’s formatted as Mac OS Standard, so maybe Big Sur (or Catalina, I didn’t try it there) dropped support for Mac OS Standard?

Anyways, I’d say you have to find a machine running an older OS, mount it there, then copy everything you need off.


As an addendum, I poked around and found a couple .iso images. One is a Windows image, and Big Sur mounted that fine, reporting the file system format as ISO 9660. The other had a file system formatted as Mac OS Standard, and Big Sur wouldn’t mount that. So it looks like Big Sur supports .iso images just fine, but not the Mac OS Standard file system format.


It may not be a Big Sur problem; Big Sur on my Intel Mac opens the image just fine, it’s Big Sur on the Apple Silicon Mac (M1) that’s the problem. Which kind of Mac did you try it on??

Bingo! “Mac OS Standard” is Apple’s name for the old HFS (not HFS+) file system.

Apple started the process of dropping HFS support in Mac OS X 10.6 (Snow Leopard) - volumes could only be mounted read-only. Support was officially dropped in macOS 10.12 (Sierra), but unofficially kept working until 10.14 (Mojave). Starting with 10.15 (Catalina), HFS volumes are not mountable at all.

If you need to access the content of an HFS volume on Catalina or later, there are two options I can think of:

  • Install macOS 10.14 or older in a virtual machine or an emulator. Mount the ISO file or optical disc from there.

  • Use the open source hfsutils software package. It is part of most Linux distributions. It is available for macOS via Homebrew.

    Note that hfsutils does not actually mount the volume like a normal file system, but does provide a command-line mechanism to walk through a volume and read/copy files. I find it very awkward to work with.

Sadly, neither of these options is very convenient if you just want to read a few files from a CD-ROM or a CD image.


Intel Macs, should have included that, sorry. It’s curious though that you can open it in Big Sur on an Intel Mac, I couldn’t and what I’ve read around the ’net suggests they’ve completely dropped support. Maybe they dropped support but left the code in for Intel Macs? At least you can access it though.

A third option which might give the most faithful view of a Mac OS Standard/HFS filesystem is to use SheepShaver, which emulates a PowerPC Mac running classic MacOS (and allows copying files to the modern Mac host). This will probably be a lot faster, and it is relatively lightweight. Instead of requiring gigabytes of space for a MacOS X installation, the entire emulator+OS will likely come in at around 1 gigabyte. Current builds of SheepShaver are listed here:

SheepShaver builds for Mac OS X, links and downloads - E-Maculation

However, instead of manually configuring SheepShaver and installing classic MacOS, it’s much faster to download Edward Mendelson’s pre-packaged system which includes everything ready to run as a single application (now universal for Intel and Apple Silicon).

Mac OS 9 for OS X/macOS

I keep SheepShaver around for the times I need to access old CDs or disk images, and occasionally WordPerfect for Mac files (I learned of Edward Mendelson’s excellent work from the WordPerfectMac Group).

This is sort of a variation on @Shamino’s first option.

1 Like

Thank you for the suggestion. Ironic that I have to turn to either an older Mac emulator like Sheepshaver or pull out an Intel Mac from storage just to deal with a file format that the most advanced hardware Apple now makes refuses to open!

My point in originally posting this issue was to state that I sincerely hope there are no other surprises in store for those of us using the M1 Macs. I don’t like these kinds of surprises.

I think this is more likely a consequence of MacOS changes, regardless of Intel or M1 (as @Shamino & @blm have noted). It’s unfortunate, though at least HFS support lasted a lot longer than MFS (which still had a 13-year run)!

Changes like this are inevitable, so I always view them as interesting puzzles. If they revolve around mission-critical software, that’s an indication that upgrades to the software or underlying business practices are necessary. Otherwise, they’re just amusing challenges that almost always have solutions, even if they involve wacky emulators like SheepShaver or actually digging out old hardware.

Life’s too short to get stressed about how long Apple will support some ancient format.


This is exactly the right attitude to take, imo. Change will happen, whether you’ve planned for it, or it is a surprise.

I understood the issue was not so much change (which is inevitable), as change that is not announced and left to the user to discover when in the middle of work. My understanding here is that although the format is old and has long since been deprecated, modern versions of macOS have nevertheless continued to offer some access and that it’s only M1 Macs that now lose this. Not a big deal if it’s known and people can prepare ahead of time, but definitely an unpleasant surprise if somebody has to discover this in the middle of trying to get something done.

1 Like

According to everything else on the internet when I did a search, this has nothing to do with the switch to M1. People started complaining about the loss of access to HFS with the release of Catalina. How @bjmajor can access an HFS volume on Big Sur is a mystery!

Whilst searching, I also came across this article which provides a nice guide to using the hfsutils utility that @Shamino referred to. As said, you can’t browse the volume/disk in the finder. But you could use hcopy -r and the * wildcard to copy the entire contents of an HFS disk elsewhere.

While I think sometimes Apple jumps the gun on dropping support for things, in this case I have to agree with @ace. HFS/Mac OS Standard was introduced in 1985 (1985!), was replaced by HFS+/Mac OS Extended in 1998, and dropped in 2019 with Catalina. So it lasted 34 years, which is forever in computer time, 21 years of which a much better file system format was the default. And there have been 4 workarounds suggested. So yes, it’s annoying when you’re trying to get some work done and hit a roadblock like this, but in context, it’s really not that big of a deal.

I suspect this is also the reason why some of my very much older files appear as an .exe file, which I have been able to save by opening them in my ever trusty LibreOffice and safe as a file from there. That helped me save my doctoral research and thesis way back from AppleWorks days lol.

Also, once HFS+ was released there was really no reason to stick with HFS. Arguably, HFS was defunct by a year or so after HFS+ came along.

There were basically no drawbacks to switching, and a significant benefit in terms of efficient disk use. The one question I would have, though, is that my memory is that for compatibility, an HFS+ volume is contained in an HFS volume. That would imply that some code must still be able to handle at least enough of HFS to enable HFS+.


Not to mention that it will make the efforts of those who take the time and effort to upload files to archive.org in vein if, eventually, a lot of that archived material can’t be accessed by a modern OS and/or modern hardware. Just because a format is older and fallen out of use doesn’t mean it’s worthless, either.

Thanks for your reply!

1 Like

I generally agree that it’s not unreasonable for Apple to have dropped HFS support, but on the flip side, they still support FAT volumes – and that format was introduced a year earlier in 1984 and on a non-Apple platform.

Not quite. For external disks and disk images, HFS was still important for several years so that older Macs could access them. There were still many Macs in use that couldn’t run Mac OS 8.1.

If you mounted an HFS+ volume on an older Mac OS version without support, it appeared as an HFS volume with a single SimpleText file that provided information about HFS+ and how to access it. I don’t know how this was achieved – it could be that the initial information in HFS+ looks like a small HFS volume to an HFS OS, rather than the HFS+ volume being wrapped in an actual HFS volume.

FAT was actually introduced in 1977. The difference between FAT and HFS though, is that FAT is still actively used, in embedded systems, on things like digital cameras, on flash drives and media cards, and on the boot partition of PCs. It’s also the de facto standard for interchanging media between Windows, Linux, macOS, and miscellaneous devices, which is probably why Apple still supports it. None of that can be said about HFS, which was effectively obsolete in 1998.