Weird Message on iDevices

On both my iPhone 12 and my iPad Mini 6 recently, a message popped up on the screen telling me I had to use HomeKit in order to use iCloud; so far it hasn’t appeared on my iPad Mini 5. Has anyone here seen something similar?

I only use iCloud for my Dot Mac email and Contacts, nothing else. I do NOT use any HomeKit or non-Apple so-called “smart” home devices and never will.

1 Like

I haven’t seen anything like that, but I have also never wanted to use HomeKit. In fact under Settings Apple ID > iCloud > Home I have that master switch turned to off. What does that switch say for you?

Even though I NEVER enabled it, “Home” was enabled on my iPhone 12. However it was disabled on both the iPad Minis, yet the Mini 6 still displayed that message.

I’m going through the list and turning off everything except for Mail & Contacts, as those are the only two iCloud items I use.

I also religiously turn off everything I don’t actually use regularly. And I’m afraid after updates I usually have to go revisit that because apparently I’m holding it wrong. :wink:

Ah that may explain why my iPad Mini 5 doesn’t get the message as I have to keep it on iOS 14.4.2 due to a critical finance application.

1 Like

Having to yet again turn off all the stuff I don’t use because Apple knows better than me what I want and turns on Bluetooth and random other stuff, etc infuriates me anew with every single update which comes out.

Ahhhhhhhhh Religion: After every major iOS update, I take the time to go thru all three of my iOS devices and check the settings. I can ABSOLUTELY swear that one or more were changed by the update. SWEAR!! And I do this immediately after the update, with the iOS device in Airplane mode and with wi-fi and bluetooth off. If I do not have the time to check, I delay the update. I regret I am not that religious when I update the MBP or MBA.

1 Like

Do you have a HomePod or Apple TV? Those are both hubs and setting those up could be what switched the setting on.

Yes, I have 2  TV 4K units. I’ll have to see what is in their settings. I’m going to be using the one connected to my 70" TV to watch the WWDC Keynote in a couple of hours.

Update. The  TV in the living room was enabled as a hub; the one in the bedroom (which I haven’t used) was not even setup as a hub yet so I just left it disabled for now.

Update. The  TV in the living room was enabled as a hub; the one in the bedroom (which I haven’t used) was not even setup as a hub yet so I just left it disabled for now.

I am regularly disappointed to find that settings have been turned on by Apple like that, either as part of an update, or just whenever, I can’t tell.

As an example I have never turned on ‘Game Center’, but have turned it off upwards of 20 times in 10 years.

I await with dread the day apple decides to turn on desktop icloud sync “for me”.

I agree. Just the other day I discovered Apple had turned on Automatic Updates on my iPhone so my iPhone updated to iOS 16.5! Now I have to keep Airplane Mode on unless I’m making a phone call. Timmy is ticking me off more & more.

1 Like

I check auto updates, iCloud stuff, nd Game Center fter every update on every device.and have never signed into the letter but have signed out of it dozens of times. And while I appreciate the ‘are you sure you want to keep allowing app xxx to run in the background’ warnings…one would think that keeping track of them and if I say :always allow’ say 3 times then leave it off permanently or perhaps just ask the user all of those questions once after every major (whole number) update.

1 Like