VueScan: Not the ScanSnap Replacement You’re Looking For

Hi, I would like to point out an article about testing ExactScan with a Scansnap. I found this blog via a blog entry on the Devon site.
The main difference in use seems that with ExactScan one has to start the software first and order the ScanSnap to start scanning from with in the app, though it will perform everything reasonably similar to ScanSnap manager from that step.


A couple weeks ago, my copy of VueScan started telling me it was unregistered even though I bought a Professional license which has a lifetime registration. I sent an email to support explaining this and here’s the reply:

I seem to recall you did something obnoxious, so I revoked
your registration info. Go away.

Ed Hamrick

I’m flabbergasted. I’m really not sure what to do at this point. Any suggestions?

IANAL, so take my words with a grain of salt. You may have done something that warrants revoking the license, as set forth in the agreement you made when you bought the license. But without further explanation, just doing “something obnoxious” is not a warrant for revoking your license to use something you’ve paid to use, if you’re using it according to the agreed terms. Even if it’s something obnoxious that Mr. Hamrick doesn’t like one little bit.

If it were me, I’d start by calling my state’s attorney general’s office. They should have a division of consumer affairs that can handle a complaint like yours. Probably online.

After checking it out, you might let Mr. Hamrick know that you plan to pursue this route, because the attorney general’s office tends to deluge the complained-against business with a ton of paperwork that he will be required to complete. So it would probably be cost effective for Mr. Hamrick just to give you back the use of your license.

That would be my opening strategy anyway… Others might have better suggestions…

The “obnoxious” thing must have been the post I made earlier in this thread. That doesn’t seem like legal grounds for revoking a license.

Wow. Just wow.

From a reducing stress in your life category, my suggestion would be to do nothing. Your post speaks for itself and it’s on the record for posterity.

A quick Google turned up this stream of comments on a photography site. You are not alone.

Astounding. And not in a good way!

I apologize to Adam and Dave for using the TidBITS forum to air dirty laundry. I’ll try to keep this as on-topic to VueScan as possible, but I do need to clarify a couple comments.

He claimed to be a software developer, but he’s not, he’s a 50-something
musician who does IT in his wife’s veterinary practice.

  • The part about not being a software developer isn’t correct. I am a full-time programmer although my credentials are certainly not nearly as impressive as Mr. Hamrick’s. I studied computer science at SF State but didn’t graduate. The CS program was highly impacted in the early '80s so it was hard to get into required classes. I was a rash youth and after a lot of frustrated attempts to sign up for classes, I stomped off in an impatient huff. In retrospect, it wasn’t the wisest of career moves. A little sleuthing would turn up my public profile on Stack Overflow.

  • My wife and I did own a veterinary clinic. We bought it in 2005 and sold it in 2018. As a business owner I kept the computers running and did the books. But that was in addition to my full-time job.

  • Yes, music is a serious hobby of mine. I play in a cover band, sing in a community choir along with my wife, play in musicals for a community theater company, and play double bass in the orchestra at the local community college. It sounds like a lot but in the end it’s just a hobby that tries to pay for itself.

  • Mr. Hamrick got my age correct.

He bought it in 2012, and I don’t have any way of refunding this. If
he sends me his paypal address, I’m happy to refund him so I never
have to read his obnoxious e-mails again.

I did buy an upgrade to the VueScan Professional license in 2012. I bought the regular license many years before that, but the detailed transaction information in my accounting software only goes back to 2011 so I don’t have any exact dates. I know I used VueScan as far back as 2007.

I sincerely appreciate the offer of the refund, if not the sentiment behind it. I’ve thought about it and am not going to ask Mr. Hamrick to issue the refund. VueScan did a good job for me for many years and I certainly got my money’s worth. I’ve switched to other software now so I will no longer be sending emails to Mr. Hamrick so to that end the refund is not necessary.

Here’s the exchange that ‘triggered’ Steve:

If we’re going to publicize the exchange, let’s include it from beginning to end in the interests of completeness. To Mr. Hamrick’s credit, his response time to emails was very impressive. Much of this conversation was essentially in real-time. I’ve not reviewed the emails before posting them here so there’s every possibility they’ll paint me in a bad light. But I am committing to including the entire interaction without edits except for removing links to uploaded files. The first email is a list of answers to the questions asked for support claims. (Incidentally, the behavior I reported went away in a subsequent update to VueScan.)

  1. Brother MFC-9970CDW
  2. The Vuescan preview pane flickers, especially when I adjust the selection marquee. It even flickers when it’s in the background of the login screen when I switch accounts.
  3. This problem has existed for months. I’ve restarted the computer and installed multiple VueScan updates.
  4. vuescan.log attached
  5. This happens whenever I use VueScan with one of the two user accounts on this iMac. With my main account there is no flickering, only with this account. The account that works is an admin account and the other is a Standard account. I tried making the other account an Admin account but that didn’t help. I also tried deleting ~/Library/Preferences/com.hamrick.vuescan.plist and ~/Library/Preferences/vuescan.ini

I’ve tried to attach a couple movies of the behavior. They’re pretty big so I’m not sure how or if you’ll get them. I’ve also copied them to a Dropbox folder: (link)

I know this is a weird one. I hope there’s something here that’ll help you track it down.

Best regards,
-Steve Nicholson

Yes, something is definitely wrong.

You might check to see if some non-Apple software
you’ve installed might be causing this.

The vuescan.log file shows that everything
is ok when you scanned.

Ed Hamrick

Hi, Ed:

There’s nothing installed in that secondary user account that’s not installed on the main user account. In fact, it’s a much cleaner install than my main account. The only things I use in that account are iTunes, Preview, and VueScan. Do you have any ideas about what might cause that behavior? Has no one else ever reported this?


Does VueScan work ok in the Administrator account?

Ed Hamrick

When I changed the secondary account to an Administrator account, it didn’t change the behavior. When I get home tonight I can try creating a new Admin user and see how VueScan works with that one.


Hi, Ed:

I tried creating a new Admin account and a new Standard account and they both have the flickering problem. Can you try creating another user account on your Mac to see if you can duplicate the problem?


I get almost 10,000 people per day downloading
VueScan, and you’re the only person in at least a
year who has reported this flickering problem.

The only thing I can conclude from this is that
it’s related to something unique to your system.

Ed Hamrick

Hi, Ed:

Have you tried creating a second user account on your Mac to see if the flickering problem happens there?


No, it’s not worth spending time on. You’re the
only one reporting this problem, and I have tens
of thousands of customers using VueScan on a
Mac with other accounts.

Ed Hamrick

It takes less than five minutes to create a new account, run VueScan, and delete the account. Are you refusing to spend five minutes to attempt track down a bug?


You’re the only one reporting it, so it’s not a bug in VueScan.

Ed Hamrick

Wow. I don’t even know how to respond to that. It’s obviously a bug in VueScan because it’s happening in VueScan. But if you refuse to acknowledge it or spend the smallest effort trying to duplicate it I guess there’s nothing else I can do. As a software developer myself, I’m completely at a loss to understand your actions and attitude.


You’re missing the conclusion that any professional
software developer would reach:

  1. 10,000 downloads per day
  2. 1 report of this problem in a year

The obvious conclusion is that the problem is
with the software on the system that’s having
the problem - something you’ve installed on your
computer is causing flickering. It’s such a trivially
simple and obvious conclusion that I’m stunned that
you claim to actually be a software developer.

Ed Hamrick

I’m still curious why you thought it was OK to revoke a user’s license.

If I give you money for something, and you take the money, but then make it so I can’t use the thing I paid for, how is that different than theft?

Even if you did refund his money, it’s a very hostile action to take because you were bothered by something someone said. Is that official company policy?

I’ve only used VueScan with Canon scanners and had great success. The only problem was when I had an old scanner that only worked with 32-bit software. Ed explained the problem as to why it wouldn’t work with 64-bit so I was able to justify replacing the scanner with a new one that did more and cost less than the old one. I then donated the old scanner to the Salvation Army.

“…this equipment…”
To what equipment are you referring? This is a pretty long thread to look back through and re-read.

The ScanSnap scanner that is the subject of the email.

I have a very old ScanSnap scanner, which I had managed to keep going with some tweaked up drivers. The upgrade to Catalina brought that to an end.

I came across this article while searching for a solution. While it seems that a lot of people are happy with VueScan, the attitude of its developer(s) towards someone asking to look into a potential bug is unbelievable! Thanks for posting the email exchange. I am going to steer clear of it!

I’ll give ExactScan (trial) a go and if that doesn’t work, it’s time to replace the scanner with something newer

Good news for you:

2 posts were merged into an existing topic: Surprise! Fujitsu Releases 64-Bit ScanSnap Manager for Older Scanners