Update badge despite nothing to update

So I got my new MBP and that forced me to update to Catalina. So far it appears I’ve been lucky (hope that didn’t just jinx it). One strange issue has popped up though. Sys Preferences is showing a badge. The badge comes from Software Update. However, when I run that it reports 10.15.4 and nothing to update. But the badge persists.

At first I thought this might be related to having stopped Catalina nagging on my previous Mojave MBP (from which I migrated). So I went back to check. Indeed sudo softwareupdate --reset-ignored returns an empty list. Even softwareupdate --list shows that there remains nothing to update.

Any ideas why the badge refuses to go away?

There was a recent supplementary update to 10.15.4. Try hitting CMD + R to refresh the software update window.

Yeah, I had tried that. But no dice. It just displays I’m up top date.

But the badge remains. Argh.

Have you relaunched the Dock? Doing that usually gets rid of sticky badges.

There is probably an easy Terminal command to do it, but I use the venerable utility TinkerTool which can be downloaded from https://www.bresink.com/osx/TinkerTool.html.

Hmmm, annoying.

Good suggestions about relaunching the Dock.

(There are also Terminal instructions around to suppress the red badge for people who want to update to Catalina, but you don’t want that).

As far as I can recall the 10.15.4 Supplemental Update (April 8th) is the most recent item that would appear in Software update. Does this appear in System Information > Software > Installations on your Mac? If not you could download and install it manually from HERE.

You could also try running the 10.15.4 full installer on top of existing. (won’t affect data or apps or settings).

I also get Epson 3.3 after every system update because I installed the full Epson package sometime by mistake I think.

Thanks. Good tip. But unfortunately, that doesn’t clear the badge either. And the fact that the badge is also on the Software Updates panel in Sys Prefs tells me it’s not just a Sys Prefs icon display issue either.

By the way, I had an older version of TinkerTool so I tried updating. Downloaded the DMG from Bresink’s website. I can launch the DMG but it never opens an actual image. Nothing mounted, nowhere. Tried twice. Anybody else see this? Is this a problem with his DMG or is this some kind of Catalina thing?

It does not show there, but then again, there’s hardly anything in there because the Mac is brand new. It never had to run any updates yet. The supplemental update will not run saying it’s not supported on this system. I guess my OS is too new.

I actually noticed that my version of TinkerTool needed updating before I wrote my reply. When I opened the DMG, the associated message explicitly said to move the app into a folder. So, it apparently needs to be on an actually drive, not the virtual drive created from the dmg file.

I didn’t even make it that far. When I double click the DMG nothing opens. Nothing gets mounted.

Other DMGs do mount so I wonder if there’s a specific issue with his. But you sound like you’re able to mount. :confused:

Scratch that. Noticed a process (Image Mounter IIRC) was stuck at 100% CPU. Nuked that process. After that Bresink’s DMG mounted. No change though. Dock restart doesn’t affect badge. :frowning:

It does not show there, but then again, there’s hardly anything in there because the Mac is brand new. It never had to run any updates yet. The supplemental update will not run saying it’s not supported on this system. I guess my OS is too new.

So if the macOS build number is 19E287 that would figure.

It is a bit of a coincidence you have this issue and migrated from a Mojave where you had surpressed the Catalina update notification. But that is speculation and I wouldn’t know how to deal with it.

In your shoes I would run the full installer for 10.15.4 over the existing install. Or you could wait for 10.15.5 any day and see if that mops it up.

Yeah, at this point I’m inclined to wait for 10.15.5. That said, if I boot into recovery mode and reinstall from there, will that automatically install the latest Catalina there is?

Depends on how you decide to do the reinstall. According to Apple:

There are three magic keystrokes for recovery:

  • CMD-R. Reinstall the latest macOS that was installed on your Mac.
  • CMD-OPT-R. Upgrade to the latest macOS that is compatible with your Mac
  • CMD-SHIFT-OPT-R. Reinstall the macOS that came with your Mac, or the closest version still available.

So, if you reinstall with CMD-R, you’ll get what you were already using (assuming you never downgraded). If you reinstall with CMD-OPT-R, then you’ll get the latest version available at the time.

Of course, you could also download a full 10.15.5 installer (when it becomes available), make bootable installation media from it, and boot that in order to make sure you are installing that specific version and nothing else.

1 Like

Awesome. Thanks for that list, @Shamino.

This just got weirder. Now my TV app in the dock also has a badge showing 1.

It popped up right after I had checked Sys Prefs > Apple ID and selected to use TouchID for purchases. There is zero indication that there’s anything new in the TV app for me to see, download, etc. I selected check for available downloads, but nothing. Authenticated computer, it already was. Signed out and back in. No change.

Hot damn, WTH is up with this badge mania?

Ironically, neither Sys Prefs nor TV show up in the Notifications settings so that I could at least turn off the badge. Go figure. :confused:

Have you already upgraded to tvOS 13.4.5 (17L562) that came out on Wednesday?

tvOS? I don’t have an Apple TV.

Maybe this is a coincidence, but I just noticed on my iPhone that the TV app there is also showing a badge. Upon launching the app I realize it’s just Apple trying to push their TV+ service on me. No thanks. Back to the home screen. Badge is gone.

But that has no effect on the Mac side. AppleTV app in dock is still stubbornly showing a badge. With no apparent way to get rid of it. Argh.

This is really annoying. To me a badge signals I need to deal with soemthing my system is trying to tell me. My muscle memory has been trained to notice badges. Now I have to deal with the fact that my Dock is showing a bunch of bogus badges I should just ignore. All while still paying attention to not ignore badges that still have meaning (such as new email) and react to those. Tell me there’s still people at Apple who realize this is really bad UI. :disappointed:

So if the macOS build number is 19E287 that would figure.

Just to correct or add to this I see that the recent 2020 13" MBP shipped with 19E2265:

I don’t think the Mac would let you install the wrong one anyway.