How can I turn off Catalina nagging?

I’m taking the advice of numerous Apple gurus and postponing the installation of Catalina. Now, how can I turn off the constant prompting of the System Preferences > Software Update for Catalina, without turning off the other notifications?

1 Like

There’s been some discussion of this over in

2 Likes

Thanks for this. It really helped.

Betty

Some extra tips from Macrumours:

  1. QUIT System Preferences (If the next 3 steps are executed with System Preferences running, you could confuse things.)

In Terminal type these commands
2. sudo softwareupdate --ignore "macOS Catalina"

  1. defaults delete com.apple.preferences.softwareupdate LatestMajorOSSeenByUserBundleIdentifier

  2. softwareupdate --list

note: only use sudo for the --ignore.

1 Like

https://robservatory.com/

There are instructions there.

By Jove, I think I’ve got it! I knew I could get an answer here — thanks, everyone. And I rely on TIDbits to tell me about important updates.

I tried the sudo instructions and that didn’t work as each morning I got the same message. I just spoke to applecare and they said to go the system preferences, software update, advanced and to unselect all of the options under that. I’ve done that and will see what happens tomorrow.

Mine just stopped nagging on its own. I kept selecting the “later” option and did not see the message this morning.

I’m surprised they would make that recommendation. That will prevent you from getting updates for system data files and security updates which include the latest information needed by XProtect, MRT and Gatekeeper to protect you against malware and applications from developers that have had their developer license revoked. IMHO, that’s a pretty big hit to prevent a small annoyance.

-Al-

1 Like

See Rob Griffiths’ page at https://robservatory.com/remove-the-macos-catalina-guilt-trip-from-macos-mojave/.

This command stops the nagging alerts:
sudo softwareupdate --ignore “macOS Catalina”

This command gets rid of the red dot on the System Prefs icon in the dock:
defaults write com.apple.systempreferences AttentionPrefBundleIDs 0

The dock then has to be restarted with the command:
killall Dock

The alerts are gone and won’t come back. The red dots WILL come back so the last two commands have to be run again, either manually or by a shell script such as the one Rob describes (a launchd agent). I use a Keyboard Maestro macro. I’ve had this configuration for nearly two weeks and no problems noted–and no more nagging (though the bigger problem for me was the risk of inadvertently triggering a system update by fat fingering the Magic Touchpad, which requires significantly different “feel”/muscle memory than the older touch pads). Agree with Al that automatic security updates are a must.

As @alvarnell says, it will prevent you from receiving essential security updates. Do NOT deselect the “Install system data files and security updates” checkbox. I wrote about this a few years ago.

Note that since Mojave, you also must check, under “Automatically”, “Check for updates” in order for the system data files and security updates option to be available. That may cause the red badge to return periodically, but I have not seen it yet after running the Terminal commands previously covered and running a separate Mojave macOS update today.

And of all of this just because Apple put marketing ahead of its own users. Sigh.

Seriously, just give users a darn option to turn off the nagging already. Any number of people will resort to all kinds of steps (even such that Apple support themselves erroneously recommend) to get rid if the nagging which will open them up to all kinds of potential harm they do not realize.

The answer to that is not, “suck it up”. The answer is Apple needs to give their users an option to stop what is essentially an overly obnoxious sales pitch. Not reigning in Schiller here is basically equivalent to saying “we don’t mind customers putting themselves in harm’s way over this” plain and simple. It’s really just common sense.

1 Like

I’m not quite sure what the issue is. I turned off the checkbox “Install MacOS updates” in the Software Update pane of System Preferences and I am not getting nagged about anything. I’ve not had to issue terminal commands. Yes, there is a badge on the System Preferences icon on the dock, but I’m perfectly capable of ignoring that for as long as I need to. (I have one 32 bit app that is supposed to be updated in mid-November. I will probably wait a little longer than that anyway - I usually update MacOS around mid-December to mid-January most years.)

I just noticed that ironically, iOS 13 behaves exactly the opposite.

My 13.1.3 iPhone tells me the 13.2 update is available if I got to software updates and check manually. However, neither the Software Update menu nor the Settings app show a red badge. While I don’t want a red badge on my Settings app for an update I do not want, I’m surprised there is no badge on the Software Update menu informing me (at least until I tell it I’m not interested) that there’s an update available.

Feels odd that there’s kind of inconsistency between iOS and macOS on an issue that is not in itself actually technical.

My vague impression has been that Apple can control the appearance or non-appearance of the badge, at least in iOS. So there can definitely be updates available that don’t trigger the badge. My sense is that Apple triggers the badge after the update has been out for a while and they want people to install it.

Interesting theory. I’m anxious to see if/how they’d synchronize such a step with their other signal: no longer signing the previous release.

I know that the badge doesn’t appear immediately when an update comes out. One of the things I’m pretty sure it waits on is the background download of the update. That is–once the badge appears of its own accord, if you go to settings, the update will be downloaded and ready to install. But if you have no badge showing and go to settings, it will tell you that the update exists but offer you “download and install” instead of “install”.