Slow Internet browsing with Safari

About a month ago, I received my Mac Studio and got it all setup and running. It’s pretty damned amazing, I must admit. However, I’ve noticed that Safari often has browsing issues. For instance, I can enter a URL, and Safari just sittings there for several seconds or even minutes until I intervene. While waiting for the URL to load, I can switch to Firefox enter the same URL, and it loads instantly! Like so fast, I’ve barely taken my finger off the return button. I have AT&T Fiber, and get up/down speeds of over 1GB when I run any testing tool, so it’s not my network. DNS is pointed at my router, which is pointed at CloudFlare (

Safari does this slow loading business about 20% of the time, and it doesn’t matter what the URL is. It could be Facebook, The NY Times, Amazon, or California’s DMV. I run an app called Cookie, that clears my cookies and cache, on Login, browser quit, and app quit, so the cache isn’t the issue.

Any thoughts or suggestions?

I think this could be the exact same problem that I reported seeing with Safari ever since I got my new 14" M1 Pro MBP back in Oct 2021. It came with Monterey which I previously didn’t have on the 2020 13" MBP it replaced, so I wasn’t sure if it’s related to Safari, Monterey, or M1. And that still remains unclear to me although at least one report claims they experienced the issue also on Big Sur.

Do you have Private Relay turned on?

Are you using any ad blockers?

Yes, and yes … 1BlockrX is installed, but even with it disabled, I still have the weird slowness issue occasionally. And yep, Private Relay is also active. I’d forgotten about it. I’ll disable it, and see how it goes. Good call! Thanks.

A related issue… Safari had become increasingly slow to load my bookmarks & history. I had to wait for minutes (well, it seemed like minutes) before the favourites bar was available. This only happened on my iMac, not a Macbook.
I found some tips here:

In brief, in Safari Preferences, go the the Advanced tab, activate the Develop menu. Go to that menu and select Empty Caches.

1 Like