Safari 16

Originally published at: Safari 16 - TidBITS

Updates the Web browser’s Tab Groups feature and provides several security updates. (Free, various sizes, macOS 11/12)

1 Like

I can’t believe Apple still hasn’t fixed this bug where the “Bookmarks” button in the Safari toolbar still doesn’t go to bookmarks (shift-opt-b), but instead toggles the favorites bar (shift-cmd-b).

I reported it a year ago. :roll_eyes:

The ‘Customize Toolbar’ window calls the star icon a Bookmarks button. However, the tooltag that comes up when you pause on it says ‘Toggle the favorites bar’.

Perhaps this is the desired behavior. But then the “Bookmarks” label is wrong. Either way, this should be a simple fix. And yet, after one year, bupkis. :frowning:

With Safari 16 on Monterey, I’m seeing a new problem. Happened 3 times today. I’m browsing and suddenly it loses Internet access. I check a bunch if different sites, and can connect to none. I’m streaming Apple Music, however, so my general Internet connection is good; it just seems to be Safari. Fortunately I’ve been working in grouped tabs, so it’s easy to quit and relaunch and be back where I was, but all 3 times after I quit and relaunched Safari, all the sites were immediately available. What’s up with that?

Have you tried this?

Sys Prefs > Network > Location > Edit Locations… > +
Create a new location, select Done, and then hit Apply.

Stick with that new location and see if while using it Safari stops spontaneously losing network connections.

Simon, thanx for the suggestion. No, I hadn’t, so just went there, but didn’t know what to add. I left it at its only setting: Automatic. BTW, maybe relevant that in Safari Preferences > Privacy I’ve selected Hide IP Address from Trackers and Website.

You add by hitting the plus button at the bottom of the list that pops up once you select “Edit Locations…”

Indeed, I know how to add. Just don’t know is what to add. ―Ken

Doesn’t matter. You just need new a location. It’s about testing the “network reset” that entails.

Okay, done. Don’t see how this changes anything, but will be watching for subsequent outages. BTW, when I entered a nonsense string, the green indicator turned orange, and the message said that I wasn’t connected to the Internet and had no IP address. That’s when I last wrote. This time, I went ahead and Saved, and all seems normal with new location string. Thanx for the suggestion, Simon, but I think the problem is related to unfixed bugs in the tab group feature, which still has some odd behaviors.

Could it be iCloud Private Relay?

Thanx for jumping in, Adam. I guess it’s possible—who knows?—and I did have it turned on, but the possible issues they list—“Some websites may have issues, like showing content for the wrong region or requiring extra steps to sign in.”—don’t seem to apply. I’ve now turned it off. We’ll see.