Problems with my external backup drives - anything I can do?

This seems to have been getting worse lately, and now it’s gotten so I can’t use two of my WD external hard drives. My Mac is a late 2013 MBP running Big Sur, 11.2.1 with 16 GB RAM and an internal 512 GB SSD.

Both backup drives are 1 TB drives, a few years old. Maybe more than a few years. Newer than my MBP though.

One is being used for a Time Machine drive, and the other split into two volumes (1) for a CCC (Carbon Copy Cloner) cloned daily backup and (2) a smaller partition for BackBlaze cloud backups because there wasn’t enough space on my internal drive for the miscellaneous space it needed to process files.

Lately both Time Machine and CCC backups were often not completing. I could restart and then get backups again for a few days but it seemed unreliable.

Right now I can’t get backups with either.

I decided to use an SD card for the BackBlaze extra partition since this Mac has an internal SD slot and I wasn’t using this SD card for anything else. So I reformatted the SD card and that’s fine. Backblaze is up-to-date.

Since I didn’t need the extra CCC drive partition for Backblaze, I wanted to erase the entire drive and start over again clean. But even in recovery mode I can’t mount everything on that drive, so I can’t erase it.

I wanted to start clean with the Time Machine drive also, but I can’t mount it or erase it now either.

It’s possible that both drives have gone bad, but it seems like a coincidence for them both to go bad at the same time.

It’s not the hub, because I have an external SSD connected to it with my large Photos library on it and it’s working fine.

It’s not one or the other WD drives interfering with the other because I tried just mounting one at a time and leaving the other disconnected. That doesn’t work either. And I tried different hub slots.

Right now my backup situation is that Backblaze is working and up to date, so I can restore from there as needed. And I have full iCloud service, including Desktop and Documents.

I plan on updating my MBP later in the year, so I went ahead and ordered a new 2 TB external hard drive which should arrive tomorrow. I’ll try formatting that and using it for CCC. My newer Mac will need a larger capacity drive anyway. If that works I’ll maybe get another drive for Time Machine.

But can anybody think of anything else I can try?

Thanks.

Hey Doug…

I would unplug everything from the Mac then plug one of the drives directly into it. If it works… I would not blame the hub, but it can help you isolate the issue.

If you have multiple cables that match the ones the drives use, label them, then swap them out and see if that makes a difference.

Make notes as you go along so it’s easier to track what you did, what worked and what did not.

Cheers,

Dave

1 Like

Drives have finite lifetimes. Old age and failing can be detected by viewing SMART parameters. Apps such as SMART Utility and TechTools Pro can test and display these. Disk Utility does not. Replaced blocks and CRC errors most often indicate a failing drive, which may be your problem. Get a SMART-capable utility to check your drives.

Disk Utility or (Terminal command) diskutil should be able to erase a drive without any volumes mounted. In Disk Utility:

  • Go to Disk Utility > View and check Show All Devices.
  • Select the external device (Media) to be erased.
  • Click the Erase button.
    Use of diskutil is left as an exercise for the daring user.

Thanks for the replies people. I finally was able to erase the disk and create it new (CCC 2021) but CCC reports the disk is bad and disk utility’s repair also report errors on both disks. I will also try to directly connect it but I don’t have an extra cable. The new WD external drive is arriving this morning. So that will be another test.

Thanks,

doug

Hmm… Hmmm… Just before I took the newly reformatted CCC 2021 drive and connected directly to the MBP’s only open USB slot and CCC is backing up without complaint. Quickly too.

  1. Did I waste money on a new 2 TB drive? It’s coming this morning and it’s from Amazon so easy return if I want to send it back. Of course I am planning on upgrading to a 2 TB MBP later this year (my MBP is 8 years old now!) so it could come in handly.

  2. Why is my external SSD that I use for my large Photos library working just fine via the hub?

  3. I guess I’ll disconnect the CCC backup drive after it’s done and see if the Time Machine drive is actually still working when connected directly.

If so, then the problem does, in fact, seem to be hub related. Somehow. Like maybe the hub doesn’t work well anymore with multiple things connected?

Hmm… hmm…

doug

Mechanical drives generally use more energy compared to flash drives or SSD’s so your hub may be not providing enough power for the WD’s to work properly. But as another poster said, you should check the SMART status if possible. Some cables that look fine can also cause problems as I found out once. I would keep the new drive and make another backup just in case.

1 Like

I’ll try to check the SMART status - as soon as CCC is finished with the cloning. It’s been going about 2 hours so far and I think it’s about 2/3rd done now.

I wonder if I should get a new hub in the meantime. It looks like the late 2013 MBP retina only has two USB 3 ports and I have 3 external drives: the SSD for PhotoLibrary, Time Machine and CCC.

I’m doing printing wireless these days. I used to have my printer hooked into one of those ports.

Thanks.

I’ve always found USB hubs to be unreliable with hard drives (and often with printers), even if both the hub and the drives provide power. They tend to give me plenty of unexpected ejections with large flash drives, too. The least bad I’ve found is a 45 watt 7 port USB-3 hub, but even it gets squirrelly with more than two drives attached. The pre-plague street price was $27 and I’d happily buy another if I could find one, but It’s now either discontinued or hard to get due to plague constraints. The few I’ve seen have had scalper prices and/or were at unreliable vendors (aka amazon).

A friend once did some poking around with hubs, and he discovered 4 different kinds of specifications: press release specs, technical specs, what the hub tells the computer it can do (e.g. how much power it can supply to a port), and what it can actually do. All of which can be different for the same hub. Many cheap hubs tell the computer that they can supply a given amount of power to each port, when in reality it can supply a max of that amount of power total spread out over all of the ports (on a good day).

1 Like

Interesting. But it’s curious that the hub has been running just fine for years now.

CCC finished ok. But then I tried to connect the Time Machine HD to the USB port and it didn’t seem to load. On top of that Disk Utility isn’t showing any volumes, even though the external PhotoLibrary is there.

I guess I’ll try to just restart.

Any electronic device can go bad over time and with hubs, it’s hard to tell. Some hard drives require more power than others but usually have a separate power supply. Some of the smaller ones will often include an additional cable for USB power as the hub itself cannot power that drive adequately. You never mentioned what type/brand of hub you have. Does it have a separate power supply? Also, that power supply could have an issue not the actual hub.

I sometimes have to do an SMC reset with my Macbook because the USB-c port becomes unreliable and it cannot access an external drive:

I have three WD 2 TB drives attached to my 2018 Mac mini; one for the daily backup, one for the weekly backup and the third drive is used for Time Machine. I used to have very similar problems to Doug’s with all three drives where they would suddenly get corrupted and become completely unusable for no reason at all.

  • I used to unmount the drives (other than the Time Mchine drive, of course) when they were not being used. That seems to have created more problems. Now the drives are always mounted.

  • I tried apps such as Disk Drill, TechTool Pro, Drive Genius, etc. They can be all set up to run in the background to check the status of your drives and warn you if any problems are developing. They can also create copies of the directories to recover any data if necessary. They are all a big joke, putting it mildly. None of them issued any warnings before the drive failure. I stopped using them altogether. Perhaps, they will work fine with HFS formatted drives, but APFS is a whole different ballgame. If Disk Utility cannot recover or fix your drive, nothing else can.

  • I also switched from Catalina to Big Sur.

I cannot tell you which one or all of the above methods helped with my problems. All I can say is I have not had any problems with my external drives for the last couple months or so. I’m keeping my fingers crossed.

The hub I have does have an external power supply.

Since the Time Machine backup finished successfully (several times overnight) and since the CCC did as well, I’m going to return the new 2 TB WD drive that arrived yesterday. When I get my new MBP sometime later this year it’s hard to predict right now what kind of ports I will be using then anyway.

So right now the situation is this:

The hub has one drive on it - the external SSD used for PhotoLibrary. That’s a waste obviously, so I’m going to connect that small SSD to one of the USB ports by itself.

Then I’ll try to run both external WD drives (Time Machine and CCC) from the hub and see if that works without the SSD connected. If not, maybe the best thing is to get a new hub next?

Thanks.

There has been a lot of discussion on this thread about the power draw of external USB hard drives on USB hubs. So, my question is if the drive is directly powered via its own electrical plug, does it also stress the hub?

1 Like

FWIW, my 2018 Mac mini, running Catalina, also has three external drives attached. One Time Machine and two clones. The clones are unmounted, ejected and powered off when not actively in use. They are connected (along with 7 other devices) to a powered 10-power USB hub.

These are 3.5" Toshiba hard drives installed in Vantec USB 3 enclosures, each with its own separate power supply.

If your drives are bus powered, that could easily be an issue. I personally put zero trust in the ability of any USB hub (even mine) to deliver reliable power, especially when there are multiple high power devices (like hard drives) drawing from it. Which is one reason (of many) why I avoid off-the-shelf bus-powered drives for my backup solution.

Just now I turned off Time Machine automatic backups and unmounted that drive from the USB port. I connected the CCC drive to the port and it immediately mounted and CCC started a catch-up clone backup.

So the external drives do seem ok. And I will return the 2 TB external drive I bought in haste.

After this backup is complete I’ll try connecting just the two hard drives back to the hub after disconnecting the SSD drive which I’ll plug into the extra USB port.

Maybe the SSD drive, which I only added about 6 months or so ago, is interfering with the hub operation?

I’ve had to do this also with my 2019 iMac 5k. It’s important to note that the hard drive being connected to the USB-C port was also powered by a separate wall wart, not USB-C. I still had to do an SMC reset at one point where the Mac stopped seeing the drive.

Well, the current situation is:

  1. The external SSD for the Photos library works plugged into the USB port directly. All my photos and albums are synced and up-to-date.

  2. The Time Machine and CCC external USB drives seem to work after being reformatted, plugged into the hub (which has it’s own power supply) and that hub is using the 2nd USB port.

  3. Backblaze’s extra partition is running on a Transcend SD in the internal slot, nice and flush against the edge.

  4. Amazon’s delivery service is picking up the new 2 TB external USB drive that was delivered yesterday. This time the return shipping isn’t free but curiously it’s 500 yen if I drop it off at the shipping center or 410 yen if they pick it. So they’ll be picking it up tomorrow morning. The shipping box hasn’t even been opened.

I needed to restart my MBP again because Disk Utilities got into a state where it wasn’t showing volumes until I did that. Not sure what that’s about. But it was ok after a restart. (I have done more restarts the last two days than I have done all year.)

If things fail again I’ll rethink. But the more I think about “what might have changed” it seems the only thing really new since things started getting unstable was connecting the SSD drive to the same hub some months ago. Maybe the hub isn’t that great anymore or… I don’t know.

But this is a late 2013 MBP with a 512 GB SSD internally. It can’t even hold my Photos library anymore. When new M2 MBPs come out later this year I intend to upgrade to a nice, new MBP with at least a 2 TB internal SSD to last me another 7+ years. At that time I’ll see what ports it has and decide on my backup strategy again.

Thanks all!

I don’t believe there is any stress if the drive has its own power supply but since the OP mentioned that the drives were 1TB and only a few years old, I assumed they were bus powered which may or may not work well with a hub even if it’s powered. Since there were three devices plugged in, you could assume there is not enough power under some circumstances.

The age of your computer is not necessarily an issue if it does what you want it to. I have a 2012 Mac Mini and I was starting to run out of USB ports a few years ago. I wasn’t using the Thunderbolt port so I purchased a Kanex Thunderbolt to eSATA and USB 3.0 adapter and attached to that a Kanex 4 port Superspeed USB hub with power adapter. I have a combination of bus powered Toshiba hard drives and an old printer connected. I’ve never had a problem with this setup. My computer USB ports are for my Blu-ray recorder, two external SSD’s and an old WD powered drive. One other drive I use for AIFF audio storage is a WD firewire. I do hope it works out for you whatever setup you decide to use.