Monterey hoses Internet

I just updated my 2019 27” iMac directly from Mojave to Monterey. The installation was working fine before the upgrade. The usual app incompatibility stuff came up, but something far more serious happened. I cannot connect to the internet either via Wifi or Ethernet. The machine gets an IP address but will not connect to the internet. I tried using my phone as a hotspot but the same issue occurs. Has anybody experienced this problem, and how did you solve it? I have a backup and I could restore but I’m hoping to avoid that.

When this happens after an upgrade, I usually go into the Recovery console, and “Re-install MacOS”. This harms nothing and often fixes the TCP/IP stack issue.

First off, always start by doing a full shutdown (power off), wait a few minutes and then power-on. I’ve seen network adapters get into a funky state from time to time and no amount of software can fix them until they are powered down.

If you’ve tried that to no avail, what do the rest of your network settings look like?

What are your DNS server addresses? Can you ping them? If you can, try to resolve an address from the command line using the host command and try to ping it:

> host has address has address has IPv6 address 2606:4700:3037::ac43:d539 has IPv6 address 2606:4700:3033::6815:17c7

> ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=56 time=16.785 ms
64 bytes from icmp_seq=1 ttl=56 time=16.332 ms
64 bytes from icmp_seq=2 ttl=56 time=23.912 ms
--- ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 16.332/19.010/23.912/3.471 ms

If your DNS servers are not working, double-check those settings. If you get them from your router via DHCP, make sure it is getting correctly getting them from your ISP. Check your ISP’s support web site (with another computer/phone, of course) to make sure you got the correct addresses.

If your ISP’s DNS servers aren’t working right, try manually configuring an alternate server, at least temporarily. Like Cloudflare or Google public DNS.

If it is not a DNS problem, review your firewall settings to make sure nothing there broke. If you are using a third-party firewall package (like Little Snitch), try temporarily disabling it. You might need to install an update (e.g. Little Snitch 5.3.1) or review/relax some of its rules.


After restarting in recovery mode, running Disk First Aid, I am now able to access the internet on pretty much every application except Safari. Not sure if that really did anything because it didn’t show any errors. Safari seems to work but will only load a page after a super long delay. Firefox loads the same pages instantly. My workaround will be to use Firefox until I can figure this thing out. I have uninstalled Little Snitch so I think I have ruled that out. Any suggestions greatly appreciated.

Glad to hear networking itself is working.

The long delays sound like timeouts. The browser is trying to connect to something that doesn’t exist. When it eventually fails, it tries again with some alternate connection mechanism, which works.

There are many reasons why this might happen, but my first guess would be that you’ve got some cached content (HTML pages, scripts, etc.) that are pointing the browser at a no-longer-valid data source. If you haven’t already done so, clear your cache and maybe also your cookies.

Also check if there are updates for any Safari extensions you’re using. If you don’t have available updates, try temporarily disabling the extensions to see if anything changes.

My internet is working well except for opening Safari on one iMac - very slow to load favourites menu & access history. Seeing David’s tip reminded me about clearing the cache and cookies. I followed the advice here and it is now “instant” loading.
I had accumulated more than 900 cookie entries. Note that sign-ins/password are stored in the Keychain app and so are unaffected (I hope).
Note also that you can clear the cache with a keyboard shortcut: Shift-command-E

Cookies generally store data used to maintain a login session. So when you restart the browser and return to the page, you’re still logged in. The cookie typically stores a token - some piece of data that is meaningless except in the context of the web server’s scripts - and not your actual login credentials.

The keychain stores your login credentials (e.g. user ID and password). Safari will use this data to auto-fill a login screen, so you don’t need to type them in when starting a new login session.

After logging in with your password (whether manually typed or filled from keychain data), the web server will send you a cookie to represent the new session. This cookie will maintain your session across browser restarts until it expires, at which point the site should present you with a new login screen.

By blowing away your cookies, you will be asked to re-log-in to web sites that require it, but if your passwords are stored in the keychain, then Safari will fill in the form for you.


So far I have deleted cookies and cache from Safari, tried to disable the only installed Safari extension (1Password) and reinstalled the OS using Recovery. I thought I had uninstalled Little Snitch (I used the uninstaller!) but a search with Find Any File turned up a bunch of detritus which I deleted (that involved disabling SIP to delete the kernel extension). NO RESOLUTION. Safari is still bunged. I can’t change any of my iCloud settings in System Preferences because it won’t connect to apple’s servers to let me log in. By some miracle Apple Mail actually works. Getting ready to pull my hair out…

That sounds like a DNS problem. Everything else is using the DNS set in Network System Preferences (either set manually or provided by your home router) but I think Firefox now uses DNS over HTTPS by default which connects to an entirely different server for translating host names into the correct IP address. Try using a different DNS, one Devid C. suggested.


It turned out indeed to be a DNS problem. I added to the DNS server list and problems are solved. Thank you to all who commented. Now I just need to figure out why all the rest of the devices in my house work just fine…


This has been an ongoing problem for me with a VAVA USB hub with an ethernet port. It seems like three times a week I need to power-cycle the VAVA hub. (I just moved the ethernet adapter to an Anker hub in an effort to avoid the problem. However, the Anker hub is daisy-chained off the VAVA hub, so now I won’t know which one to reboot.) I am happy that it’s a relatively easy fix.

If I recall correctly, the problem started for me about the time I installed macOS 11.5.1 (I skipped 11.5) and continued through 11.5.2, 11.6, and 11.6.1.

I had a safari problem during the Big Sur betas. It seems I got a bad Dylib somewhere in the process which would cause safari to crash, a clean install fixed it and got rid of some other issues. I recommend a clean install with every major is update (bigsur to Monterey, especially if you jump forward more, bigsur was first to lock down the os into a separate partition). I have my files all using the cloud, so backup/restore is a breeze, and I only download fresh copies of applications. Scammers and hackers are out there, just sayin

If it’s a DNS problem, compare this computer’s DNS addresses against what other devices in your house are working. If they differ, then there’s your problem.

If at some point you manually added DNS server addresses, then they will override any automatic (via DHCP) addresses. If your ISP changes its addresses, you won’t see the changes.

Try going to the computer’s DNS settings screen and delete every configured address (after writing them down so you can put them back again if you need to). This will tell macOS to only use automatic addresses (assuming it is configured to get its settings via DHCP).

If your computer is not using DHCP for network configuration (manually configured), double-check your addresses against the ones your ISP says you should use, or just use the one(s) that your working devices are using.

David C. all devices in the house were set to use the same (default) DNS server. Nothing set manually. I am using an Orbi system. In my case the DNS server is the router address Every other device in the house works perfectly. On the upgraded computer, Safari and iCloud services (including App Store) didn’t work, but Apple Mail and Firefox did. Occasionally Safari would connect to a page but it was inconsistent and usually only succeeded after a several minute delay. I had no trouble connecting to other computers on my home network; it was only the internet that was a problem. It was only after manually adding a DNS server on the offending computer that the issue was resolved.

I don’t think my problem is related to this one but I’ll pass it along anyway. I have a 2014 27" Retina iMac. It ran Big Sur for many months but with a number of minor problems. I used a VPN from Cloudflare and after an update I could not access the Internet. Other devices worked fine.
I reinstalled the OS without success and after hours on the phone with Apple Support I decided to run a clean install, the first since buying the machine. I’d been planning to do this for some time so I knew the steps. I decided not to install from Time Machine in case the problems were there too. Reinstalling apps, resetting all preferences and options, reloading all data, etc. etc. took a couple of days. The result was complete success, all the Big Sur ‘bugs’ vanished (I did not reinstall Cloudflare VPN!).

Monterey is not supported on this machine so I may buy the new Apple silicon 30" iMac when it is launched next year. At least I can use Time Machine confidently for that.

It doesn’t help much…but I’ve got 2 Monterey laptops…one M1 and 1 Intel that are both working fine. Maybe try creating a new network location and set up networking from scratch?

I’m running Orbi mesh routers as well…the ax model.

If you have IPv6 enabled, you might try disabling it temporarily and see if your issue is resolved.

Check that your Safari Bookmarks aren’t in an infinite loop. EVERY time I try to use iCloud to sync my Safari bookmarks, it generates a clone, which gens a clone, etc. This means the Bookmarks,plist file is over 10MB (on a GOOD day) and takes FOREVER to load. To cure, turn off Safari bookmark syncing in System Preferences and delete the huge file from ~/Library/Safari

Special thanks to Neil Laubenthal for coming up with the fix. I created a new Network location and now everything works fine. All this voodoo really confounds me. Oddly enough, prior to OS X I could troubleshoot pretty much anything on a Mac. In the old days I even had an old PowerMac with dual ethernet cards running router software to distribute internet to all my devices at home. Now I seem to stumble over the smallest things.

I learned from somebody on a list years back that leaving network location set to Automatic was not advisable but instead to create a variety of named locations depending on your needs. Don’t remember the details of exactly why it was ill advised though. So…I can only take credit for reinventing the wheel from somebody else’s solution.