Monterey hoses Internet

I remember having heard that same advice too, a long time ago.

But truth be told, I’ve never had it set to anything but automatic and I have never seen any trouble from it. I prioritize interfaces (at work I want it to always use Ethernet when plugged in, tethering is always last option, etc.). I do, however, always insist on setting up proper DNS entries on any router I configure. I’d never trust anything I get fed default by an outfit like Comcast. :stuck_out_tongue:

I never noticed any troubles from it either…but wherever I got it from detailed some issues that were…more than anecdotal but less than statistically proven…so I made locations and used them.

Have you done the obvious, e.g., restart the router and modem and reset the ARP table on your router? In addition, I’d flush the DNS cache on your Mac. I’ve upgraded my three Macs to Monterey and haven’t had one issue. One of mine was also a 27" 2019 iMac with an external drive as the boot device.

Like @fellwalker57, I had internet problems (exactly mirroring those described by @toxdoc) after upgrading (in my case from Big Sur to Monterey) while using the Cloudflare WARP VPN. After much frustration, I remembered that it was installed, turned it off, and all troubles were resolved.

Taking a page from @neil1, I just now created a new Network Location, manually changed my DNS from that provided by my router (which ought to be, but who knows for sure!) to, and turned Cloudflare’s WARP back on. No internet problems at all!

So, not entirely a scientific A/B test, but it looks as if WARP and the OS together can get confused if a DNS server other than Cloudflare’s is used…

bocaboy I’m glad you have had no issues

Pleased to see that those steps resolved the issue for you Erik. Unfortunately, when I tried them after my internet problem they did not work on my system.
Nevertheless, I am pleased that I was forced to run a clean install on the iMac, the first in at least 8 years. Before I did this Airdrop did not work, I could not sync audiobooks from my iMac to my iPhone, and my Magic keyboard behaved very strangely when logging on. All these problems went away with the new install. I still use for DNS but have not had the courage to reinstall Cloudflare’s VPN. Instead I’m using Hotspot Shield VPN which is included with my Dashlane premium account. So far, so good.

1 Like

I tried all of the solutions here, but none of them fixed it, although the symptoms (Safari and iCloud couldn’t log in; Chrome fine); turned out it was Cisco AnyConnect that was the problem, posting here in case someone else has the same problem.

Thanks for the update. VPN software can cause all kinds of strange problems, especially when it’s a corporate-access VPN, because all network access will get filtered according to your corporate network policy.

For my employer, all traffic not aimed at devices on my LAN (like printers) is all sent through a corporate proxy server where the requests and replies may be allowed, blocked or modified. When the VPN is disconnected, networking returns to normal.

That makes sense - the pernicious part of this particular software is that it blocked traffic even when it was disconnected!