Microsoft Teams frustrations

I seem to be chasing my tail trying to use Microsoft Teams. For numerous reasons I use Firefox on an iMac running Mojave.
A few months ago when I received an email with a Teams meeting invitation I simply clicked on Join Meeting Now, which loaded an MS page in Firefox. This then asked if I wished to continue with the Teams app. I selected this and Teams loaded and prepared me for the meeting.
In the last few weeks Firefox gives a message that it has failed to open Teams. I don’t know what changed.
So I tried the alternative of entering the Meeting ID and password directly into the Teams app. I cannot find a way to do this with Teams on the Mac.
Online advice says go to the Teams Calendar section and there will be an option “# Join with an ID”. This does not appear for the Mac Teams app. Or does it require a paid Teams subscription?!
My only option at the moment is to copy the link from the email and open it with Safari - which asks permission to open the Teams app and does so successfully. I suspect that macOS or Firefox is preventing this when I try to open the link with Firefox.
BTW - I am reluctant to use Mojave Safari because it lacks security updates so only use it when I am desperate.

Check to see if Firefox content blocking is causing the problem.

It doesn’t seem to be blocked. In any case, I will try clearing the caches in Firefox.
My main issue is the apparent inability to directly enter the meeting ID and password in the Teams app for Mac (“free” version).

I was curious about what was going on in your situation, since I’ve been able to access the “# Join with an ID” button in my Mac’s MS Teams client’s calendar view using my paid Microsoft 365 Business account.

A few days ago, I logged into the Teams app on my Mac using a basic, free Microsoft account I use for testing purposes. The account has no associated Microsoft 365 subscription nor any add-ons like paid ad-free Outlook email.

When I did that, Teams behaved as you described: there was no “# Join with an ID” button in the calendar view, contrary to Microsoft’s support page.

Today, I happened to be sitting in front of a Windows 10 machine, so I tried logging into the Windows Teams app using the same free Microsoft account. With the Windows app, I was able to see the “# Join with an ID” button and sign into a meeting.

Here is where it gets interesting: I then went back to my Mac and signed into the Mac Teams app using the free account, and now the “# Join with an ID” button did appear!

I don’t know if the problem was a Mac-specific bug that was fixed in the last couple of days or if logging into the Windows client somehow changed something with the account so that it worked on the Mac client, but the problem did go away on my machine.

You might give it another try on your Mac. I’d make sure to be on the latest version of Teams, then I’d try logging out of Teams first, quitting Teams, and then deleting the Teams cache before trying to log back in. If that fails, maybe you could see if logging into Teams on a Windows machine would clear the condition.

FWIW, the version of Teams on my Mac currently is version

Thank you for your experiments and information. I have my next weekly meeting later today so will try the tips before then.
As I indicated in my post, I have reported this apparent bug to Microsoft. Maybe they fixed it quickly … but then again!

Clearing the Teams cache (actually deleting the Teams folder from ~Library/Application Support/Microsoft ) worked - thank you.

Update: Spoke too soon! The Join with an ID button has appeared but when I enter the meeting ID and password it opens Firefox instead of joining with the Teams app so I am back to square 1 (Teams is not supported in Safari or Firefox).

Interesting. It’s a bit of a shocking result, actually, but I see it, too. I’m going to file a support request at Microsoft. It may be worth doing the same on your side, too.

I made the mistake of an agreeing to a Microsoft Teams meeting and I simply could not connect with my MacMini running Monterey. It said it would not run under Firefox, then it started asking me to enter the password for various of my email accounts, but it could not connect with the Mac Keychain. This went through m personal account, and two of my Gmail accounts with no joy and the clock ticking. It asked me for my Skype account, but same password problem. I said the hell with it and called in once I found the number. This morning I found a Microsoft site that said “Firefox, and Safari, don’t support Teams calls and meetings.” It offered some work-arounds, but that tells me all I need to know. I have been able to make Teams work a few times, but this looks like Teams is a lot more trouble than it’s worth.

It seems that they want us all to use Chrome - which I find very creepy.

Or another Chromium-based browser, like Edge. I suspect Brave would also work.

Or you could install the Teams app. You need a Microsoft account to log in with, but if you have a Microsoft 365 account, that should be enough.

This whole discussion started because the Teams app could only connect to a meeting if it is launched via a browser.

I did wind up installing the Teams app, but I didn’t succeed in getting any passwords approved – including the Google ones – so it didn’t do any good. Teams did not succeed in finding the passwords linked to my emails. I couldn’t even open up my Skype account, perhaps because I had not maintained it for a while.

If you’re joining a meeting by clicking on a link (or pasting a link into a supported browser), Microsoft still says that you don’t need any account to join the meeting.

I just ran a quick experiment using my business account to host a Teams meeting on one Mac. I started a meeting using the Teams app on that Mac and shared the meeting link via email to an email account that is not associated with any Microsoft accounts. I opened that email on another Mac and pasted the URL into private windows on Chrome, Brave, and Edge.

I was able to join the meeting from those browsers without entering any accounts or passwords. The procedure was exactly what was detailed in the Microsoft support link I shared above. This is the screen that appeared at Step 4 (“Join now”) of the process:

1 Like

Microsoft says that Microsoft teams doesn’t work in Firefox or Safari. Microsoft Teams meetings on unsupported browsers - Microsoft Teams | Microsoft Learn The last time I tried to open a Teams invitation my Mac opened Firefox (my default browser), and then directed me to downloading Teams. I tried that and got hit by requests to log in that did not find my passwords in Keychain. At that point I ran out of time to connect, said the hell with it and used the dial-in phone number.

I have gotten Teams to work a few times in the past, but their updates seem to break things. I don’t know what I’m doing wrong, but for now all I can say is it just doesn’t work for me.

I will cave in and try installing MS Edge but won’t make it my default browser. This means I need to copy and paste the URL from meeting invitation into the browser to proceed but I am OK with that.

This ongoing farce does not look good when trying to do business. It seems that at any time an update will break Teams on a Mac and I cannot join a meeting.

BTW - if you use Skype make sure you have updated it before trying to connect as the app will likely demand that you download an update.

I definitely sympathize with everyone who has been having issues with Teams. I hope it is clear that in no way was I intending to be critical of anyone.

If you don’t use them almost every day, there are enough quirks with Teams (and Google Meet and others) that it is hard to be confident that they will work without headaches. Microsoft in particular has used so-called “dark patterns” to “encourage” people to create Microsoft accounts in many of its products, even when they’re not strictly necessary.

Out of the major players, Zoom seems to be the only one that has figured out the usability enough to work reliably for most people, even though it’s far from perfect. Everything else seems to have default interfaces that are a little too complex or that have too many options, hidden or otherwise.

I use Safari as my default browser. I have also enabled the Develop menu in the menubar via Safai>Setting>Advanced. The first item under that menu is ‘Open Page with…’ which lists all browsers installed on the Mac. I find that to be a more convenient way to open URL’s that don’t work well in Safari.

1 Like

My understanding is that Teams works in approximately the same way as Zoom, WebEx, and the other providers in this space. Meetings can be joined either using a stand-alone application (available for free) or by using an instance of a web application (requires no local install, but depends on browser features and limitations). Generally speaking, I have found the stand-alone applications to be more reliable.

If you have the application installed, any browser should handle a meeting URL by giving you a prompt to open the application and then passing the meeting-specific identifiers to the application. (Sometimes the web page asks you to click an additional button to open the application and sometimes the page gets the OS to present a dialog, but at least in my experience with Mac OS/ iOS/ iPadOS, there’s always a confirmation of some sort).

Processing the URL and passing identifiers to the application is a very minimal task, and generally any browser can handle it–I’ve never had issues with Safari/ Firefox/ Chrome failing to process meeting links this way.

The place where browser compatibility is an issue is when you’re using the web application in a browser window. The web application may not have all features working properly in all browsers, and there’s kind of an extra layer of complication in providing microphone/ camera access to a website within the browser rather than just providing that access to a standalone application. This is particularly true with Teams, which is not just a conferencing application but also does messaging, telephony, calendaring, and who knows what else.


Excellent tip! It even works with browsers installed in Windows virtual machines in VMware and Parallels.

Generally when I enter a meeting, I start by clicking on the invitation, which opens Firefox which, in turn, opens the stand-alone application. With Zoom, it always works, although once in a while it requires a Zoom update.

With Teams that results in a required installation of a new copy of Teams, which is where I get into trouble because the stand-along Teams asks for me to log in (which I don’t think should be necessary if it properly processes the invitation message), and cannot find my password (which should be in the Keychain). As I recall, this always pops up as a Google inquiry, as if Google is doing the processing, although I usually do not use a Gmail account. (In the last fiasco, I used an organization email run by Google, which may have contributed to the confusion, but mostly I use my personal domain.)

My bottom line is that Zoom is solid and reliable. It may help that I have a paid account for making outgoing Zooms, but it worked well before I added the paid account last year. On the other hand, Teams is almost inevitably trouble. Perhaps it’s that I don’t have a an Office365 subscription, although I do have a paid nonsubscription copy of Office. More likely, Microsoft views it as mainly used by people working in the same company and doesn’t care much about other users.