Microsoft Teams frustrations

If you have a Microsoft account, you should have access to the free tier of Microsoft 365 (web apps, mobile apps, limited OneDrive storage, etc.) which I think can be used to log in to Teams and attend meetings created by other people.

But I’m not completely sure. All of my Teams experience is on Windows, via my employer’s PC, logged in to my employee Microsoft account.

We have five Office 365 licences for our business but I refuse to pay extra for Teams because all we would ever use it for is virtual meetings - the rest of its functionality has no value for us. However since they started charging for Teams it has been a real nuisance and I cannot guarantee that it will work - sometimes it does and sometimes it doesn’t. I now tell people never to send me meeting invitations with Teams but to use Zoom instead, which works really well.

Installing MS Edge worked for me. I now have Edge in the Dock. I simply drag the URL from the invitation email onto that Edge icon. Edge opens and asks if I want to open the Teams app. Agreeing to this starts Teams and allows me to successfully join the meeting.
Edge is available for High Sierra up (I am running Mojave).


@mpainesyd I don’t know if this addresses your Firefox issue, but I noticed the following bug fix in the Firefox 117.0.1 Release Notes:

  • Fixed a bug causing links opened from outside Firefox to not open on macOS (bug 1850828)

I doubt if it will have any effect. The problem, as I understand it, is that Safari and Firefox do not have Chrome-related components that allow (limited - I hope!) control of your computer from the MS Teams app launching website. There are other websites around with the same limitations.
As I indicated above, I have installed Edge solely for the purpose of launching the Teams app. But even that failed on me the other day and I was forced to join the meeting with the Edge browser.
I am finding I need to try and join Teams meetings at least 5 minutes ahead of time to allow for something no longer working, or a forced MS software update.

I find myself stuck with another request for a Microsoft Teams call, and spent a while trying to get into Teams. It opens displaying my personal domain email in a screen asking me to verify my identity, which directs to my gmail address. I click on that by entering my personal domain email and says it will send a verification if it matches the email on my account, and nothing domes. Nothing comes if I enter the gmail address. I go back to the opening and have no code to click, so I click on “I don’t have any of these.” and I get “If you can’t access any of these, you need to update your security info at

I tried that and fell down the rabbit-hole of Microsoft’s all-Microsoft security system, which appears to rely very heavily on tracking everything you do on Microsoft products, none of which I use but Office and (as little as possible) Teams and Skype. Are we not be using enough MS products to be considered secure?

FWIW, I recently had a Teams meeting (with my HOA).

I couldn’t connect to the web-hosted meeting via Firefox. It couldn’t find my microphone, which is kind of strange, since other conferencing apps have had no problem with this.

But I was able to install the Teams app on my Mac. Teams won’t let me log in with a personal Microsoft ID (the app’s name, “Microsoft Teams (work or shool)”, made that pretty clear) but I was able to use it to connect to a meeting created by someone else.

I was able to click on the link from the e-mail invitation, and Firefox launched Teams (after granting it permission to do so). I was then able to participate in the meeting. I think I should also be able to type in the meeting ID after manually launching the app, but when I tried it that way, the password I received with the invitation didn’t work.

I finally managed to figure out how to get into Microsoft Teams. It was a quirky thing; MS shows only the first two letters of a gmail address, and I have two with the same two first letters, so I used the wrong one. So, I thought briefly, I might have solved the problem. The new version of MS Teams I had downloaded earlier today was Teams Classic, which MS retired in April. (Why they still have it posted for downloading is an interesting question.)

But this gets even “better.” I clicked on the download offered in the announcement that Teams Classic has been retired. It downloaded another copy of Teams Classic. I checked another place on the page, I downloaded yet another copy. I tried to contact Microsoft from the contact link on the page, but two people have been ahead of me on the “live chat” for half an hour, and it’s clearly not “live”.

No sign of MS Teams on the App store, so I searched the web and found a download page at I succeeded in downloading, installing and opening the file. I started to set it up, and was informed
“Personal accounts aren’t supported yet in Teams (preview)
To use your personal account, open Teams on the web.” and given a link to “Open Teams on the web” (Supposedly there are corporate versions, but I’m not going to go chasing that.)

I’m using Firefox, so that tells me " Hmm. Your browser version isn’t supported. Quickest solution? Download the desktop app." Around and around the circle goes. This may explain why others have been having trouble. This is truly amazing ineptitude from a company the size of Microsoft.

I have an appointment on Monday to do a test run on making a Teams connection with the person who has set up the interview.

I’m not sure which of the various Teams apps I installed, but here’s my about box:

Screenshot 2023-10-18 at 16.42.13

That’s the final new version I downloaded today, which Microsoft says does not work for an individual account. I don’t know if it would work if you got an invitation from someone else.

See my original posts back in June - up until around April or May Firefox successfully launched the Teams app, which allowed me to join the meeting. Then this sequence stopped working. I thought it was a problem with Firefox and tried clearing caches etc but this made no difference. So it seems to be a change introduced by Microsoft.
So my advice is, don’t rely on Firefox (or Safari) for joining Teams meetings.
I eventually acquiesced to the corporate giant and installed Microsoft Edge which I will only ever use for starting Teams meetings (or an increasing number of webpages that demand Chrome-based browsers).
Now I am running Ventura and my default browser is Safari, which means I have to remember not click on Teams link in emails. Instead I copy the link, start Edge and paste the link to open the Teams initiation page.
Regarding signing into a Microsoft account, see my experiences above. In short, using the Teams app on a Mac doesn’t let you join a meeting with a meeting ID and password if it is a personal account.

It does. As I wrote, I used it a week or so ago with an invitation from my HOA.

I could not log in, but I could use the link in the e-mail invitation to launch it and join that meeting.

I remembered your earlier comments about the Teams App having stopped working in the spring, which helped me understand what was going on.

My working plan at this point is to do a test run on Monday and see if Chrome allows me to do the interview on my Mac rather than on the phone, which was how I saved one interview. I have now have some hope that will work. I don’t want to get caught again wasting much of the time for an interview fighting computer problems.

I have other problems with Microsoft. I have a college alumni email account, which the college turned over to Microsoft to manage. That gave me two separate Microsoft accounts, and the resulting problems caused me to lose access to the alumni account. Microsoft’s security system has caused other problems because it hides the middle of email addresses when identifying them – and thus Microsoft shows me the same ABC… that I can’t tell apart.

I had my tryout call for Microsoft Teams today. I opened Google Chrome, copied the web link from the invitation, pasted it into Chrome and Microsoft teams and opened – and told me that the meeting number I had pasted in was wrong, please find the right one.

I went back to look up the invitation and clicked on the link again – and Firefox opened and asked if I wanted to open Teams in the browser (Firefox) or the app. I knew the app wouldn’t work, so I told it to open the browser version. Not only did it work, but the person I was calling started to see my face, at the same time I did the same thing, because neither of us had expected it to work. I don’t know if this ritual is required for it to work. Perhaps what you need is to have Chrome open in the background so it can open something that Teams requires.

In any case, I am passing my invocation along it case it might help you get Teams to work.

On Friday I tried the above procedure again for the real interview and it worked, although I had to click on the the invitation a second time after clicking somewhere else on the screen by mistake. So this works, but the whole setup of Microsoft Teams and Firefox on the Mac does seem a bit fragile. I suspect the key to success is having Chrome open to establish a connection with your Mac which Teams could work on Firefox when it was running in the browser.

Teams has descended further for Mac users. Microsoft has re-issued Teams as “Teams Classic” which refuses to accept my personal account and then crashes (Sonoma on an M2 Macbook Air). I have deleted it so it cannot be opened from a web browser (eg Edge).
Teams (New) “for work and schools” will open and not crash (this week!) but, again, will not accept my personal account login. However at least it does allow me to enter a meeting ID and password to successfully join a meeting.
Trying to join a meeting via a URL link does not work.

Have you tried the new teams app?
Download is on this page

This is really frustrating and seems to be Microsoft’s current policy for Mac users.

Microsoft’s pricing plans shows that Teams is available for personal accounts (including a free tier), but apparently, this is only using the Windows app (at least I’d assume so, but I haven’t tried it).

I’m not sure what their logic is here. It’s the same app (I think) for personal and business accounts, but maybe there’s a reason I’m not thinking of.

That sounds like a Microsoft ad!
Yes - as reported above I tried the “New” Teams. At least it doesn’t crash on my system. Not much else positive to say about it.

As best I could determine, the Teams app on the Mac is limited to “institutions” and will not run on an individual account. If you have to use (or attempt to use), you want to get the web version of Teams. You also can fall into outdated pages describing Teams on the Microsoft (or Teams) website. It’s a mess.