Massive login failures on only the first boot after a macOS update

(Adam Engst) #1

Does anyone else run into this problem? Whenever I update macOS on my 27-inch iMac, the first boot afterward is a disaster because the Mac somehow logs in before I enter my admin password and tries to open everything that was open before (I never select the checkbox to open previously open items after restarting, but I do have a LOT of login items). As a result, because my keychain is still locked, all sorts of apps and system processes ask for a password that they would normally get from the keychain. So I’m inundated by dialogs asking for my login password, perhaps 20-30 all told, and all sorts of things don’t work.

The only way to recover is to fight off all the dialogs—many just come back repeatedly if I click Cancel—and restart the Mac again. This can take a while, since apps are in a bad state when they can’t access password-protected resources and services, but once I managed to force the Mac to restart, it comes up perfectly the next time.

This has been going on for ages, and I always forget to ask about it because it only happens five or six times a year, but installing macOS 10.14.4 just reminded me of how freaking annoying it is. It’s only on this Mac, and I assume there’s some .plist that’s corrupt, but I haven’t been able to figure out what.

Any ideas?

0 Likes

(Bob Dahl) #2

I USED to see it on system updates, but no real password glitches. It just hung on any app that needed that keychain entry. It happened on (almost?) every upgrade.
I simply restarted via the on/off button, then it started normally and it continued doing any upgrade bookkeeping it needed.
Haven’t seen it happen much like in the past. Probably a few years. The hard restart always worked. For me. As far as I could see, anyway…

BD

1 Like

(Alan Forkosh) #3

I haven’t seen anything as bad, but I do see some flakiness after the auto-restart after a system update. I usually do a full shutdown as soon as I can and then power on the system. That seems to clear the issues.

1 Like

#4

G’day Adam

macOS Mojave on a 2017 27" iMac – the OS updates take an eternity with multiple self restarts; always ends up on black screen so I never know whether the update has finished or is still doing something. Like Alan, when I think it’s probably finished I turn the power off at the wall, wait a couple of minutes and then power up. Seems to have done the trick so far.

My sister has a 2012 MacBook Air running High Sierra. Did the security, etc updates last week and had exactly the problem you describe, followed by a load of error messages about the startup disk not being usable when she next turned it on. Booted into safe mode which seemed to work, shut down and did a normal start which worked. Then a message popped up saying the security update which she had just “installed” was available for installation. Still umming about whether to try again.

A colleague at work has a 2017 27"iMac running High Sierra. He has problems after every update. Boots OK into safe mode but cannot find the startup disk when booting normally. Always needs to get a tech in to reinstall the OS.

Cheers, Gobit

1 Like

(Al Varnell) #5

This has been normal behavior for some time. It auto logs the updating user in and locks the screen.

What I’ve been doing since that started was to quit all running apps except for System Updates (was MAS now System Prefs) before agreeing to reboot.

1 Like

(David Ross) #6

As Al said, this is normal. The update trys to return you to where you were. I find it best to do such updates from the admin account. At least with that I wind up in a reasonable place when it is done.

You DO have a separate admin account on all the Macs you work with? Right?

2 Likes

(Will M) #7

I’m completely ignorant about this (and you’ve made me afraid to install Mojave), but I have a question or suggestion. What if you held the shift key (that does boot into safe mode, right?) during the first restart? Do get the bong indicating that a reboot is starting, so you would know when to press the shift key?

1 Like

(Adam Engst) #8

Not arguing, but why would such an approach make sense? I can’t imagine the logic that would treat a restart after upgrading any differently than any other user-initiated restart.

No, I’ve always found running in a non-admin account to be quite annoying in my everyday usage.

This isn’t related to Mojave at all—it’s happened for years in different versions of macOS.

I’ve never tried what you suggest—a Safe boot—after an upgrade, mostly because it takes long enough to upgrade that I’m seldom watching carefully enough to know when to press the Shift key. It might be possible, but with what Al is saying about it doing an auto login, I’m not sure it would work. Have to try that next time!

To be clear, a second restart always clears things up. If you’re seeing disk errors or subsequent failures after the first one, there’s something else going on.

0 Likes

(Will M) #9

Understood. But installing Mojave would be an update to the OS, and therefore could (would?) trigger the problem.

0 Likes

(Adam Engst) #10

I can’t remember for sure if it happens after a major upgrade, but I doubt it because the Setup Assistant runs on the first boot after a such an upgrade. It’s all the minor upgrades afterward that are the problem.

0 Likes

(Jerome King) #11

I have similar but slightly different problems after a system update (or upgrade)
I have 4 User Accounts in addition to my personal Admin user account
I have to go to each user account (including mine) and clean up.

I always get the password quesiton but I check the later option and eventually everything gets up and running. But the first time in each UA is a (about) 10 minute

Makes me reluctant to stay current

That and the reported Google issues with 10.14.4 is keeping me at 10.14.3. Has the Google problem been fixed?

Jerry

0 Likes

(Al Varnell) #12

When this first came up, it was reported as a security risk in that in addition to logging the updating user back in, there was no immediate lock screen. Apple eventually eliminated the login, but brought it back a few updates later with an immediate lock screen in case the user had walked away from the computer during the update, which I would guess is fairly common.

I have never seen any communication from Apple to explain the logic of such a change, but it’s obvious they felt it was useful. Personally, I appreciated it as my older iMac with HDD took forever to login, so I was happy to have the computer immediately available for use as soon as I unlocked it.

0 Likes

#13

quit all running apps except for System Updates (was MAS now System Prefs) before agreeing to reboot.

In all three of my above cases everything apart from Software Update is quit before the initial restart.

No, I’ve always found running in a non-admin account to be quite annoying in my everyday usage.

Likewise.

(and you’ve made me afraid to install Mojave)

As Adam mentions, upgrade from one OS to the next seems OK – I’ve only seen the problem in the subsequent point updates. You’ll see in two of the cases I mention above, it’s happening in the point updates in High Sierra too. It may have but I can’t recall it happening in earlier OSs.

Cheers, Gobit

0 Likes

(Beatrix Willius) #14

I’ve never seen such a behaviour. My MacBook Air is used a test machine and so gets updated with macOS betas relatively often. Because at least one app blocks the update I tend to quit all open apps before an update.

0 Likes

(Will M) #15

Thanks for that clarification. I hadn’t understood.

I’m running 10.11.6, and I don’t recall having the problem with any of the incremental updates. Perhaps the problem is newer than my most recent update, or perhaps I’ve avoided the problem by logging in as admin (I’m normally in a user account rather than an admin account) before installing an update.

Does the OS require or expect an internet connection on the first boot after an update? My habit is to turn off wifi if I am not using it. I believe I have done this after the download was completed but before the restart occurred with no ill effects, but maybe I missed them and maybe things have changed.

0 Likes

(Adam Engst) #16

I’m guessing that these two techniques would eliminate the problem, since macOS wouldn’t try to be restoring a logged-in state with numerous apps right after the upgrade.

For my usage, an Internet connection is always necessary at boot for apps alone. Nearly everything I do requires connectivity, and while I can work on a disconnected MacBook Air in a few apps if I have to, I make a point of always being online.

0 Likes

(Kevin Patfield) #17

I don’t see this exact problem because I use FileVault so my updated system CANT boot until I’ve put in my password.

For the last few major releases MacOS seems to have made a totally misguided attempt (in my opinion) to make the update “transparent” by returning to the same screen as I started from. After half an hour with several reboots and maybe a firmware update this is just silly. Of course it’s not transparent.

By the way, another vote for using a non-admin account. It may be “annoying” but it’s great to know that nothing can modify my system without asking me first.

0 Likes

(crun) #18

do you have automatic login enabled? if so, turn that off and see if the same thing happens next update.

0 Likes

(Al Varnell) #19

Let me tell you in advance that it won’t make any difference.

0 Likes

(Simon) #20

The same is true for admin accounts. Anything that wants to write to critical areas such as /System, /Library, or /Applications needs to authenticate first.

0 Likes