macOS 10.13.4 Warns Users about 32-Bit Apps


(Josh Centers) #1

Originally published at: https://tidbits.com/2018/04/13/macos-10-13-4-warns-users-about-32-bit-apps/

Last year at WWDC, Apple said that High Sierra would be the last version of macOS to run 32-bit apps “without compromise.” The recently released macOS 10.13.4 takes the next step in that direction by alerting users the first time they launch a 32-bit app. Here’s what we know.


10.13.4 and Office 2011
(PaulBrians) #2

I upgraded to High Sierra 10.13.4 today and when I launched Word 2011 I got the alert that it needed to be upgraded for 32-bit compatibility, but to do so required me to enter my product code, which I did. But I got an error message saying it was an invalid code.

I examined the sticker on the disc envelope carefully—the code was correct. Clicking the link for help got me only to a general search-for-help page. Nothing specific to this problem.

Then further checking led me to a post that said Microsoft had ceased supporting updates for Office 2011 last fall.

It seems to me that instead of giving the “invalid code” feedback, the error message should instead have read “this version no longer supported” or something like that.

Anybody know a work-around?

Paul Brians
Bainbridge Island, wA


(David Price) #3

I am running High Sierra 10.3.4 and Word for Mac 2011 version 14.7.3. I haven’t seen any warnings (which, frankly, surprises me).


(Jerome King) #4

Comment 1. It took almost 3 minutes for my screen to populate with the “applications” that were seen. Probably partly due to the fact that I’ve “migrated” for over 10 years instead of doing a clean install. Hope to be brave enough to do with my planned new iMac

Comment 2. It doesn’t seem possible to “delete” a 32 bit application from the system manager screen. But where are these “application” files stored so I could track them down to delete?

Jerry Naples


(Adam Engst) #5

That will help some, but not completely. I did do a clean reinstall around New Years, and although I’ve brought back only apps I’m actually using, the list of 32-bit apps contained a lot of things squirreled away in Application Support folders and the like. And Downloads folders can have a lot of junk in them too.

A darn shame that you can’t delete or even reveal apps from here, isn’t it? The clumsy workaround is to click the app (or multiple ones) and look for the Location field in the description below. You can copy that string, switch to the Finder, press Command-Shift-G for Go To Folder, paste the string in, and press Return.


(Charles Jacobs) #6

Just to add to some of the confusion that this creates. Some applications that are 64 bit can be run in 32 bit mode from a checkbox in the get info window. A rather famous program that works this way is SheepShaver, the Classic MacOS emulator. When I checked my system profile, some interesting programs came in as 32 bit including some useful ones like Logitech mouse controllers.


(Jerry Nilson) #7

Hopeless that one cannot copy text in System Information or at least export it to Numbers/Excel - would be easier when talking about an issue like this … (but that holds true for much else like Contacts …).

Really lots of applications I cannot easily substitute, even if I bought BBedit it will take me years to work with html in the same speed as in PageSpinner (no trace of the developer since 2012, Jerry and also from Sweden like me). StyleMaster is much easier than any other css editor for people not working daily with css - a little unstable in version 5 but still works great. No need to upgrade to MS Office 2016 if only working in Word & Excel … Adobe CS 5&6 mostly works fine still and costly to upgrade. Fetch (the obviously best ftp client :wink: - knows Adam disagrees) needs to be updated. XLD - indispensable for ripping/converting audio needs to be updated. I still manage to use Peak LE 6 (but it takes a bit too much trouble now, but still better in some ways than other audio editors, and DSP-Quattro that I got (much worse) also needs to be updated, but maybe Fission or Audacity would be good enough for me now). Apple iDVD & iWeb will be the end for too (but not sure if they do work now). Free ruler is also a nice program, but likely there are substitutes. (Even the peculiar sidenote still works …) Guess there are many other special programs in special fields that might not be upgraded too. Airy needs to be updated. Cisco Webex? Dymo drivers? Many still use FileMaker 11&12. Incscape & XQuartz? iVMS-4200? Marratech? SnapScan for my S500? SolidWorks eDrawing?


(Jerome King) #8

Thanks Jerry for your message

I have so many “no” apps (not counting the duPlacates caused by my clone backups that I can’t plan on addressing the 32 bit issue.

I don’t expect any help from Apple :apple:. What is new?

Jerry Naples.

Jerry


(Al Woodcock) #9

Still running 10.12.6 and tried to check for the 32 bit APS. After clicking on “Applications” and after a wait I get a message “The plug-in did not respond quickly enough while gathering this information.” Any suggestions what to do to show the list of applications?


(Jerry Nilson) #10

Jerry - I plan to run macOS in a VMware environment if possible. They make it really hard downloading the macOS of your choice these days too – spent some time figuring out how to download El Capitan today, despite having 50 Macs from the Classic onwards next to me I could not find one where I was allowed to download El Capitan, but got a hint by some comment on the web. My main troubleshooting external drive partition is running El Capitan (a pretty good idea) and if one boots from that one is allowed to download the El Cap installer (already have a clean clone of El Cap, but wanted the installer).


(Diane D) #11

Jerry - which OS are you running? I’m on Sierra.

I love Fetch! I did use Text Wrangler for a while a few years back, but went back to Fetch.

I also saw Word and Excel in my list - I am running 2011. Is there a newer version that uses the classic menus vs that damned ribbon?

Illy CS 6 - I need to keep this forever as I do not agree with the subscription model. :frowning:

Ascent is another huge one for me, I am pretty sure High Sierra breaks it completely. (I import my workouts into it)

Diane


(@lbutlr) #12

You probably have at least 19 more months to plan. Every indication is that 10.14 will still be able to run 32 bit apps and that 10.15 (Sep/Oct 2019) will be 64 bit only.


(Bernard Frangoulis) #13

Yes, same here with Mac OS 10.13.3. Timeout with the same error message. Couldn’t get it to work!


(James French) #14

Thanks for this helpful article. I just checked my one year old MacBook Pro and only found a few 32 Bit apps. The only one that amazes me is Compressor (latest version) made by Apple. This is a pro app. Surely it is 64 Bit? If it is, any idea why it is incorrectly labelled?


(Hylke Tromp) #15

Rogue Amoeba announced a few weeks ago, that their Nicecast (32-bit) will not be supported after the end of 2018. The numbers of users is not enough for them to rebuild a 64-bit version from scratch.


(Jolin Warren) #16

Apple provides the link to download El Capitain on this support page:

The link is:

https://itunes.apple.com/app/os-x-el-capitan/id1147835434?mt=12


(Jeff Swart) #17

Thanks for all y’all’s info on this topic

re: Jerry’s “Hopeless that one cannot copy text in System Information or at least export it to Numbers/Excel”
You can print the SysInfo>Applications list (e.g., to a pdf) but, lord only knows how the sort order is determined; certainly there’s no relation to any of the sorting options displayed in the SysInfo window…
… knowing it isn’t as useful as a .csv, etc, but at least you don’t have to wait for the apps list to generate @ SysInfo…

re: link to OS X El Capitan installer. Thank you very much - been meaning to track that down for my aging MacBook Pro 17 (mid/late 2007)

… limping along w/ 10.11.6 w/ numerous “issues” I’ve been trying to resolve and hoping reinstalling the OS might help… to keep me afloat until I can get a new Mac…
… one such “issue” is being unable to boot to Recovery Partition or the Command-Option-R to boot into [macOS Recovery] --> Panic


(Jerry Nilson) #18

Jolin: That won’t help you much unless booted from El Capitan or having a computer that cannot be upgraded to High Sierra, but that can be upgraded to El Capitan … (and that is only a select few between 2007-2009 (who often have High Sierra presented as a possible upgrade to those computers too and one first realizes that it will not be installed when trying to install it)).


(Jerry Nilson) #19

Diane: 10.13.3 (I’m waiting to update my Carbon Copy Cloner clone before applying the 10.13.4) (High Sierra on the first Touch bar MBP 13"). It was long since I tested Ascent, but the other programs still runs fine and might well do so on the next system release too. Saw someone speculate that maybe 32-bit apps will only be problematic to run on new computers with new processors that does not support 32-bit … but in any case my guess is that Apple has simply not yet decided to which degree to support 32-bit apps on the next system. For now they only want to push as many of the current active developers as possible to upgrade their apps apparently.


(Jolin Warren) #20

I agree it’s not easy, but with the installer downloaded, it should be possible to make an El Capitan boot disk (e.g. on a USB stick), boot off that, and install El Capitan on the computer. Would definitely be a faff, but doable. There are articles about downgrading to El Capitan once you have the installer, if one does a search. I realise you’ve solved your issue for now, so this is by way of information for others.

Also, I was responding to your need for an installer to install El Capitan into a virtual machine. Wouldn’t it work for that?