macOS 10.13.4 Causing Installation Log Failures


(Adam Engst) #1

Originally published at: https://tidbits.com/2018/04/13/macos-10-13-4-causing-installation-log-failures/

If you’re running macOS 10.13.3 High Sierra, and you restart, it’s possible that you’ll see an Installation Log screen and an error telling you that the macOS installation couldn’t be completed. Here’s how to recover.


(Jeff Hecht) #2

You’re not alone, although my experience was different. I bought a new MacBook Air which was sold by MicroCenter as coming with 10.12, but was running 10.13.1 (NOT .3) when I got it up and running. It did that happily for several days until a couple of days ago, when I left it plugged in to recharge and was stunned when I opened it to find it was booting up an upgrade and supposedly would need 13 minutes before it was finished. It didn’t wait that long, but it came up in 10.13.4. Perhaps because I haven’t installed much of anything onto it yet, I didn’t see any problems yet, but I definitely had not set it to auto-update. Really not good, Apple


(@lbutlr) #3

I had this same problem on my iMac (2012) which has been acting oddly for a few months. I didn’t think too much of it an chalked it up as another mark against its aging issues.

I solved it by booting to recovery and running disk utility, which took awhile and fixed what appears to be some significant issues (something about the UUID not matching?) and since then its been fine.


(Doug Miller) #4

A few months ago, my mother-in-law sent me an email asking if she should update the MBA we bought her for Christmas the year before to High Sierra. I advised her to hold off; I had a Reminder set every month to decide whether or not to tell her to go ahead and try it. Finally, last week, I said it should be ok.

Guess what happened?

Over the phone I also had her try to reinstall from Recovery, and was plotting when or even whether I should make the 45 minute drive to pick it up and see if I could fix it if that didn’t work. But, as it did with you, reinstalling from Recovery worked fine.


(Laine Lee) #5

Did anyone experiencing the problem try the four-finger salute to reset NVRAM (hold command-option-P-R and wait for 2 or 3 additional startup chimes)? I’m pretty sure that some of these issues can be avoided by using the High Sierra 10.13.4 Combo Update, which can under most circumstances be applied to a qualifying target partition even while booted from another qualifying partition. There’s also a chance that a “mac os x install data” folder at the root level of the target partition could be errantly left behind during an installation and require certain some specific actions to get things working correctly again.

I think the Apple HT204904 article has some information about startup key combinations for reinstalling MacOS that are simplified to the extent of causing confusion. For example, if the installer finds what it considers a viable system on your target partition, it will not install anything older to that partition.

There have even been circumstances in the past where a supplemental security update could supersede the latest OS installer version and render the built-in system installer absolutely useless. In such a case, the only way to install was to hack the system version information on the target partition to make it appear to the installer to contain an older system version, or to perform a wipe and install (Archive and Install went away after 10.4 Tiger, if I remember correctly, but that’s good, because it was one of the most confusing and potentially destructive installation processes I’ve ever encountered).

Even if you’ve erased your target partition, you can’t install Sierra on an APFS volume. Also (correct me if I’m wrong), although you can nondestructively convert an HFS+ volume to APFS, you can’t nondestructively perform the action in a reverse manner, that is, convert an APFS volume to HFS+.


(Adam Engst) #6

No, I didn’t think to try that because the log was showing failures that sounded like they were related to the disk in some way — files not existing or not being able to create the files.

And just to reiterate, in none of these cases was I trying to update — I was just restarting to solve performance problems. So if there was an actual installation of macOS 10.13.4 taking place, it was kicking itself off, rather than going on my command.


(Laine Lee) #7

That’s what made me think of the “mac os x install data” folder, because I seem to remember some cases where that folder could be around for awhile and somehow be involved in startup problems later on. Anyway, I always try to reset NVRAM whenever a simple restart doesn’t work, because it’s pretty easy, and I’ve never (at least not when using recent system versions) had any significant complications arise from using it. It can be important to disconnect everything other than power and keyboard when performing it, however.


(13Parsecs) #8

I’ve seen this too on other Mac installs… quite a few long nights with my client base.

Could be some overlap/bug like the one in create install media.

I"m just spitballing here, from insights gleaned in ‘other’ resources, to whit:

This installer path "\.I ABootFiles\boot.efi " was changed by Apple

// OS X installer paths

STATIC CHAR16 *OSXInstallerPaths[] = {

L"\Mac OS X Install Data\boot.efi",

L"\macOS Install Data\boot.efi",

L"\macOS Install Data\Locked Files\Boot Files\boot.efi",

L"\OS X Install Data\boot.efi",

L"\.IABootFiles\boot.efi",

L “\System\Library\CoreServices\boot.efi” :arrow_left:︎ new Path

};

Credit: Chris1111


(Portex) #9

Hello,
I have the same problem, I can access by pressing the option button at the beginning, but every time I turn it off and on, it gives the error being necessary to keep pressing the button every time I restart it.

Were you unable to resolve the issue permanently?

Thank you


(Adam Engst) #10

Did you update to 10.13.4 after getting it to boot? That might fix things, assuming you don’t need to stay at 10.13.3 for other reasons (like the dual-display apps). I did update, and don’t seem to have any trouble at restart.


(Greg Scarich) #11

I’ve had to go into safe boot lately to do OS upgrades and Friday (the 13th) I decided to go for .4. As often happens something hangs and I reboot, but this time I ended up at the same screen you saw. I looked through the log and couldn’t see anything that seemed suspicious, but I’m pretty minor league on reading logs. I tried safe boot again but to no avail. Forgot about Cmd-R mode and spent $75 at the local computer store to find out about my ignorance. If I’d only waited a couple of days or had read my saved notes on recovery.

The other problem I ran into is that I booted my MBP 2013 off another drive and tried Disk Utility and it would only do a quick check (took only a few seconds to check the drive compared to the normal minute or two) which seemed odd. It was odd, it should have told me I can’t use DU from a hard drive on an SSD formatted with APFS. I’d probably read that “long” ago, but that became part of my $75 education.

When I quickly Googled for problems with 2013 vintage MBP I found out that cable failures to the drive were common, so I quit looking then figuring OK the drive is good and I just need a cable.

Everything seems OK now, the store did the .4 upgrade and since I took it in this morning and picked it up an hour ago I can’t say everything is fine. Only one startup.

You can add the DU misinformation to your list of Mac irritants.


(Horvath Adam) #12

I had a very similar experience (MacBookPro mid 2012) previous day I updated to 10.13.3 -long time user playing cautiously with updates. The update run fine, the machine appeared to be somewhat slow (lots of beach balls) but was serviceable.
Shut down and re started next morning & got a warning similar to AE’s though the graphic was different. Tried several of the “usual” things; safe boot, running Disk D. from a clone start up disk etc. On the second attempt to start up from a remote disk I got the “cannot complete the update again”. Spent an hour and a half with the Apple service folks who re set PRAMS and eventually re installed 10.13.4. Good service but very unusual problem. As far as I can tell, no data was compromised. Hope Apple comes clean with an explanation


(Adam Engst) #13

2 posts were split to a new topic: List of Mac keyboard shortcuts


List of Mac keyboard shortcuts
(Owen Laws) #14

I had a less traumatic update experience yesterday with my MBP 2014, without the Installation Log screen. I had been working and left the computer plugged in. When I returned a few minutes later the screen was black and unresponsive. After a few minutes wait, pressing keys and diddling I pressed the start button - and nothing happened, even after repeated attempts and holding it down.

Finally it did restart - several times, with different kinds of installation process bars showing different amounts of time that installation would take. After about 30-40 minutes the process completed and I could log in as usual. The OS 10.13.4 update was installed even though I never actively check auto install in preferences.

I had upgraded to High Sierra a few weeks ago and haven’t had any problems.


(Joe Stoner) #15

Hi Adam I didn’t experience your errors BUT when I upgraded to 10.13.4 last night I got a notification from the App Store that there is another update to 10.14.5! I can only assume that another update means that something isn’t working as well as Apple wants. As my iPhone 6S updated its OS without my asking it to (I always leave at least a week before updating). Thus the control of updating IS being wrested away from us users and firmly in the court of Apple’s patrician (I don’t include our distaff as I’m a gentleman:) propeller-heads; this is borne out by a news item (that I haven’t verified yet) that Apple is disabling iPhones which have had their screen repaired by a third party! They DON’T want us messing around with “their” shiny technology:((


(@lbutlr) #16

Are you enrolled in the beta program? 10.13.5 went into beta right after the release of 10.13.4 (this is how these things pretty much always work).

Not sure about iOS, as I’ve never had an iOS device update without

  1. Asking me
  2. Making me entering my device password

I did have an iPad that was on iOS 10 for many months after 11 was released.


(Owen Laws) #17

No, not in the beta program. Was very surprised at being forced updated, can’t remember it ever happening before.


(akent35) #18

This is one reason why I prefer to never do an “automatic” update of the Mac OS, even one “within” the same Mac OS. For OS 10.13.4, given that it had bene a while since OS 10.13.3 was released, and with 7 beta versions of OS 10.13.4, I did a clean, fresh installation of V10.13.4.

With V10.13.5 (now at its second beta), I will most likely download the Combo Updater, and do the update myself. Like the clean installation above, that gives me way more control over the upgrade process.


(@lbutlr) #19

I would double check that, the only way to have macOS 10.13.5 is to be in the beta program. The latest release is 10.13.4, which came out March 30th.


(Adam Engst) #20

2 posts were merged into an existing topic: macOS 10.13.4 Warns Users about 32-Bit Apps