Mac mini SSD replacement

My former employer has a late 2014 Mac Mini which is used as an archive and MySQL server. It runs Yosemite and the Server app (it is not publicly facing). It uses many of the Server services.

The internal SSD drive is flagging read errors every time CCC tries to clone it. We have several backups but it’s becoming more difficult to be confident in their integrity. We want to simply replace the SSD but I’m having major problems trying to find a suitable replacement. The only drives OWC have require an upgrade to at least High Sierra (which will render Server app useless).

Does anyone know of a replacement drive for the built-in SSD (APPLE SSD SM0256G) which doesn’t require a system update? I have seen some Crucial drives but am not sure of their compatibility (and I think Apple also have a unique physical design).

Have you considered using an external SSD? I have a 2012 Mini and cloned the spinning drive to a Samsung T7. Every performance issue 8 was having disappeared. Running Mojave on it as I’m only doing file sharing of an external 16tb enclosure.

That’s very weird. They say it in the context of “designed for APFS”. I would love to know what the technical reason is for this stated requirement, because it doesn’t make sense to me.

If your Mac doesn’t have a hard drive in it, you could install a 2.5" SATA SSD. It won’t perform as fast as the Apple SSD, but maybe it will be good enough.

If you want to install/repalce the internal drive yourself, iFixit has a good set of repair guides. Not too hard to do as long as you’re careful: Mac mini Late 2014 Repair - iFixit

And, as @glenthompson wrote, you could just get an external SSD. A USB drive will perform a little slower than an internal SATA SSD, but will be far far easier to install. A Thunderbolt drive will perform very well, but you may have problems finding a TB2 drive these days. (TB3 drives can be used with an adapter, but the adapter won’t pass power, so any drive connected that way must have its own power brick.)

Yes, there’s a strong possibility that’s what we’ll do. I attached a second Thunderbolt SSD yesterday and set it to clone and will try it next week. My preference would still be to replace the internal drive just to make it neater. As the MM still has thunderbolt 2 even finding an enclosure is getting hard - most of the ones I have are of a similar vintage as the machine.

I’m not sure of the technical reasons but I can confirm the new drives definitely won’t work with earlier than High Sierra. I installed one in my old 2015 MBP and jumped through hoops trying to get it to work with Sierra without luck. The drive simply doesn’t appear if you boot with Sierra - neither Disk Warrior or Disk Utility can see the drive.

If I installed the 2.5SSD would it still require the primary slot to be filled? I’m not sure if these machines were released with spinning drives alone or as Fusion drives which might still require the blade.

1 Like

Is there that much of a performance increase? My mini late 2014 is running Monterey but is pretty slow with the original drive. It only is a file server at this point but if a T7 makes it more peppy that’s probably not a bad idea. Would obviously need a usb c to a dongle to hook a T7 up to it but way cheaper than a new mini if it works nicely.

I have an old 2012 Mac mini with a Core i5. It’s still a surprisingly useful headless number cruncher ever since it’s been equipped with an internal SATA SSD in lieu of the original 500 GB HDD.

Swapping the disk was not as simple as you’d like, but it wasn’t terribly difficult either. iFixit has a very good guide. Although, in the case of the 2012 Mac mini, the suggestion to disconnect antenna cables to slide out the board is entirely unnecessary to swap disk drives. Skip steps 10, 11, and 13-16, just fold back the antenna plate, and slide out the disk. On reassembly, getting the disk fitted right is much easier if you turn the mini upside down and let gravity help you.

Huge difference in speed. Writes are ok but reads about 5x faster.

Yeah…I plugged in my travel photo backup T7 and got about 8x for both read and write so there will be a pretty decent improvement in both file sharing performance as well as when using Screens to remote into it and configure/update/whatever.

So…bought another Samsung T7 for my 2014 mini since while it is slow on the spinning drive it’s only a server but the throughput to the external spinning drive is really slow…this server is essentially a destination for my roll your own TM replacement with CCC for laptops. Backup performance is a lot better so I figured I would boot from the SSD as well…but that’s been problematic.

Tried a full CCC clone including macOS to the SSD, selected as boot drive, doesn’t work. Downloaded the Monterey installer, nuked the SSD completely, formatted as APFS, and installed Monterey on the SSD…still doesn’t boot from it, looks like the mini thinks awhile and then gives up and boots from the internal spinner. System Prefs sees it and lets it be selected as startup disk…it just doesn’t actually boot from it.

It should boot from external USB according to google search but it isn’t working. Is there a trick here to make it work that I missed? The only thing I haven’t tried is a recovery boot and reinstall on the SSD…but I figure if the full installer doesn’t work tht won’t either.

It doesn’t really seem worth it to buy a new mini for 5is purpose, but I would like better performance when booting it and for the occasional login via Screens 4.

That 2014 mini predates T2 so you shouldn’t need to authorize external booting first.

Has the SSD been formatted GUID?

I have not had problems booting a 2013 MBP from an external USB3 SSD, but admittedly that was on Mojave, not Monterey, so definitely simpler because it was before the System/Data split.

If you install from Recovery, make sure to boot with cmd-opt-r so you’ll get the latest macOS version that runs on your hardware instead of whatever was installed previously on the internal disks’s recovery partition.

Howard Oakley has an extensive guide to doing what you want with Monterey. Check to make sure you haven’t missed anything. Good luck! :slight_smile:

Yep…formatted the disk new as GUID and then a single APFS volume. Downloaded the full Monterey installer (internal spinning drive is up to date Monterey on late 2014 mini) and installed Monterey to the SSD which is connected to the USB port since I don’t have a TB2 to USBC/TB3 adapter. Sys Prefs allows selection of the SSD as the boot device but it doesn’t boot and instead boots internal. Figured it might be some sort of EFI or whatever issue so did a command R start and installed later Monterey on internal, then selected SSD again as startup and it failed. Command R again and installed to the SSD but did not reformat it again before installing. Still boots to internal.

I’ll go take a look at Howard’s page you referenced again…just in case I missed something…but I been doing Macs a long time and was a sysadmin in my working life so while it’s possible, even likely that I missed something…if I did it hasn’t occurred to me yet. I even checked with LockRattler and SilentKnight to make sure everything else is up to date.

I’ve also pulled the SSD of of the mini and verified that it does boot my M1 Pro MBP 14 correctly…so that isn’t it either.

Edit…checked Howard’s page and verified that there is no firmware password set so with no T2 booting from external should work. Did not see anything on that page that I had missed…

Sheesh.

Yeah, that is odd indeed if the disk can boot another Mac. Does sound like you have all your base covered. I’ll have to think about it some more to see if I could come up with anything else that could be amiss on that mini.

Let me just note that your T7 is a USB device, so you cannot hook it up to your TB2 even with a TB2-TB3 adapter. It does not speak TB, only USB so that is what it needs to see. In your case that is a bit of a bummer because your built in USB ports are only 3.0 ports with 5 Gbps whereas the T7 sports a 3.2 Gen 2 interface for up to 10 Gbps. Your TB port would indeed offer bandwidth to match that, but since the disk does not support TB you’re stuck with what you have. Sticking with Samsung, I believe you’d need their X series to do that. Of course, unless you’re doing really demanding stuff on that old mini, chances you’ll be perfectly fine with the T7 and 5Gbps. Considering the limitations of your mini’s USB ports (you’ll be hard pressed to find an older Mac that actually puts 5 Gbps real-world over its USB due to overhead), any SATA-based SSD should be more than good enough.

If you had a Mac with a T2 chip, I would suggest that the startup security settings were configured to block booting external media.

But the 2014 mini doesn’t have a T2, so that shouldn’t be the problem.

What happens if you hold down Option when powering on? Do you see the T7 drive from there?

Yes, it’s a USB C only device but it’s still about 10x as fast for read and write as the internal drive is and is hooked to the USB A port on the mini…and I’ve even switched ports just in case that might be it although since macOS sees it the port is obviously fine. I got it for quicker network backups from our laptops due to the better throughput but figured I would boot from it as well since doing anything when remote connected for management is painfully slow reading from the internal drive.

Yes, it shows up with option boot as well as in Sys Prefs as a valid startup drive…but selecting it in either it still boots from the internal. I even tried hooking up a real keyboard and mouse to it instead of remoting in since it’s video is hooked up to the TV anyway…and from everything I can think of it should be booting the T7.

It’s not actually a big deal as I only remote in for occasional management purposes and file transfer speeds from our laptops to the T7 (which is what I got it for) are as expected…but at this point my stubborn gene wants to keep trying to figure out why it won’t work as it should.

One other weird symptom which may or may not have anything to do with it. The monitor it is connected is our Sony 65 inch TV. When I reboot it with attached keyboard and looking at the TV the Apple logo and progress bar appear ‘small’ as one would expect with the large monitor with very slow progress on the bar. About halfway through the boot there’s some sort of screen resolution change thing where the apple and progress bar about double in size like it was on a smaller resolution monitor and then about 1 or 2 seconds of much faster progress bar progress then the user login screen appears.

Searching the apple support communities I found this discussion

https://discussions.apple.com/thread/8090214

that claims that external SSD’s should have their own power supply.
Most discussions of booting from external SSDs from Samsung use the T5, not the the T7. It might be that the T7 needs a bit more more power than the USB-bus is able to supply.

All of the external USB 3 SSD’ s that I’ve used have no external power supply and no way to connect one and all work fine. The models are Toshiba XS700 and Samsung T5. Both boot fine in Catalina. I do have a T7 for data but never tried booting from that one.

This is probably not the issue but with the T7 I have used for data, the cable it came with was faulty. Moving it just a bit caused a problem. Since you said you can see it with the option boot, I don’t think the cable is the issue but you never know.

I can boot into Catalina fine with T5’s but never tried the T7 for that.

This is an interesting discussion. I thought for clarity, I’d just relate what we did to solve the original issue. I had zero luck getting a replacement SSD - the only options are later drives which require High Sierra or later. I created an extra clone with an old Thunderbolt 2 external SSD. It booted but the Finder went into an unending crash/restart/crash loop so was unusable. Presumedly there was a damaged/corrupt System file somewhere.

I searched the office and was lucky enough to find an identical, unused Mac Mini. It had the same issue with the Finder crashing from the extra clone. I went back to the original clone which has been on the machine since day one. Thankfully, this booted the machine without issue, I’m guessing the corrupt file never overwrote the original file.

I cloned this to the internal SSD and replaced the machine with the bad SSD. Everything’s been running fine for a couple of weeks. I’ll reformat and zero the original machine and see how the SSD responds after that. Hopefully it will be able to serve as a spare.

1 Like