Mac downloading Install-Monterey app, when I did not ask for it…

I remember that, now that you mention it. For a moment, I even thought maybe that’s why I had no badge, but no, it isn’t an alias in the dock. Somehow, I’m lucky—no badge, no Monterey installer download.

1 Like

My catalina 2018 mini downloaded Install macOS Monterey (version 17.1.02) on about Jan 14. I copied it to an archive disk and left the installer in place. On Jan 22 it did it again, with a newer version (17.2.02) replacing the earlier one. I’ve now turned off check for updates in hopes that cures it.

It took 26 hours each for them to download, saturating my connection for the entire time. I’m tempted to send apple an invoice for the internet usage they stole from me, but it would just be a further waste of time.

1 Like

Or you could just remove it from the Dock altogether. System Preferences is always available from the Apple menu, so it isn’t even any more difficult to get there when you need to adjust something.

3 Likes

Ok here’s the plan. For those with no internet issues we have a contest to see who can get the most pushed copies of Monterey. Winner gets a personal thank you from Tim Cook and a free U2 album! :slight_smile:

I’m at 3 so far, and now understand why my internet was so slow last Thursday, and my CPU so hammered that my fan was running… because there doesn’t seem to be an obvious way to tell that the download is happening. I’m not even sure it showed up in Activity monitor/network. Because if you were trying to push/hide something on users, you’d specifically not want them to see it there.

Separately, if only there was a way to hide the sys pref badge on ios, other than pushing sys prefs into the randomly sorted app library.

I think I’m up to four. I deleted the installer the first two times it appeared. I didn’t bother deleting the third, but I just checked today and I see that the date on it is this past Sunday at 4:17am, so Apple clearly downloaded yet another copy of this installer.

As a test, I’ve just deleted it, and I’ve created a symbolic link to /dev/null (the null device), to see if that will block anything:

$ cd /Applications
$ sudo rm -rf Install\ macOS\ Monterey.app
$ sudo ln -s /dev/null ./Install\ macOS\ Monterey.app

Maybe this will work, but only if Apple tried to overwrite the package. If they just delete it and write a new copy, then this won’t do anything.

I find myself thinking that this constant and forced downloading isn’t a bug but rather an intentional decision on Apple’s part…hoping that users will ‘accidentally’ upgrade and hence perhaps reduce the support calls to Apple. Since there’s clearly a choice in System Preferences…they should honor the user’s choice. It’s just like…to me anyway…the constant asking about location permissions on iOS and iPadOS…I can understand them offering me the choice that say Weather has used my location 17 times in the past 3 days and do I want to keep allowing that…but once a user has said “allow permanently” 2 times then they should accept that answer and quit asking about it…or at least make it only every 3 months or something.

There are still people on limited and/or fixed bandwidth caps and with the size of the current installers wasting 12 GB or more several times is a bad idea on their part…heck, I’ve got a limit of 1TB per month on cable and I generally only download the installer once and then move it to the other machines in the household.

For what it is worth (and hoping I don’t jinx myself), following is what I have done, and so far, no Apple pushing a third “Install macOS Monterey.app” onto my MBP: I did receive a second installer, and I put it into the trash. Then I created a bogus text file (via Pages) (size about 92 KB), and changed the file name to “Install macOS Monterey.app”, and then put this file into the Applications folder, and locked the file. Fingers-crossed !!

1 Like

I haven’t had another since I turned off check for updates. But I want to install the recent security update and I can’t find a direct download for it, so I’ll have to do that via software update which will probably download YA Monteray installer.

You can see if Apple is downloading software (but not what) if you turn on Content Caching, then in Activity Monitor look in the Cache tab. These downloads include any iOS apps that got downloaded too, so if you do a lot of that, such as an update or updating a lot of apps, it will a little trickier to sort out.

Maybe it’s time for a Bad Apple Tidbits article? And lots of email to Tim asking to be refunded for lost network service from those of us with slow connections or low data caps.

After reading your post, I decided to do the same thing. I’m assuming a read-only file is likely to work better than a symlink to /dev/null.

Anyway, a week later, Apple tried again. At least I assume they did, because this morning, there was yet another notification on my screen asking me to install Monterey.

But there was no app-installer and the read-only file remains in place as it was last week. So that part worked. Whether or not they actually downloaded 12GB in order to discard the data, I don’t know.

I didn’t bother with a 92K Pages file. A tiny (51 byte, in this case) text file works just as well. From a Terminal:

$ sudo rm -rf "/Applications/Install macOS Monterey.app"
$ sudo vi "/Applications/Install macOS Monterey.app"

Then insert a line of text and save the file. Instructions for using vi is beyond the scope of this message, but if you need them, here’s a tutorial.

After you save the text file, make it read-only:

$ sudo chmod 444 "/Applications/Install macOS Monterey.app"

Mode 444 means the file is read-only for everybody (user, group and other. ls -l will show it as -r--r--r--.). See also Unix / Linux - File Permission / Access Modes

1 Like

And likely beyond the scope of anybody who’s not already familiar with vi and its use anyway.

There is the very simple nano installed with every Mac that’s much easier to use for people who are not used to CLI text editors.

But best of all, none of that is actually necessary at all. Just pipe the text you want straight into the file.

echo “This is my line of text” > /Applications/Install\ macOS\ Monterey.app

Done. :slight_smile:

1 Like

Yes, but if you prefix the echo command with sudo, it doesn’t create a root-owned file. I assume because the redirect operator (>) is not part of the command passed to sudo.

You also can’t do it for a file in a normal /Applications directory, because the directory is owned by root and only writable by its owner and group (admin). Since it is bad practice to be logged in as an administrator, your account won’t be able to write anything to that location without sudo or another equivalent.

Using an editor, you can create a root-owned file by calling it with sudo.

Of course, you could also create a file in your home directory, then move it to /Applications and chown it to root. But that’s more steps than just running your editor via sudo.

(And I now just realized that on an umodified system, non-admins can’t use sudo either. But doing it all via the Finder will let you explicitly authenticate those operations that need additional privileges.)

Update: Last night I did my monthly ‘turn on download security updates’ in software update/advanced, and sure enough this morning I find a shiny new Install Monterey.app in my applications folder. So apple has decided that downloading something I didn’t ask for is just the ticket. The sort of thing microsoft does, which is about a deep an insult one can give, now isn’t it?

That puts me at 4, tied for top spot I reckon.

So if that’s indeed the case, Apple would be forcing many-GB downloads onto people who were merely choosing to have the fairly lean MRT, XProtect, et al. updated. That would indeed be quite sleazebaggy. :frowning: :-1:

2 Likes

Certainly I would rather create a file in BBEdit and then move it and change permissions in the Finder. But if I were feeling frisky…

Would this work for the non-admin user?
su admin
sudo command
Of course, I assume the non-admin user replaces admin with the name of an administrator and enters the correct password when prompted, and command is whatever command the user wants to run. I believe I have done this, but I’m not certain.

Also, I have a note to myself that sudo -u admin foo would execute command foo as user admin. I don’t believe I have ever tried it.

I got an unwanted download of Monterey when I tried to download the Big Sur update a few days ago. I noted the download was taking a long time and was surprised when the Monterey installer popped up and asked me to launch it. I didn’t, and it appears to have gone away by itself.

We all do what we’re most comfortable with. I was a Unix user for many years before I bought my first Mac, so Terminal-based approaches are natural for me.

But if you were a Mac user first and started learning Unix only as a part of performing tasks that are otherwise awkward, then a GUI-based approach will probably feel more natural.

That should work.

In my case, I hand-edited my /etc/sudoers file so I (but no other users on the Mac) can use sudo despite not being in the admin group.

It’s good to be the sysadmin. :grin:

I haven’t had another copy foisted on me since feb 3 when I turned off check for updates (crossing fingers). But that has the repercussion of not being able to update anything, from security updates to mac app store apps.

Whether or not they actually downloaded 12GB in order to discard the data, I don’t know.

It likely downloaded then failed to copy. Software updates generally download to /Library/Updates. Could even still be there, and maybe that file can be blocked, but it’s it’s probably version specific. I’ll eventually be testing that when I can find a 26 hour window of clobbered net connection that won’t annoy me fatally. Nothing quite like taking more than a minute to open a straight text mail message, or ten minutes to load a small .png in a browser…that kind of nostalgia I can do without!

1 Like

h/t to @romad:

Using the System Information app, I can actually see all of the (successful) downloads of the Monterey installer. They are listed as installations of “MacOS Monterey”, even though I absolutely did not run the installer. In my case, there are four downloads (which aligns with my observations I mentioned in the above thread):

So, if you’re curious about how many times Apple has pushed this installer on you, now you know where to look.

2 Likes

On my iMac, there isn’t any MacOS past High Sierra, version 13.6.02 dated 10/2/19, 17:49. However, my MacBook Pro uses a very weird date format:

macOS 12.2.1 version 12.2.1 Install Date /132/22, 09:26

Since 2022 is only 61 days old, the 132 can’t be the Julian day date, and moving the forward slash to between the 1 & 3 doesn’t make sense either (unless Apple’s January calendar has 32 days!)

The only possible way these digits could make sense to me would be if the slash is misplaced and there’s a European date format, making it February 13th.

Of course, it could just be mangled data from a bug.

Do all your dates on that computer look messed up in the same way? In which case, you may have a messed up custom date format (either a mistake or via a bug):