Getting told update is needed for my iPhone to connect to Mac, but download doesn't work

iMazing triggers the same update. I just did it last weekend. I guess I was lucky that I had to wait only like 1 hr for the download to finish. The installation also took seemingly forever.

What did it update? The Mac or phone?

Diane

These are updates to macOS but their purpose is to get the Mac to properly talk to the iOS device. This is why they often occur after new iOS devices have launched, but sometimes they also happen outside of those windows.

That’s good, but what happens when you are on an older OS? I’ve gotten messages to update my Mac OS to a higher version. I’m on Sierra which is why I went to iMazing, knowing my 13 Mini wouldn’t back up to my older iTunes.

Diane

I’m assuming the Mac.

iMazing needs that update too because they’re running on top of apple’s structure. But they’re as good as it’s possible to be about letting old stuff work. My mac with iMazing is a 2011 mini running el cap, and I had to do one of those updates when I upgraded to ios 15. I do have older hardware though (iphone 8, ipad mini 5). My escape hatch if needed when I get a new iphone and ipad this spring is to move iMazing to my Catalina mini, but if I didn’t have that, Catalina in a VM (which I think you already have?) should also work. You’ll need to tell the VM host to mount USB devices. In VMWare, I generally set things to ask each time a new device is connected; I don’t know how Virtual Box does it, but surely there’s something similar.

I am running iMazing (to keep backups of iOS devices) under El Capitan on an older Mac mini. The update was of the MacOS component as others said, which it requires to talk to an iOS device (iPhone SE 2nd gen in my case). The only change was my updating iPhone from iOS 14.8 to 15.3 a few days before the component update was triggered.

I had this problem with my iPhone 12 and my iMac Retina 27" on Big Sur. The download never got beyond the first blue dot. Then I closed my Cloudfare Warp VPN and everything worked properly. This is not the only issue that has been connected to Cloudflare Warp VPN, although Cloudflare 1.1.1.1 works fine. I have since deleted the VPN.
If you are not running Cloudflare Warp or a VPN of any kind then we need to dig deeper.

I get the same thing on my iMac that is maxed out at MacOS 10.13.6. I click on the “Not Now” button and my iMac connects just fine. As far as I can tell, this is only another form of Apple FUD to force us to buy newer, yet unneeded hardware.

Follow-up on 1 Mar 22
I just synced and backed up my iPad Mini 4 running iPadOS 15.3.1 using iTunes 12.6.3.5 in MacOS 10.13.6. I got the “update” alert and just dismissed it before syncing and backing up.

It’s only needed to connect to new iOS hardware or enable new features/fixes. If you connect older working iOS hardware, you can ignore it without problems. Except of course Apple’s constant nagging. :frowning: I end up just doing it because of that. Precisely what they want obviously. Oh well, you have to choose your battles. :wink:

And Apple apparently doesn’t know that a Mid-2011 iMac running MacOS 10.13.6 CAN’T be updated anymore! :laughing:

No, not at all. As others have stated, it simply allows you to connect to any new iDevice you may have purchase or will purchase in the future or to accommodate an iOS/iPadOS update on an older device.

Has nothing to do with macOS updates and your Mac can still be updated with background updates to such things as MRT and XProtect as well as these iDevice updates. They don’t require a restart and have always been very quick and trouble free for me (as opposed to the OP’s recent experience).

4 Likes

Aren’t those supposed to be listed in System Report/Software/Installations? The only items I have listed there are seven 1Password and one AdBlock updates and the oldest is from 2019.

They should be. Sort by install date, most recent first. I see the last update to XProtect and MRT on my main MBP was on 2/4.

The list also shows MAS updates and 3rd party updates (Zoom for example).

In that list I also see a RosettaUpdateAuto took place after I installed the 12.2.1 update. Didn’t know Rosetta does auto updating on its own. Makes sense though. Sneaky, but I like it. :slight_smile:

1 Like

Yes, they should be, as long as you have both “Automatically Check for updates” and “Install system data files and security updates” enabled in System Preferences->Software Update. If you don’t enable both of those then you will never get those background updates.

Thanks, that did it. I then sorted by Source and have it showing those from Apple first.

Looks like the most recent Security Update is 2020-006. The MRT, XProtect, Gatekeeper were updated this month.

That wasn’t a background update. It requires you to accept the install unless you have “Install macOS updates enabled”.

I’m guessing you meant within a month as MRT & XProtect were last posted on Feb 3. There hasn’t been a Gatekeeper update since mid October 2019, so not sure why that was updated for you. It’s no longer used, so not a big deal.

Oops! You mean today isn’t February 30th? Yes, it was on Feb 4 for me

Just a note: It now works. I had plugged my iPhone in, got that annoying dialog box telling me to update. My choices were either to ignore and getting it popping up again in a few minutes, or hit install, drag the installation dialog box off the screen and ignore it.

This time, I hit install, and it actually installed. Don’t know what changed. Maybe it was an OS update of some sort.

I had this problem last week. After much Googling , I fixed it.

It turns out I had upgraded XCode but never run it since. It seems that XCode upgrades the same library that the mystery dialog also wants to upgrade. So all I had to do is open XCode, tell it to update its command line tools, and voila! The mystery dialog disappeared and hasn’t come back since.

2 Likes