Mac downloading Install-Monterey app, when I did not ask for it…

So if that’s indeed the case, Apple would be forcing many-GB downloads onto people who were merely choosing to have the fairly lean MRT, XProtect, et al. updated. That would indeed be quite sleazebaggy. :frowning: :-1:


Certainly I would rather create a file in BBEdit and then move it and change permissions in the Finder. But if I were feeling frisky…

Would this work for the non-admin user?
su admin
sudo command
Of course, I assume the non-admin user replaces admin with the name of an administrator and enters the correct password when prompted, and command is whatever command the user wants to run. I believe I have done this, but I’m not certain.

Also, I have a note to myself that sudo -u admin foo would execute command foo as user admin. I don’t believe I have ever tried it.

I got an unwanted download of Monterey when I tried to download the Big Sur update a few days ago. I noted the download was taking a long time and was surprised when the Monterey installer popped up and asked me to launch it. I didn’t, and it appears to have gone away by itself.

We all do what we’re most comfortable with. I was a Unix user for many years before I bought my first Mac, so Terminal-based approaches are natural for me.

But if you were a Mac user first and started learning Unix only as a part of performing tasks that are otherwise awkward, then a GUI-based approach will probably feel more natural.

That should work.

In my case, I hand-edited my /etc/sudoers file so I (but no other users on the Mac) can use sudo despite not being in the admin group.

It’s good to be the sysadmin. :grin:

I haven’t had another copy foisted on me since feb 3 when I turned off check for updates (crossing fingers). But that has the repercussion of not being able to update anything, from security updates to mac app store apps.

Whether or not they actually downloaded 12GB in order to discard the data, I don’t know.

It likely downloaded then failed to copy. Software updates generally download to /Library/Updates. Could even still be there, and maybe that file can be blocked, but it’s it’s probably version specific. I’ll eventually be testing that when I can find a 26 hour window of clobbered net connection that won’t annoy me fatally. Nothing quite like taking more than a minute to open a straight text mail message, or ten minutes to load a small .png in a browser…that kind of nostalgia I can do without!

1 Like

h/t to @romad:

Using the System Information app, I can actually see all of the (successful) downloads of the Monterey installer. They are listed as installations of “MacOS Monterey”, even though I absolutely did not run the installer. In my case, there are four downloads (which aligns with my observations I mentioned in the above thread):

So, if you’re curious about how many times Apple has pushed this installer on you, now you know where to look.


On my iMac, there isn’t any MacOS past High Sierra, version 13.6.02 dated 10/2/19, 17:49. However, my MacBook Pro uses a very weird date format:

macOS 12.2.1 version 12.2.1 Install Date /132/22, 09:26

Since 2022 is only 61 days old, the 132 can’t be the Julian day date, and moving the forward slash to between the 1 & 3 doesn’t make sense either (unless Apple’s January calendar has 32 days!)

The only possible way these digits could make sense to me would be if the slash is misplaced and there’s a European date format, making it February 13th.

Of course, it could just be mangled data from a bug.

Do all your dates on that computer look messed up in the same way? In which case, you may have a messed up custom date format (either a mistake or via a bug):

Nope. This is the only place I’ve seen this, however I went into the Date & Time Control Panel, deleted the Short Date layout and re-entered it (since that was how the messed up dates seemed to be formatted). When I closed the panel, the dates adjusted themselves properly. So you were right that something had gone buggy on that preference.

1 Like

… and a few weeks later, Apple blew away my read-only text file and put yet another copy of the Monterey installer in my /Applications folder.

This game isn’t fun. The people at Apple who think it is should have their collective heads examined. Going to war with your customers is not the way to convince them to use your product.

How does Apple actually achieve that? Does Software Update operate as root?

Maybe. Or it runs from an account in the “admin” group - which has write access to /Applications.

It probably needs to be in that group, since it installs software.

In addition to the chmod, try:

$ sudo chflags uchg,schg "/Applications/Install macOS"

I haven’t tried that (my system doesn’t seem to download it, just natter about it) so no guarantees, but worth a shot.

1 Like

The problem with flags like this is that they don’t prevent deletion of the file. The permissions on its containing directory (/Applications) control that, and I really don’t want to make that entire folder read-only.

If by “prevent” you mean that Software Update can’t override them, you’re right, it could easily turn them off just like it overrides a 444 mode, but it might not. If you mean the flags don’t prevent deletion if they’re on, they seem to (on Mojave at least):

$ echo hello >x
$ rm x
$ echo hello >x
$ sudo chflags uchg,schg x
$ rm x
override rw-r–r-- blm/staff schg,uchg for x? y
rm: x: Operation not permitted
$ rm -f x
rm: x: Operation not permitted
$ sudo rm -f x
rm: x: Operation not permitted
$ sudo chflags nouchg,noschg x
$ rm x

1 Like

I accidentally downloaded Monterey on my laptop a while back, but thought it it went away of was deleted. Now I found a Install Monterey on the laptop dated April 27, when I know I didn’t download it. The new date implies something new happened yesterday. Weird!

I’ve had at least one more Monterey download in the past month (though I can’t find the installer app any more so they’ve hidden it) or 12GBish of disk space has just mysteriously been used by something else. So that’s 5.

This is actually making me not install Monterey, just to be contrary. I mean, I normally skip alternate Macos versions anyway so don’t want Monterey on that basis, but apple is pushing my ‘you can’t make me!’ inner 12 year old buttons.

1 Like

Not exactly surprising since all macOS software updates are initially completely downloaded into a /private/var/folders/zz/…_n0000000000000/ temporary folder before being moved to /Applications. Note that you won’t have visibility into the temporary folder, which is why you can’t find it.

Find Any File can search through all folders, including system and hidden ones. It can also search based on size instead of (or as well as) name, so you could look for files larger than 10GB.

1 Like

i installed Monterey this week (as my poor 2017 Air won’t get Ventura, so no point in waiting to skip one major version as normal) and, despite then downloading 12GB to do the installation, the 12+GB partition in my SSD (shown as an update file in disk utility) disappeared. Totally coincidentally 2 days later I have 12ishGB more available disk space.

So not only did apple foist this on me repeatedly it didn’t even then use it come the day. And they’d gone out of their way to hide the download, having done so when I’d explicitly selected NOT to download updates.