Loss of wifi hours after boot requires reboot –> M1, Monterey, ...?

One odd thing I have noticed on my 14" MBP is that every once in a while, after rebooting the system (usually after macOS updates because mostly that’s the only time I reboot), after several hours of perfectly normal use, the MBP will lose its wifi. It will just show an exclamation mark over a grayed out wifi menu bar symbol. This is on my home wifi which is all Apple (final gen AirPort Extreme) and otherwise rock stable. There appears to be no issues with the wifi on any other devices, just this 14" MBP. And only after it has been recently rebooted, like yesterday because of 12.5. The whole afternoon everything remained peachy after the update, but then this morning no wifi. It must be about the 4th time I’ve seen this happen since I got this MBP last Nov.

When it happens, no amount of turning on/off wifi, reselecting the network, or changing network locations helps. No other clients show any issues. AP Utility connects to the base station (from another Mac only, of course) and reports all looks good, but indeed the 14" is no longer listed as a client. I’ve tried logging out and back in (since Howard Oakley almost had me convinced that very little actually happens in addition when you do a full reboot) but no dice. The only thing that ultimately seems to help, is to just reboot the MBP. Then it will immediately reconnect to my home wifi as if nothing ever happened. Apple Diagnostics reports all peachy which is kind of what you’d expect considering that most of the time access to my home network is great.

Short of drastic stuff like reinstall macOS or trashing my network prefs etc. I’ve tried pretty much everything I can think of. And honestly, at this point it’s more about curiosity than wrestling this to the ground. It happens rather infrequently and can easily be remedied. Any other suggestions for things I could try next time it happens (could be months away)?

Any guesses as to what’s going on here? Is this some kind of odd Monterey bug? It’s almost as if on certain boots, there will after a couple hours be trouble with wifi so then when that happens you reboot again and if you’re lucky on that boot things will remain solid. Until the next reboot and then you roll the dice again. Odd. I was wondering if perhaps it had to do with Apple Silicon network stack, since I never experienced this on the very same wifi with any of my Intel Macs. But then again, my wife has never reported seeing the issue with her M1 MBA (2020 model) so I hesitate to point fingers at the M1—those two machines share a slot of commonality and in terms of network stack are likely identical.

Anyway, anybody ever seen something like this?

That’s a weird one, for sure. Can you connect to your phone’s hotspot when this problem occurs? And if you have the adapter, can you connect to wired Ethernet? I don’t have any theories to go along with the results of these tests, but they may offer some interesting data points to you or to others with more networking knowledge than I possess.


I’ve seen a loss of WiFi with my 14" MacBookPro also after the system update yesterday. Toggling the WiFi did not fix it, but a reboot did.

My MacStudio did not drop WiFi, so I don’t think its a general Apple Silicon issue.

1 Like

Nice. I definitely should have connected to Ethernet just to be sure. I’ll do that next time. Expect that to work. Hotspot would be worth a try too I guess. Thanks. :slight_smile:

Thank you. So it’s not just my 14" after all.

Perhaps indeed something with macOS then. I would have been absolutely willing to believe it’s a setting screwed up somewhere in my account, but if you’ve seen this too on your 14", that to me makes it smell rather like macOS. Just odd it’s not happening on other Apple Silicon Macs. I would not have thought this could be exclusive to a single CPU (M1 Pro).

Just one other note to pin it on the MacBook:
My router is a relatively new Asus ZenWiFi mesh setup. So I am using the WIFI 6 protocol rather than the older one supported by the Airport Extreme.

I’m not sure I follow. Your Studio and my Wife’s MBA all also do Wifi 6, right? And regardless of new Asus vs. old APExtreme, the MBP shows the issue, the other two Macs don’t.

Your Airport Extreme only handles wifi protocols up to 802.11ac (WiFi 5). My newer one maxes out at 802.11ax (WiFi6) which is also what the Apple Silicon Macs top out at. I mentioned my router to rule out our network not using WIFI 6 as an issue.

Sp. it appears to be a problem specifically related to the MacBookPro’s WiFi setting after a system update.

Ah yes, got it. Thanks. So it’s MBP only (as far as we know), but it appears unrelated to wifi 5 vs 6.

And just FTR, I would say it’s not necessarily related to system updates.

I had at least one instance where I lost wifi after a reboot that was entirely unrelated to an update (had to shut Mac off for security reasons at a certain facility).