"Lightning to USB 3 Camera Adapter" introduces audio artifacts

Just want to share this tidbit with the community.

I’m trying to do higher-end audio/video projects using Apple gear. The iPhone 13 Pro has a great camera for the video, but the built-in mic is, of course, lousy. I’ve been using various external mic solutions with A/D converters to alleviate this issue.

Recently, I started what I hope to be a high-quality “studio” recording project with video. Playing one of the tracks at home the next day after an evening recording session, I heard audio artifacts randomly “clicking” throughout this recording. These are quiet, acoustic instruments, and these clicks are very disturbing.

Sometimes I also record full-length (2 hour) live shows. In this application, the Lightning to USB 3 Camera Adapter is particularly important because it allows me to supply power to the device so that an entire concert can be recorded. But the captured audio has “click” sounds randomly throughout, ruining the recording.

I tried using different mics, different video recording apps, etc. What made the difference was removing the Lightning-USB 3 Adapter and using the regular Lightning-USB (Camera) adapter. Thinking the Lightning-USB 3 Adapter item was defective, Apple replaced it. Today the new one arrived and has the same problem. This suggests to me that there is an engineering design flaw in the Lightning-USB 3 Adapter. I have tried multiple recordings, and the Lightning-USB 3 Adapter always has audio artifacts, but the other adapter never does.

Here are the most relevant cases, including the control case, reproduced today in the studio with some deliberately soft playing:

Zoom H6 Audio Interface w/ Microphone
→ Zoom Mini USB-USB-A cable
Lightning to USB 3 Camera Adapter (has power port, but nothing is plugged into the power port) (Lightning to USB 3 Camera Adapter - Apple)
→ iPhone
→ Camera App, Video Mode
->>> CLICKING SOUND (Dropbox - Lightning to USB 3 Camera Adapter - CLICKS.m4a - Simplify your life)

Zoom H6 Audio Interface w/ Microphone
→ Zoom Mini USB-USB-A cable
Lightning to USB Camera Adapter (NO power port) (Lightning to USB Camera Adapter - Apple)
→ iPhone
→ Camera App, Video Mode
->>> NO clicking sound (Dropbox - Lightning to USB Camera Adapter - NO CLICKS.m4a - Simplify your life)

After to speaking to Apple Support again today, I opened a Bug Report with Apple. Their responsiveness with other tickets for engineering has been fairly lame, so I’m not optimistic. But this is not okay. This is a $40 adapter, not some cheap Chinese knock-off, and the only solution to this particular problem. Apple continues to do media promos at Apple Events showing iPhones used in studio / pro applications. I’m not a media guru, but I’m getting more heavily into this space, and I’ve been buying more pro / semi-pro hardware and software to get the job done. I care about pristine audio quality. But the iPhone should suffice as the camera. If it’s not going to work, then I’m not gonna let Apple get away with those promos ;-)


I’m no expert on this, but here is the summary of something I read about sound recording on an iPhone:

  • Put the phone into Airplane mode. Otherwise it is repeatedly looking for cellular and WiFi services by sending out a radio signal, which can introduce interference (a microphone can be thought of as antenna).

I don’t remember where I read it or if it is even true. :person_shrugging:t2:
It is easy to try.

Nice music.
My speakers/ears must be bad, because I don’t hear clicks on either file.

1 Like

Thanks for the reply and the compliment on my guitar doodling.

That note about airplane mode and DnD was from another post by me :slight_smile:

From what I read online, these little clicks may be from audio buffer under runs, not from cellular or WiFi interference. And note that I didn’t change anything on the phone between the test with the adapter that worked and the one that didn’t.

I’m glad I at least have a cable that handles audio properly, even if it can’t power my devices. At least a short recording sessions can now resume.

1 Like

I can definitely hear the clicks, but I couldn’t tell if they were regular or random. If they are being introduced by the iPhone, I would expect them to be regularly spaced; if it’s a buffer underrun (or other issue that varies with the signal input), I would expect them randomly. If you record, say, 30 seconds with the same setup but don’t play the guitar, do you still get clicks?

(I am also no audio engineer; just going on instinct here.)

I actually wondered the same thing but never tried it LOL. Now I’m probably going to have to :-)

Fascinating! This just in…

I just randomly had a message pop up to update the firmware for my USB Camera Adaptor. The message looked like this:

So even though I was in a middle of testing, I proceeded with this, since I have no idea where it came from or how to make it come back if I say no. Here’s what it looked like during the update:

I’ve been using this accessory for months. But within 24 hours of starting this thread and opening the Bug Report, this popped up. Coincidence?

Anyway, I had no idea there was firmware inside this device. But that makes some sense, since at least some type of buffering appears to be going on.

Thanks to the above link, I can see the version of the firmware it’s running:

I wish I could have known what it was running prior to updating. However, connecting the non-powered Camera Adapter, that one only says 1.0.0; and I’m not getting prompted to update its firmware. As a reminder, that’s the one I reported above as not having audio issues.

Can Apple hire me as a QA Engineer so I can get compensated for this? LOL

1 Like

Okay, here’s the result, noting that I apparently have new firmware installed for this USB connector since the previous tests.

[Dropbox - Lightning to USB 3 Camera Adapter - Quiet Recording - SOME CLICKS.m4a - Simplify your life]

I tried to be mostly quiet, but to inject a few different types of music transients to see if that mattered. Sometimes it seems like sound triggers clicks; I certainly don’t hear many during the quiet passages. But overall, I heard a few in there.

Not sure what to make of this, or the new firmware update. But any clicks don’t make me happy, and I’ll stick with the unpowered adapter until further notice!

(p.s. I’m using Dropbox links because audio attachments are not allowed)

1 Like

Dave, just a thought - how about using a MagSafe charger and your”pure” camera adapter. That way you could get power and a “clickless” audio recording for an extended period of time.

1 Like

Thanks for reminding me of that! I’m not exactly clear on how the power is wired, but the power port is supposed to also charge the USB audio interface. But I don’t think the Zoom is getting charged with this setup, and it’s mainly the iPhone that needs the power here, so that might work. The main problem will probably be fitting the MagSafe between the phone and the bracket holding the phone for video.

I’m going to try this when I get home!

Maybe I wasn’t quick enough, but the player link isn’t working for me. But whether or not I can hear clicks, your ears are the important ones here (and likely much younger and more accurate than mine anyway).

As I don’t use iOS devices for anything, I am only able to contribute baseless speculation:

Those clicks (they’re clearly audible and, yes, would annoy the bajeezus out of me) sound a lot like “static pops,” which are audible interruptions in an audio signal generated when someone touches a (typically unshielded) cable and discharges static electricity into it. (Since we’ve just started winter, I’m hearing this a lot in recent days from the “fellow kids.”)

Offhand, I’d say check your grounding…except that the pops aren’t happening with the unpowered adapter. So my baseless speculation: don’t those charge-over-USB3 devices charge in pulses, rather than a continuous current? If so, wouldn’t it be interesting if the clicks corresponded to those pulses?

I’m imagining two controllers talking to each other: “Hi, stop doing audio or whatever silly thing you’re doing, I need to use these wires for power.” “OK, I"ll buffer this audio.” “OK, I’m done with the power thing, resume, you know, whatever.” “OK.” Perhaps the clicks don’t happen every time, but it only takes one to ruin a recording, right?


Good point. It didn’t work for me here, but it’s a perfectly good link when I paste it into a browser. But you can’t see the URL because this forum is rendering it as an (unplayable) audio file. I have gone back and put brackets around it which reveals the hyperlink, but maybe @ace can look into why it wouldn’t play as an embedded file?


Interesting! But literally, the entire setup is completely untouched for these tests. I set it up, and then I sit a foot or two away with an (unplugged) classical guitar playing into a microphone, and no one else is even in the room. Noting, too, that I keep that room around 45% relative humidity because it’s also where my piano is located.

Just to be clear, there is nothing A/C in this entire setup. The Zoom H6 is battery powered. The mic is phantom powered by the Zoom. The Zoom USB’s to the iPhone through the adapter that has nothing plugged into its power port.

Yea, so under running an audio buffer is what I read somewhere online as being a possible cause of these clicks. Actually, here’s the link:

But to your point, maybe, even though nothing is plugged into the power port of this adapter, the adapter is still polling the power port, and doing so in a way that interrupts the flow of audio? That is in line with my general hypothesis. Hopefully there’s a smart engineer at Apple looking into this now :-)

1 Like

Yeah, that’s my unsubstantiated thought. But doing this sort of thing with iOS/mobile devices is well outside my wheelhouse.

Well, when the world decides it wants to use touch screens and touch screens don’t work for you…those devices aren’t options.

Not sure if this helps but in digital recording ALL devices need to be set to the same bit rate. If the Zoom recording is at 48kHz and the iPhone is set for 44.1 kHz you will get digital clicks.

Thanks for that tip! That makes sense, but I never labbed that setup to prove it.

Of course in my case, it’s the adapter that appears to make the difference, so I don’t think that’s the problem I’m having. But perhaps there are 2 variables at play.

But also, I was wondering about matching bitrates before, but I can’t find any setting in the Camera app that lets me control bitrate. Any idea if that’s an option? I also purchased ProMovie, which has lots of options, but bitrate is not one of them.

Okay, QuickTime Player hooked me up with a metadata report, since Photos didn’t. Assuming Photos didn’t change the bitrate while Exporting, the iPhone recorded at 44.1 kHz:


And while the Zoom offers many options, I have had it set to 44.1 kHz as well. Likewise, my project in Logic Pro is set to 44.1 kHz, so I think we’re good. Thanks for forcing me to check that :slight_smile:

Did the MagSafe make a difference?

Thanks for the follow up!

I can confirm that the MagSafe charger fits in the video mount bracket, and so would be a great solution for keeping my phone alive during a long recording session!

The rest of my answer is because you’re forcing me to explain something that I have skirted up until this point. The “USB 3” adapter in question is hooked up like this:

The question is, what is that power source meant to power: the Lightning device or the device connected to the Camera/USB input, or BOTH?

I originally bought this to use with a different Audio Interface, a USB-bus-powered Presonus. Since my iPhone couldn’t provide enough power to the PreSonus, I had to find a way to inject power into the same USB port that was delivering audio data to my iPhone. That’s when I discovered this adapter, and it worked perfectly. The Presonus powered up and the audio data passed to the iPhone. I made this entire demo clip using that setup:

Given how loud that recording is, I didn’t notice any little pops or clicks and still have no idea if such audio artifacts are buried in there.

Fast-forward, and I bought this Zoom H6, which is a really cool product with a ton more capabilities. But it does chew through sets of 4 AA batteries. What I haven’t figured out is whether this is providing bus-power to the Zoom, like I did with the PreSonus.

So all this is to say that, while I love the MagSafe solution for keeping the iPhone charged, half the goal here was to keep the Zoom charged. And part of what I’m confessing here, partly to myself, is that – audio issues aside, which are a real issue – this USB 3 adapter may not be fully solving the power-delivery problem I’m using it to solve.

I’m going to reach out to Zoom and see if the device supports being bus-powered in the first place. If it doesn’t, then I can use the MagSafe idea to power the iPhone, ditch this troublesome adapter (maybe get my money back), and try to find some other solution to powering the Zoom.

Okay, you’ve got me on a roll LOL.

I think I went down this path early, just not as methodically, and so my conclusion that it doesn’t work is accurate, but my testing wasn’t as organized.

Here’s the setup:

That white “power” line goes to a USB AC adapter and the black line goes to the USB input on the Zoom. I removed the batteries in the Zoom to ensure it wasn’t drawing on battery power. And as suggested by the blank screen, the Zoom will not power up. To control the experiment and prove the Zoom works as a USB-bus-powered device, I took that USB 3 adapter out of the setup and plugged that black USB line directly from Zoom to the AC adapter. Sure enough, it powered up.

So it seems that somehow, the Zoom is not getting USB bus power through the adapter, or not ENOUGH power. Noting again that the Presonus interface powered up just fine in the identical setup when swapped in for the Zoom.

Maybe the Zoom draws more power? I don’t know. But this $40 adapter is Apple’s only solution to this problem and it’s not working. So this is a second problem with this USB 3 adapter. If the issue is that it exceeds the draw limit, then it’s not a bug; just an annoying limitation. But the audio issue is definitely a bug.

I will see if I can get specs on the draw of the adapter vs. the Zoom.