Just upgraded to Ventura

This weekend, I discovered that Microsoft updated Office and the latest changes are incompatible with macOS 11 (Big Sur). So I decided to upgrade the Mac (2018 mini, 3.2 GHz 6-core Intel i7, 8700B)

I decided to skip 12 (Monterey) and go on to 13 (Ventura). I figure that since Ventura has been out for a year, the critical bugs should (hopefully) all have been fixed by now, and 14 (Sonoma) is far far too new for me to consider using.

I made three backups: two to external USB HDDs via Carbon Copy Cloner, and one via Time Machine.

Then I downloaded the Ventura installer via the App Store using the link Apple provides for this purpose. The installer was about 12 GB and amazingly installed without a hitch. I don’t know how long it took, because I left the room to do other stuff while it was running, but when I came back, Ventura was running and had automatically logged into the account I used to start the upgrade.

(I wish they wouldn’t auto-login during upgrades, but this is nothing new). Things I noted:

  • I got some popups asking me to confirm the installation of the Oracle VirtualBox kernel extension. I did, rebooted, and it seems well. I launched my MS-DOS VM and it seems to be working.
  • I went through all of the new system settings and double-checked it all. I removed many apps from the list of background-processing (leaving only a small number of app updaters, like Microsoft Auto Update)
  • The Launchpad icons got rearranged. Most of the icons remained in the groups where I put them, but they ended up in a different order from where I left them. I remembered where most of them were, but I am glad that I shared a screen-shot in July. :slight_smile:
  • One weird thing. I have the F17 key mapped to the “Application windows” shortcut. macOS is warning me that this conflicts with another hot-key but doesn’t tell me which one. I walked through all of my system’s keyboard shortcuts and couldn’t find anything else using F17. The key works, so I’m not too concerned, but I would love to know what is generating that warning.

Thanks for your report. Just yesterday I was pondering updating my Intel iMac (on Monterey) to Ventura (its max) but couldn’t find a recent straightforward report. I don’t have any complex apps such as yours, so I will backup and cautiously proceed. Thanks.

That’s definitely high on my list of unhelpful system warnings. I’ve interpreted a few threads on other sites as indicating that it may not be possible to catalog all keyboard shortcuts on a given system because some apps implement them via methods that only manifest when the app actually is running. Still, one might hope for a way to list all shortcuts that are active on a system at a given moment.

Somewhat related: I recently had a devil of a time trying to migrate from Quicksilver to Alfred due to a key mapping issue. I wanted to invoke Alfred using the same key combination I had been using for Quicksilver (^-space), but the combination was already in use, despite completely uninstalling Quicksilver. Eventually, I found a solution that involved temporarily toggling the keyboard profile from US-English to another version of English and a few other steps. Extremely inelegant.

1 Like

I removed many apps from the list of background-processing (leaving only a small number of app updaters

That would be a useful list! Can you share some of those?

Sure. Go to: General → Login Items:

From there, you can view all the apps in the “Allow in the Background” section. I disabled all but:

  • Microsoft AutoUpdate - I want these notifications
  • Microsoft Office Licensing - I’m assuming that I need this to keep my 365 subscription working

Some possibly interesting items I have disabled (feel free to point out if you think I’ve made a mistake by disabling these:)

  • Adobe Acrobat Reader DC. I’ll let it check for updates when I run it, which isn’t very often
  • Adobe Creative Cloud. I don’t use it. It auto-installed with Photoshop Elements and I’d really prefer it to go away.
  • Carbon Copy Cloner. I assume this is for the task scheduler, but since I only manually run my backups, I don’t need it there.
  • Malwarebyes Corporation. Maybe now it will stop telling me I’ve got a critical system problem which, after clicking on it, is the fact that I’m using the free version of the app and not a paid-up subscription.
  • VirtualBox. I don’t know why it wants to auto-start. Maybe there’s a feature to create VMs automatically at bootup, but I don’t use that.
  • Wireshark. I know it uses some background processes, but I use this app so rarely, I’d rather just manually start them when I need to.
  • XQuartz. I honestly have no idea why it wants to run in the background, except maybe to check for updates.

One more thing I just noticed. The Apache web server reverted back to its default configuration. I was actually aware of this from others here. And as expected, my original configuration files were stashed in /Users/Shared/Relocated Items.

The files that got reverted back to factory defaults were /etc/apache2/httpd.conf and /etc/apache2/extra/httpd-userdir.conf. I was able to compare the files against the versions in Relocated Items to put everything right again. The diffs were minor:

  • In /etc/apache2/httpd.conf
    • The user-directory module (LoadModule userdir_module...) was commented-off (disabling it). I un-commented it to re-enable the feature.
    • The line for enabling PHP was replaced with a comment indicating that PHP was deprecated in macOS 11 and removed from macOS 12. Since I’m not using PHP, I don’t care and left that line unchanged.
    • The line specifying where to find the user-directory configuration (Include /private/etc/apache2/extra/httpd-userdir.conf) was commented-off. I un-commented it to regain access to that configuration.
    • The line enabling the bundled Apache server manual (Include /private/etc/apache2/extra/httpd-manual.conf) was commented-off. I un-commented it to get it back.
  • In /etc/apache2/extras/httpd-userdir.conf
    • The line telling it to load per-user configurations (Include /private/etc/apache2/users/*.conf) was commented-off. I un-commented it.

My per-user configuration files were unchanged from before the Ventura upgrade.

A quick restart of Apache (apachectl stop then apachectl start) and we’re good to go. For some reason, apachectl restart didn’t work for me.


Thank you for this report. I think I’m likely to move from Big Sur to Ventura soon, and I will reread your post multiple times.

I have had trouble with Time Machine for about the last four Big Sur updates. (The backups always fail to complete. As far as I can tell, all my documents get backed up, so I suspect there is a permissions issue with some file outside my account space.) Would a clean install of Ventura be more likely to cure the issue than installing over Big Sur? If so, would I install using Recovery? (This is for an M1 MacBook Air.)

I have not seen that. Every Big Sur update has presented me with a login screen for the (admin) account I used to install the update.

Thank you for the details on how to do that.

Sigh. Who thought identifying the conflicting hot-key would be too confusing to the user?

Upgrade from monterey went without a hitch. Thanks.

A couple notes - I did as you suggested and went to the link you provided. I did NOT use software update but downloaded the full installer as I assumed that is what you did. Upgrade took maybe an hour, just one restart, and opened automatically to logon page. Easy peasy.

So far no app problems. A couple new notifications to set.

In addition to backups, I always disconnect (not just dismount) all peripherals before upgrade.

1 Like

Correct. Software Update is currently trying to install 14 (Sonoma).

I used the App Store link to download the Ventura 13.6 installer. Which auto-launched after the download.

Another data point for Monterey to Ventura: two Macs in my household were updated without any problems. One is a 2017 iMac, the other is a 2021 MacBook Pro.

I guess I’m overdue posting about my negative experience attempting this. I too have a 2017 iMac, 27" variety and had Monterey on an external drive. When I tried to update it 13.6 a few weeks back using a full installer it went into a boot loop after. I would get a lock-screen with login account icons and when I successfully entered my admin login credentials, the screen went black and appeared to reboot. Since I have FileVault enabled, that isn’t totally unusual, except that after a few minutes I was back to the lock-screen login again. This repeated about six times before I gave up.

I’ve tried re-installing from Recovery as well as from a thumb drive containing more recent updates of 13.6.1 betas with identical results.

There have been several reports of bricked Macs installing 13.6 that Apple has not been able to duplicate in their labs. At least one user was asked to ship their Mac to Apple for forensic examination in an attempt to identify the problem. I believe most of these to be newer Apple Silicon Macs. Hopefully they will be successful and fix things in the 13.6.1 installer when it arrives.

I also recently upgraded my 2017 27" iMac from Mojave to Ventura. I did a clean install and, after that was successful, I migrated data from a Time Machine back-up of the Mojave to the IMac.

So far no problems.

As a back-up I also used Carbon Copy Cloner to update a bootable back up of the Mojave system. I also made sure a second iMac (2014, I think - too old for Ventura) had my data so I could still run some precious 32-bit programs.

For those also still using a 2017 iMac I think Ventura is the last macOS that they can install. I noticed a significant performance improvement after the upgrade but that might be mostly due to cleaning out cobwebs after a clean install (my first in many years).

FYI the iMac I just upgraded to Ventura is iMac Retina 4K, 21.5-inch, 2017

Yesterday I tried to install the 13.6.1 Ventura update - which thoroughly bricked my 14" M1 MBP. Called 800-APPLE and after explaining that the machine wouldn’t restart into Recovery mode, the agent made a Genius Bar appt for later that afternoon. My Genius said the 13.6.1 install somehow toasted the firmware and took the machine off to Revive it (who knew?). Brought it back for an admin pwd so he could login to Recovery mode - which also failed and somehow re-bricked the machine. So, off it went again for another Revival, after which I was presented with but one choice - forget about a 13.6 Restore and update directly to Sonoma. 14.1 installed uneventfully in place and, and after two hours I walked out with a once-again mostly-working machine: Arc.app is acting strange here & there, SmallCubed Mail plugins are DOA, and I need to download (and/or buy) a few misc.updates. But yes, I can confirm: Reposition-able Desktop widgets !!

Correction. You can’t disable this. It may be part of the scheduler, but it’s also the CCC Privileged Helpter Tool, which CCC needs in order to access files your normal user account can’t access.

If it is disabled, CCC will complain at startup and probably won’t be able to back up everything you want it to back up.

And ditto for Malwarebytes. So there’s still no easy way to suppress its nagging without breaking the app. :face_with_diagonal_mouth:

And for some reason, Adobe Reader can’t update itself in the foreground - it requires you to let it run in the background in order to get updates, even when manually requested from within the app.

Yuck. In other words, it looks like you need to double-check everything you disable from the background login items, because some are required in non-obvious ways.

Same here. It’s very annoying. And I’m certain 100% deliberate to “encourage” upsell.

… And a month later, I discovered another issue.

It appears that my installation of SilverFast version 8 scanner software isn’t compatible with Ventura. It scans OK, but the app’s preview window shows only a gray screen, making it impossible to select the region you want to scan or to preview any filters.

After a bit of searching, I found this FAQ:

Quite annoying. But an upgrade wasn’t too expensive. The “SE” version (for my Epson Perfection 4870 scanner) has an upgrade price of about $35 and the “Plus” version (which includes Kodachrome support, among other things) cost about $70.

I don’t like being forced to pay money on short notice, but I’m not complaining too much, since this is only the third release I’ve had to pay for in over 20 years: Version 4 came with my scanner, then I paid for upgrades to versions 6 (when moving from PPC to Intel), 8 (moving from 32- to 64-bit) and now 9 (because Apple deleted their old color management API).

1 Like