iTunes won't sync iPhone anymore


(Simon) #1

My wife’s iPhone SE (the latest iOS 12.1.1) will no longer sync with her Mac (2009 13" MBP, El Cap with the latest iTunes supported on that OS). iTunes will start the sync, but then complain that the sync “could not be synced because the sync session failed to start”. Whatever that means. Let alone give you any idea as to what you’re supposed to fix.

So after searching the web we tried a few things. Restarted iTunes. Rebooted Mac and iPhone. Deleted all the existing iTunes backups. Reset SMC and PRAM on the Mac. Rebooted Mac in Safe Mode and tried iTunes there. None of that worked. We tried syncing over USB (even tried different ports) and over wifi. In both cases the same error message.

This came pretty much out of the blue. She usually hooks it up to iTunes about once a week to do a backup and sync. The last iTunes backup carried that time stamp so until most recently everything worked just fine. I cannot recall any software updating activity within the last few months on her old Mac. And the iPhone hasn’t done anything apart from the 12.1.1 update. I did that too and I’m not encountering any of these issues on my Mac.

So now she cannot sync iTunes content to her iPhone. She can no longer back up her iPhone. It’s a mess. And of course iTunes offers zero indication as to what the user should do to fix the issue. That was her backup. If her phone falls under a truck all her data will be gone. Right now she’s really SOL. Any ideas?


(Diane D) #2

First, make sure it’s at least backing up to the cloud.

I had to reinstall iTunes twice even though I had the most current version. I didn’t get that error though, mine said my phone wasn’t compatible. Also an SE.

I really wish Apple hadn’t nuked certain phones on older versions of iTunes. I was happy having my main database on my old G4 with a CD drive.

Diane


(Seth Anderson) #3

Have you explored physical issues with the connection? Namely, the cable, the USB connection, and the port on the phone. I’ve had troubles with all three at various times. In other words,

  1. try a different cable

  2. plug the cable in a different USB port (but you’ve tried this already you report)

  3. And finally, check to see if there is any obstruction in the Lightning port. Since I usually keep my iPhone in my pocket, it tends to collect lint and dust and who knows what all. I use a flashlight and a bent paperclip to clean out gunk, there are probably more elegant solutions described on the web. You’d think the cable won’t fit in if there is obstruction, but apparently it can, and only scraping off the “gunk” allows a strong enough connection to sync.

Since the sync used to work, and nothing drastically changed in your setup, this would be an obvious vector to explore.


(Tommy Weir) #4

My thoughts too. It’s typically physical if all things software related is the same.


(Simon) #5

Thanks, guys. It’s the same error over USB and wifi. So not likely hardware. I already tried different ports and checked there’s no lint in there. I actually didn’t try a different USB cable since I was getting the same error for wifi sync. I can do that.

I wonder if this could be related to this weird iTunes update that happened two months back or so where iTunes would give you a dialog and you had to install something when you attached an iOS device. Any ideas how to uninstall that?


(Doug Miller) #6

This is a bit of a nuclear option, but after you exhaust everything else, there is an option on the iPhone - settings / general / reset / reset location & privacy. The main function of this is to reset all of the privacy and location preferences for your apps on the phone, so this will be a bit of a pain - the first time that you run a third party app that needs access to location or a privacy permission, it will ask for that permission. However, the other thing this does is to delete the iTunes pairing relationship that the phone has stored. If that is somehow corrupted, this may allow the phone to re-establish a trust relationship with an iTunes library. Mind you, it may not be what the issue is, so that’s why I suggest trying this last. (Unless your wife doesn’t mind going through the privacy and location dialogs for her apps again.)

If I was trying to fix this, I might think about creating an account on your wife’s Mac, and trying to sync my iPhone with that iTunes “library” (knowing that I’d have to go through losing all of my media and then going through the sync process again back on my Mac later on.) But if I had the same problem, I’d guess it was something on the Mac for sure, since I knew it worked fine on another Mac.

And you can always try downloading and re-installing iTunes, in case a component was damaged at some point: https://www.apple.com/itunes/download/ - there is a link to “download for previous version of MacOS” under the “Download Mojave” button on the screen for me


(Brian White) #7

Anecdotal I realize, but this happened to me once (also on El Cap) after a long period of time with no issues, and it turned out the error was in error. IOW, the sync did take place, but something made the error message pop up. Everything worked after that, and no further incidents. I don’t recall what made me check to see if the sync had taken place instead of investigating the error further, but I was glad I did.


(Richard Rettke) #8

Were any new USB devices added recently? I have a situation where is my ScanSnap S1500M is ‘ON’ I cannot usb backup from an iOS device. Unfortunately turning it off doesn’t revolve the issue. I need to turn the ScanSnap off and Reboot the Mac. The symptom is as described in your post. iTunes simply doesn’t recognize the iOS device. So I have pretty well trained myself to ‘automatically’ turn off the Scansnap before connecting an iOS device. Have never found any other solution for this.


(Simon) #9

Thanks, Doug. I will definitely try reinstalling iTunes. That’s an easy one to check off. Your nuclear option does sound interesting. I wasn’t aware that’s where the pairing is stored. But as you say that’s quite invasive so I guess that will be more of a hail Mary if nothing else works.

I also thought about having her phone sync with a vanilla account on her Mac just to check. Problem with that idea is that presently I’m not sure what state her backup is in. I hesitate to wipe her iPhone when I’m a) not sure she has a backup that could be played back to her iPhone and b) her syncing is busted so I’m worried any changes she’s made recently on her iPhone won’t have made it back to her Mac so that when once again syncing to her account (assuming that starts working again after I’ve synced it to another account) will be lost.

This is a bad situation. It’s difficult to troubleshoot syncing when you have no backup. Or at least none you place faith in.

iCloud backup is a red line for her because of privacy concerns. She stays away form pretty much anything cloud (Dropbox, iCloud, etc.) and the last thing I’ll convince her to do is put her iPhone (essentially her entire digital life) on a cloud server. So therefore I have to rely on backing up to a Mac. And of course that seems to be busted in the same way as her syncing. :exploding_head: :wink:


(Simon) #10

Thank you, Brian. That’s very interesting indeed!

It turns out I got her iPhone to back up (not sync) through iTunes. One of the last things I tried last night was to just back it up, without syncing. I got the very same error message so at first I figured it had also failed like all other tries. However, when I then restarted iTunes and went back to the iPhone overview page I at once noticed that it says the last backup was from 8:21pm. I had deleted all older backups as part of the troubleshoot so I immediately noticed that the backup had apparently completed. Checked in Finder and sure enough a whole bunch of backed up files with that time stamp had been saved.

So, like you, it appears she’s in a situation where the error message is in error. At first I thought this would indicate the sync might have worked as well. But no luck. I tried just syncing and promptly got the error message. I then checked her music and her notes to see if a song she had just bought and a note she had just edited on her iPhone made it back to the Mac. But neither appears to have made it back so I am assuming that the sync did indeed fail as the error indicates.

I’m not sure I trust the backup and I don’t know how to check its fidelity other than to nuke the iPhone and try to restore from backup. At this point I’m not really willing to try that since she’ll have lost absolutely everything should the test fail.

I guess the good news is there’s a chance she has a backup. The bad news of course is that her syncing is still busted. Since you mention El Cap I of course also wonder if this is some kind of issue between new iOS and old El Cap iTunes. Updating her MBP from El Cap to HS is of course an option. But considering her MBP has just 4 GB RAM I hesitate to do that before I have some kind of confirmation that the bug is indeed connected to El Cap iTunes. Hehe. What a pickle! :slight_smile: -> :brick:
(where’s the smiley for slamming head against a brick wall?)


(Simon) #11

Thanks, Richard. Good point.

When I was troubleshooting her setup I removed everything else from her MBP except for power. The MBP was rebooted multiple times so I think that should have taken care of the situation you describe.


(Richard Rettke) #12

Another tool I have used in these situations where iOS device doesn’t want to connect via USB (nor WiFi) is iMazing. In the iMazing preferences General Tab, is an item called “Restart Mobil Device Services”, additionally under the Devices Tab is an item called “Remove All Pairing Records”.

When my issues have not been caused by my ScanSnap, one or both of these iMazing features has resolved the issue.

FYI, I always keep relatively current iTunes backups and syncs, but I have daily automated backups over WiFi through iMazing as well.

I find iMazing to be a pretty nice App, not perfect, but a good tool to have in the quiver.


(Alan Forkosh) #13

Several iPhones ago, I had problems with backup through iTunes. I eventually switched to iCloud backup, but tried to occasionally (and sometimes successfully) synced via iTunes. However, I switched to using iMazing (http://imazing.com) for my computer backup. There is a free download, but I am not how much functionality you get before paying. I make sure to update my Imazing backup before upgrading or making major changes to my IOS devices so that I have a local backup to restore from.


(Dennis Swaney) #14

Simon, I use iTunes 12.6.5.3 due to the fact it still supports syncing of iOS apps to my iDevices. I’m using Mac OS 10.11.6. In addition, I’m using iMazing 2 in parallel since eventually iTunes 12.6.5.3 won’t work anymore and I won’t be able to sync my iDevices to my iMac via iTunes.


(frederico) #15

You’ve received excellent advise and suggestions on this thread; I just want to add I’m also stuck on the 12.6.x track, and I, too, saw that exact same stupid ‘error: there was an error’ message just last week after applying the second-to-last Security Update.

Normally these types of Sync/backup errors are, as you originally explored, easily resolved with either a simple iTunes restart or a Mac restart; but, not this time. (I’d never go through the whole PRAM/NVRAM thing for this, but I don’t blame you, and it doesn’t hurt).

And, I, too, eventually noticed I could generate what appeared to be a successful backup, but still get the error-error message.

And, I, too, could also then not backup/sync the same device over WiFi, either (endless spinning; silent timeout on the iPhone).

But, in my case, it absolutely (seemingly) ended up being a bad lightning cable attached to my Apple-brand dock (thought I bought a pack of MFi certified cables, but they all turned out to be junk and I thought I’d gotten rid of all of them).

Now, the way I discovered the bad cable was trying to connect my older iPhone, and later my iPad, to the same dock, and finding them unable to be recognized in iMazing, nor in System Information under USB, either.

So, once I had a good cable in place, while my devices were properly mounting via USB, I still couldn’t get a good sync with the first iPhone. So, I attached it to another Mac, and when it asked for ‘trust this Mac?’ I said yes; made sure it was visible in iTunes; then took it back to my Mac and it backed up again and synced without further errors.

So, be certain your cable is 100% using another device, and try the trust on another Mac; maybe it will clear yours as it did mine.

And, FWIW, I would have no issues trusting the backup it did complete, despite the subsequent sync error; they are two different processes. And I get that you thought it prudent to remove all prior backups for troubleshooting, but why did you delete them altogether? Moving them out of the backups folder should have been enough. And don’t you have a clone or a Time Machine backup containing those older backups as a backup for your backup? I wouldn’t have any problems trusting those older, weekly backups; even if they were a month old, they’re better than nothing.

If there’s just no options locally, and no faith in what you do have, either, consider discussing just a temporary backup to iCloud with your wife; they are encrypted, and while I choose not to use them for space/cost concerns, most pundits consider them more reliable these days. You could make the backup, finish nuking the phone to factory settings, restore from iCloud, then delete the iCloud backup once iTunes is working locally again.

HTH; Good Luck (and please let us know the outcome).


(Phil Seymour) #16

This was an issue that was addressed with warnings before the updates. I also have an SE, but I l need connectivity with iTunes for several of the Apps I use often. This includes the n-Track recording app that transfers 24bit recordings to iTunes, and a few other multi track recording apps that also go through iTunes to transfer data to GarageBand. Plus I still use 32bit rate older, but very useful apps that have no replacement.

My solution is simple; Don’t update! If you like the way your phone and computer work together, be very sure that the latest versions of OS wont lock you out of useful apps that work. There is nothing in the new OS-X Mojave, or the iPhone update that you need, or will work on an SE.

Erase you wife’s iPhone and reinstall from your last backup on your MacBook Pro. I have a MacBook Pro from Mid 2012 using High Sierra and my SE works together with it. iTunes 12.6.2.20 and don’t plan to mess it up with anymore updates. ( I still use Pages 9 with all the controls available and where they belong . )


(Simon) #17

Thanks all for your suggestions. We’ve been quite busy lately so not much to report. But definitely still broken.

I had already tried wifi sync and USB sync both with same result so I wasn’t suspecting USB cable. Did try another one (Apple cable, brand new) yesterday briefly. Same issue.

The backups are of course not eternally lost. They’re available on TM and clones. But getting rid of all traces of them within the iTunes file tree was part of one suggestion I found written by somebody on the Apple board who claims to have fixed the issue that way. That didn’t solve anything though.

Re-downloaded iTunes from Apple’s website. Interestingly, this installed 12.8.1 whereas before she had 12.8, but her OS X claimed she was 100% up to date. Anyway, no dice. The “new” iTunes didn’t change anything about the issue.

This begs the question if she’d get a new iTunes at all just by going El Cap -> HS. Unless somebody could confirm HS has an even newer iTunes (my HS Macs don’t) or there is some reason to believe the iTunes syncing issue is actually related to OS X, I doubt simply updating her old Mac (and investing $100 worth of RAM into an 8-year old Mac just to keep it usable) makes much sense. That said, I’ve been wanting to upgrade her anyway. It’s just a question of how urgent this really is.

So that leaves us with basically trying the “magic” reset sync command in iMazing. I’ll see if I can get around to that over the weekend.

One last question, is there a simple way to get an installer for the old iTunes (the one with the apps)? Would that install over her 12.8.1? Any chance that could get things to work again? How about compatibility with iOS 12?


(Phil Seymour) #18

Simon
The Apple techs are the ones who took away your connectivity between the SE and Mac. Why would you act on their suggestion? Get older versions of iTunes and iOS from your MacBook Pro backups.

Phil


(Curtis Wilcox) #19

iTunes versioning is independent of macOS versions. iTunes 12 requires OS X 10.10.5 or later, I think for earlier versions of OS X can use iTunes 11.4 going back to OS X 10.6. The App Store lists version 12.8.1 as being released today (12/14). You can download some previous versions of iTunes from Apple but any version released before August probably isn’t compatible with iOS 12 devices.

There’s also the “special” version of iTunes with the app section which is meant for “certain business partners” that need to keep using it to locally install apps instead of Apple Configurator. The installer says it’s version 12.6.5. I think it’s compatible with iOS 12 devices. When it’s installed, it won’t be updated through the App Store or within itself, you need to manually download and install new versions, if there are any. If it’s installed on a Mac that has used a version later than 12.6.5, I think it will rebuild the iTunes Library index files.


(Seth Anderson) #20

I have one last long shot suggestion. I remember when I was in El Cap, sometimes syncing would fail and my solution was to toggle off the different categories of items being synced (music, photos, books, etc.), and try syncing. I suspect there was something wonky about one of my libraries (perhaps Photos, I still sometimes can’t get it to sync), and only by removing categories, would the sync work properly. But I never properly solved the issue, just found a way to work around it.

When this happened to me (several times, sadly, and I filed many bug reports to Apple about it), I would remove, for instance, all my music, which deletes it all off the phone, and then laboriously add back playlists and sync. It was a total pain, but at least I could use my iPhone as an iPod again. Or as a photo library.

I also vaguely recall there being trouble with syncing voice memos for some reason.

tldr version: Before doing the so-called “nuclear option”, try toggling off music/photos/etc. and attempting a new sync.