If you are on Big Sur get 11.6.7 update ASAP

I am stuck on Big Sur as I have a 2014 iMac. I keep it up to date but just had a series of problems in which the OS refused to open files and apps claiming I didn’t have the right permissions.

I called Apple Support who quickly determined that the fix is in the 11.6.7 update. I installed this and it seems, so far, to have solved the problems.

11.6.7 doesn’t seem to have been advertised as available. So if you are not there yet I recommend you use System Preferences > Software Update to get it.


There’s my answer before I had a chance to ask the question! I was experiencing this issue with the 11.6.6 version. Very annoying to double-click on a PDF attachment and have Preview claim it doesn’t have permission to open the file. I think I accidentally discovered the workaround of quitting Preview first.

My iMac is still on Big Sur; I updated my MBPro to Monterey a couple of days ago. I think I’m now in a place where major OS upgrades happen when the next OS is announced. :slight_smile:

Thank you!

Let us know how it goes. This is likely to be my plan as well. I was hoping that 12.4 would fix the Finder’s memory leak, but it appears that it did not. But maybe that doesn’t matter too much. I rarely log-off or reboot my Mac, but I also rarely use the Finder’s Find feature, which is where the memory leak is.

On the other hand, Ventura is the first release in a while that has new features I actually find interesting (updates to Messages, Passkeys, iPhone camera with desk view, and Freeform), so maybe I’ll just wait until I hear reports of a stable release and upgrade to it at that time.

So far, Monterey seems pretty good. I don’t use Finder at all, preferring the feature set of Path Finder, and especially now that it seems stable again after a major rewrite a couple of years ago.

The one gotcha I’ve run into was a compatibility bug in Dropbox that is still not fixed in their public stable release. They encourage users to allow beta versions of Dropbox to be installed, because the bug (which has to do with online-only files) is “fixed” in the beta. I’m doing that reluctantly, because my Dropbox files are synced across all my devices and I’d hate to lose one, or a bunch, to a beta bug.

Overall, the MBPro seems to be running smoothly after a full Spotlight scan. That machine will be the bottom of the upgrade barrel for Ventura, so I’m already thinking about what happens with it after the next release. I’ve never been truly happy with it, and I’d really like the ports that Apple added back on the 14- or 16-inch models. My next gig is going to include a lot of video editing.

For now, though, Monterey seems to be happy on this machine.

I did the 11.6.7 update yesterday, today I discovered nothing would print from my M1 MacBook Air. All apps, using both (older) printers would fail with a “Stopped - Filter failure” warning in the print queue. Tore my hair out for 2-3 hours trying to troubleshoot, the biggest problem being that there is no simple way to roll back to the previous OS version. Back in the good ol’ days I’d just pop in my backup HD that I do before any software update and duplicate the data & OS back onto the laptop but that’s no longer possible. (Please, tell me I’m wrong!) Printing was working fine using an older MBP/OS 10.13.6 so I knew the network & printers were not the problem

Among the things I tried was resetting the printing system and re-adding the printer drivers. The Brother MFC-7360N seemed to add OK, but still wouldn’t print from any app, same failure. The Canon MP490 failed to add–“Could not communicate with the printer.”

Long story short…I happened to click on the Scan button in the Brother print queue and got a dialog asking if I wanted to install Rosetta to use the “older software” in my system. Uh, sure. And that was the fix.

Does that mean that the 11.6.7 update left out Rosetta? I don’t know, but hoping this is helpful to other Big Sur users that encounter printer “Filter failure.”

Rosetta (like its PPC-Intel predecessor) is not automatically installed by macOS. The first time the system thinks you need it, it will ask you to install it. Then it will be downloaded and installed.

If it asked you, then you probably hadn’t installed it yet. If you had, then the macOS update didn’t upgrade it and the button your clicked just installed its update.

Right. I should have said, “Does this mean the 11.6.7 update removes Rosetta?” I do remember being asked to install Rosetta the when first running the MBAir after the initial data migration just about a year ago, on the shiny new version of Big Sur that came preinstalled.

I’ve not had to reinstall Rosetta on any of the subsequent Big Sur updates (until 11.6.7) nor have my printers failed to print, and if this is what caused the print failure it seems a very clumsy failure mode. Onward!

Step by step Apple is making it necessary for me to replace my 2014 27" Retina iMac with a machine that will run Monterey, Ventura, and beyond. There is little in these ‘upgrades’ that I actually need or want but as more and more of the earlier OS’s cause problems this will become inevitable.

I believe that the Brother Print Queue software was long ago updated so as not to require Rosetta. Make sure you have the latest version available from the App Store.

Yes. Rosetta is deleted every time an update is installed. I suspect that is in hopes that all your apps have finally been updated to no longer need it, saving you drive space.

I installed macOS 11.6.7 last weekend. After installation, which was uneventful, Time Machine took three tries and several hours on the Time Capsule over Ethernet, but it completed a backup for the first time since I installed macOS 11.6.5 in April. (The external, spinning disk that Time Machine uses completed its first backup since April on its first attempt.)