How to share Music (formerly iTunes) library?

How to share Music (formerly iTunes) library?

I have a large iTunes music library on my Studio M1 Max running Sonoma. My lovely bride would like to access the library from her laptop, a MacBook Pro (Retina, 15-inch, Mid 2015 running Mohave) that is on the same home network.

On my Mac, I have turned on Media Sharing and File Sharing in the Sharing section of System Settings. Theoretically, on her laptop, I should see my Library in the left column of her iTunes, but I don’t see it. I can find no other way to see my Music library in her iTunes.

Researching on the web, I ran across a clue that both computers had to be signed in on the same Apple I.D. I tried that, but found no difference.

Surely there must be a way to accomplish this task. Any clues or tips as to what else I can try would be most appreciated.

1 Like

Can you access any other Bonjour-based services (e.g. file sharing) from her laptop?

I ask because some routers will not propagate multicast packets between a wired Ethernet network (how I assume your Studio is connected) and Wi-Fi (how I assume the laptop is connected). If multicast won’t pass between the two network segments, then Bonjour device discovery won’t work properly. Devices on the Wi-Fi may be unable to see devices on the wired network and possibly vice-versa.

I experienced this years ago where the culprit was the Actiontec router that Verizon provided with their FiOS service. When I disabled the Actiontec’s Wi-Fi and connected a separate access point (a Linksys router in bridge mode) to one if its Ethernet ports, the problem went away.


Sitting at the MacBook Pro laptop (which is connected to the local network via wireless), I can sign into the wired Studio Max and view all the files. I can also connect via Screen Share.

Does that meet the criteria of a Bonjour-based service? If so, I guess the answer is yes, I can.

Did you go to the media sharing menu where your library is and Turn Media Sharing on, then click on the i to the right and select Share Media with Guests

I just checked again, but this is what I described that I did in my initial post. Media Sharing, File Sharing and Screen Sharing is turned on.

Having said that, I don’t see “Share Media With Guests” as an option. Where would I find that?

Depends on how you’re doing it. If you’re typing in an IP address or using a hostname from a DNS server on your LAN, then no.

If you’re using a multicast-DNS hostname (e.g. mymac.local) or if you’re using the Go → Network command (⇧⌘K) from the Finder, then you are using Bonjour services.

Same for network peripherals like printers. If you’ve got a printer on the wired network and your laptop just sees it without any explicit configuration, then that’s also Bonjour discovery in progress.

From the laptop, I’m using Finder-Go-Connect to Server-Browse-“double click on Mac Studio”-then selecting either “Connect As” or “Share Screen”.

The reverse works also; going from the Mac Studio, I can connect to the MacBook Pro.

Check the IP address on both computers. If they are not both on the same segments (ie: one is and the other is then this can cause Bonjour propagation issues, as mentioned.

The easiest solution might be to have your Mac Studio join the same wi-fi network as the laptop. Even tho the Studio is wired, it can be on both networks at the same time. (By default, the ethernet connection will take priority.)

1 Like

Please try restarting your home router.

I don’t know if the problem for me has been with Apple or the router itself, but often I have found that Bonjour-related issues only get fixed by restarting the router. Things like printing to my
WiFi printer. Possibly AirPlay.

This is what it looks like in Monterey which should be similar to yours:

After clicking Options, you get this screen:

Screen Shot 2024-01-20 at 10.47.31 AM

As someone mentioned regarding the IP address, you would need to be on the same subnet I think.


The Sonoma windows are slightly different than the Monterey windows, but now that I know what to look for, I was able to find “Share Media with Guests” and enable it.

Still can’t see the Studio’s music library in the MacBook Pro’s iTunes music library listings, but perhaps I’m now a step closer to figuring out the problem.

I’ll be restarting the Ubiquiti Amplifi router shortly to see if that makes a difference.

Yup, we’re all on the same 10.x.x.x network. Good suggestion though.

There could be some issue since you’re running a newer system using Music and the other computer is using iTunes under Mojave. I wonder if you have home sharing turned on for the Mojave computer? I don’t know if that matters.

One other thing in iTunes: under Preferences/General, you need to have Shared Libraries checked otherwise they don’t show up in the sidebar.

Hmmm. The iTunes in Mohave running on the laptop doesn’t look like that (photo below).

Under the Sharing tab, I do have “Share Library on my local network” turned on (photo also below).

On the Mac Studio running Sonoma, the Music preferences “General” looks nothing like your example. (photo below)

Image 1-20-24 at 12.10 PM

I have enabled sharing on both computers, but can’t see the music library of either on the other.

I can share screens each way, so the computers are definitely seeing each other.

The iTunes version I use is much older that’s why. But look for shared libraries in your sidebar and under view options possibly.

The Music app since Catalina accesses home shared libraries differently from what iTunes did. This tripped me up a couple of years ago.

See Use Home Sharing to share media from a computer to other devices - Apple Support

So, in the Sidebar, you click Library and it should reveal available home shared libraries from other computers on the network.

I was excited that the problem’s solution could be that simple, but alas, no. Mohave’s iTunes “View Options” doesn’t offer that option.


On the laptop running Mohave, I had been looking in the left column labeled “Library” and not seeing alternative libraries.

I just noticed a pop-up option immediately ABOVE the library column whereby I could select OTHER libraries. And there was the library that resides on the Mac Studio.

Thanks to all who spent their valuable time helping me to figure this out. As is the case with many problems, the answer was simple once the correct one was figured out.

Screen Shot 2024-01-20 at 12.28.52 PM