Firefox 91

Originally published at: Firefox 91 - TidBITS

Adds comprehensive logic for clearing cookies and makes it easier to see which Web sites are storing local information. (Free, 127 MB, macOS 10.12+)

One thing for sure at this moment the new Firefox 91 runs a good bit better and seems to be much more flexible than the current Safari!

91.0.1 released today.

Has anyone else had Firefox 91.0.1 (I skipped 91.0, so don’t know about it) change the appearance of sites? I use the System theme with no modifications or enhancements, and the icon in the lower left of a Google Maps tab is blank, as well as some backgrounds on National Weather Service forecast pages.

Yes! Royal Games was very different-looking, and some others were altered somewhat. I would
almost call them skeletal. Also, my computer kept restarting for no reason after I got Firefox 91.0,
and finally stopped after about a week. I now have Firefox 91.0.1, and the weird appearances are
still the same.

It’s a Firefox 90 issue (and Firefox 91 during the brief time I had it installed), but has anyone else’s installation started giving an endless spin by Checking for updates after choosing Firefox > About Firefox? Any idea what file (if any) in the profile I should delete to fix this?

Sounds more like a problem with the application upgrading itself than anything within your profile. I would quit Firefox, move it from /Applications/ to the Trash, download a fresh copy and drag it in to /Applications/.

Thanks, I’ll try that. I should have said that I already tried a variation on that: I downloaded a fresh copy and dragged it over the existing copy (after quitting Firefox, of course), replacing it. I think the two procedures should be identical, but it’s little effort to try what you suggested.

One other peculiarity to my setup is that Firefox is in a subfolder of /Applications/ (along with other non-Apple applications). It has been that way for years and has not been an issue in the past.

It could be something messed up in your Firefox profile. Here are some things you can do to try and diagnose this:

  • Start Firefox in Troubleshoot Mode (aka Safe Mode). Either select it from the Help menu or hold down Option while starting Firefox. See also Diagnose Firefox issues using Troubleshoot Mode. Many Firefox features (including add-ons) are disabled in this mode.

  • Create a new user account on your Mac, log in to that account and launch Firefox. It will get a completely new profile. If that works fine, then the problem is something in your profile.

  • You can also set up multiple Firefox profiles for a single user using the Profile Manager. Like with a new user account, if the problems go away when you’re using a new profile, then the problem is something in your original profile. See also Profile Manager - Create, remove or switch Firefox profiles

If you confirm that there is a problem in your profile, you can do one of the following to try and fix it:

  • Start tweaking your configuration to see if you can eliminate the problem. This will be time consuming and may not be effective if there’s something corrupt in one of your profile’s files.

  • Create a new profile, make it your default and just start using it. Manually copy/install over your bookmarks and settings. This should work, but it may take a while, especially if you want to copy over things like saved passwords.

  • Use Firefox’s Refresh feature to reset your profile. It will preserve your bookmarks, history, passwords, cookies, auto-fill data and custom dictionaries. It will reset most other configuration settings. Your old profile will be copied to a folder on your desktop, so you can access it (or re-install it) afterward. See Refresh Firefox - reset add-ons and settings.

The fact that you have it installed to a sub-folder within Applications shouldn’t matter.

1 Like

The problem did go away in a new profile, and the problem went away with a refresh, so the issue seems to be something in my profile.

I’ll think about this. It’s a minor inconvenience to have Firefox unable to check for or install an update, and it would be a major inconvenience to enter web sites and passwords.

One interesting aspect of this is that Firefox seems to know there is an update, because it encourages me to install it. It’s just when I go to Firefox > About Firefox or Firefox > Preferences and look under Firefox Updates that I see the endless spinning.

For me, the different look is only under Big Sur (on two different computers). Under Mojave, the old look is still there (on two different computers).

If refresh worked, then I’d stick with that and then manually add back the add-ons (extensions and themes), search engines and toolbar customizations, as required.

I would also suggest checking for the bug after each item you reinstall, just in case one of them was the cause of your problem.

If you want to try and diagnose this further, you can compare the prefs.js file from each profile (the refreshed one and the original) to see all of the configuration differences (including internal ones not directly settable using normal means).

You can also visit the about:support page (The Help > More Troubleshooting Information menu item will take you there) to see a massive amount of information about your installation. You can generate this page for each profile and compare them to see if there are any interesting differences. (There are buttons to copy the contents to the clipboard, so you can paste it into a text file for easier comparison.)

1 Like

For the strange affect on the websites, go to System Settings/Accessibility/Display and turn off Increase Contrast.

Thanks for the tip. I did that, and both my newspaper sites are back to normal, and
my Comcast site looks the way it used to, also. Royal Games looks right again;
some games still wouldn’t play, but it has been funky for quite a while, so that’s
not surprising.

I’d love to have better contrast, too, but it’s a worthwhile trade-off. Appreciate the
help.

That fixes the web site problems (at least on the iMac; I haven’t gone back to Firefox 91 on the MBA yet). Thank you.

I’d really love to have better contrast. It seems to be a choice between having web sites usable or having the rest of the Mac look decent.

With only macOS tools, is there any way to set up a one-button switch to toggle Increase contrast?

If you mean toggling it for the whole Mac, in System Preferences > Accessibility > Shortcut, you can check the “Increase Contrast” box to add it to the list of accessibility shortcuts listed in a dialog when you press Option-Command-F5. Checking “Show Accessibility status in menu bar” gives you a control there for turning it on/off.

Additionally, in System Preferences > Keyboard > Shortcuts > Accessibility, you can check the Contrast option to enable keyboard shortcuts to Increase contrast (Control-Option-Command-.) and Decrease contrast (Control-Option-Command-,). That’s actually a bit different because each press changes the contrast only a little and affects the whole display. It’s more like messing with a monitor’s settings rather than the application “chrome” adding highly visible borders to things. This incremental contrast adjustment never triggers Firefox’s new feature of enabling its High Contrast Mode, overriding a website’s color choices, when the macOS “Increase contrast” checkbox is checked.

If you only meant being able to toggle Firefox’s High Contrast Mode, in Firefox Preferences > General > Colors > Override the colors specified by the page with your selections above, “Only with High Contrast themes” makes Firefox honor the macOS setting and the other choices “Always” or “Never” use Firefox’s High Contrast Mode. That’s not particularly convenient for changing the setting.

Firefox’s “under the hood” settings are accessed through about:config, you can filter them to show what you want. The relevant preference is browser.display.document_color_use, these are the possible values and their effect:

0 => detect preference from system settings (default) to choose between page’s colors and user’s colors
1 => always use page’s colors
2 => always use user’s colors

I can’t direct you to one but it’s possible there’s a Firefox browser extension that let’s you create your own options to toggle Firefox settings from the extension icon.

2 Likes

Thank you for the lucid explanations and details.

That is not exactly what I thinking, but it is just as good. Thank you!

I’m not sure how many “quite a bit” changes one can make with a single slider, but it sure looks to me like each press makes quite a bit of change. Worse, it gets ugly after one press. I had found (and rejected) this capability before posting my whine about usable web sites compared to the Mac looking decent. “Ugly” is my opinion, of course.

Thank you for that. Always before, I had been content with the defaults and had not looked at altering the look, so it didn’t occur to me now. I will look at that.

I was aware of about:config, but almost exclusively as either a source of wonder at the variety of settings or as specific entries that I toggled on special occasions. Thank you for alerting me to another specific entry that I might tweak on special occasions.

I’m just not an extension person, except for really great needs. The contrast problem would have fallen into that category, but you already solved it for me. Thank you again.