Dictation/Siri Problem with Studio Display

I love the new Studio Display, which I have cabled via Thunderbolt to a Mac mini M1, running Monterey 12.5.1. My problem is that Dictation starts with a keypress - (little mic icon pops up) but It ignores my voice. The Studio Display has the latest firmware update.

The mic works fine in Zoom, Office 365 dictation, etc. It’s only in Mac OS (Siri, dictation) that it doesn’t work. It SOMETIMES works when the Mini is first booted but then quits in a minute or two.

Things I’ve tried:

  • Turned Dictation off and then on again in System Preferences (no effect)
  • Tested on same machine with generic Admin account (worked fine but I may not have given long enough to fail)
  • Booted into Recovery Console and ran disk first aid on system volumes (no effect)
  • Started with extensions off (dictation didn’t work at all)
  • Used an external mic (headphones - worked fine)
  • Rebooted the Studio Display (no effect)
  • Reviewed web answers (no effect)

Open to suggestions…

In System Preferences > Keyboard > Dictation, I see a drop-down menu beneath the microphone icon (see screenshot). I seem to have “Automatic” selected (by default). I wonder if choosing a specific microphone here (presumably the mic in the Studio Display in your case?) might help.

Yep, tried that too (but forgot to mention it).