Can't AirDrop from iPhone to Mac (but can from Mac to iPhone)

I wonder if anybody has an idea about what’s wrong.

  1. Notes and Photos are synching via iCloud and my iPhone. So iCloud itself is working ok it seems.
  2. I can copy text from my Mac and paste it into my iPhone.
  3. But I can’t copy from my iPhone and paste to my Mac. I can’t AirDrop photos to my Mac like I usually do either.

I’ve tried restarting both devices. AirDrop seems to be on. And both devices are up-to-date with the latest OS versions.

Any idea why I can’t AirDrop from my iPhone to my Mac?



I had this issue but in reverse. The solution from the link below fixed this issue for me:

For some odd reason my own contact was placed on the block list. Not sure how it ended up there but that was the issue. In Settings>Phone>Call Blocking & Identification, check to see if your personal contact info is under the blocked list and unblock it. This fixed my issue instantly!

Yes, somehow one of my own email addresses had become blocked - I know I didn’t do this so seems like a weird Apple bug.

You might need to check the blocked contacts on the Mac side for your issue but try iOS side anyway.

1 Like

There was nothing I could see on my Mac side. The only place I could think of to check was iMessage contacts, but I wasn’t in there.

On the iPhone side in Settings > Phone > Call Blocking & Identification there is one item in there that is turned on: My SoftBank. SoftBank is my cell phone provider.

The blocked list itself is actually in Settings > Phone > Blocked Contacts. I’m not in there.

So I’m afraid I’m still stuck.

I just contacted Apple Support. They had me test with another device (copying text from my iPhone X to an old iPhone 6 Plus). That worked, so I tried again to do it to my Mac and it worked.

So obviously the solution is to simply contact support and magically it gets fixed.

Sometimes I have to go to the Go To menu of Finder on the iMac and manually select Air Drop to make the iMac visible to other devices. This is intermittent and irritating but there doesn’t seem to be a permanent fix.


I have experienced the exact same thing. By now, I usually just go there on my Mac first without waiting to see if it works by itself (the way it should) or not.

It’s a pain, but it also strikes me as just another one of these unpolished corners where things don’t just work. Apple, this is what people mean when they talk about software quality having deteriorated. Care to detail used to be an Apple hallmark.

1 Like

AirDrop and Universal Clipboard are complex technologies with a lot of moving parts (at least two devices, Bluetooth, Wi-Fi, and iCloud, at minimum), and in my experience, they work pretty well now. In the early days, that wasn’t true at all, and I didn’t use them for years because of it. Things improved a lot with newer hardware and with new versions of macOS and iOS.

I now use AirDrop to transfer all iPhone screenshots to the Mac for editing and posting in TidBITS articles. Universal Clipboard has also been a boon on occasion, though my experience is that it works only if you copy in one spot and quickly go to paste in the other—waiting too long clears the clipboard.


You know, @ace, the odd thing for me is that between iPhones it works like a charm. My wife and I exchange multiple documents from iPhone to iPhone basically every day and it essentially always goes through without a hitch. But then I take my iPhone (latest model, latest iOS) and try to do the same with my MBP (latest model, latest macOS) and this awesome thing breaks down to hit or miss. It just feels very much like the Mac side of this need a serious look.

1 Like

That was my experience before I got new Macs. I wonder if there’s a Bluetooth setting or the like that’s an issue?

1 Like

A few years ago, there was a situation where an older Mac wouldn’t show up in AirDrop unless you went into a special mode. Perhaps this is some vestige of that. Here’s an old article that mentions it: AirDrop Not Working? Use Compatibility Mode for New Mac to Old Mac AirDrop Support

It doesn’t sound like that. While my Mac is old (late 2013 MBP retina) it doesn’t seem to fit into the category of “old” in that old article.

Anyway, it just has happened one time in all the years I’ve had it.


1 Like

Like Adam, I find AirDrop and clipboard sharing pretty reliable these days, but I’m still using an old mid-2013 MacBook Air (on Mojave).

AirDrop occasionally doesn’t show the device I want to send to, but I’d say it works 95% of the time (and there’s no consistency as to what doesn’t show up, sometimes it’s a phone, sometimes it’s a computer).

Clipboard sharing seems to be magic to me – what I want is always available on whichever device I need. Whatever the parameters are for how long something is available, it’s tuned just right for my use, and I use it all the time.

Overall, I feel these features are actually one of the positive examples of Apple’s software features and quality. It’s pretty seamless and so well integrated. I can’t imagine how people cope with Android+Windows (unless something similar exists between those two platforms).

1 Like

It’s one of the main things I like about the Apple ecosystem as well. And one of the main things I mention to Windows friends.

Anyway, it seems to have been a one time problem so far.

1 Like

And yet, once again it works flawlessly on mine, just the way it should. Is it possible any of you are having interference from some of the applications you downloaded? I have a 2014 MBP, and an iPhone X. I am running developer betas of iPhoneOS and BigSur.

One thing I do every year, with every major OS update, on my MAC is a clean install. That makes sense for me because of all the betas I load, and it does not take much time with iCloud backup and a USB. I use an install disk (maybe there is an easier way, but that is the way I learned and I’m sticking with it).

There is also no interference on bluetooth and wifi, that could be an issue. I have reset bluetooth and reset the SMC from time to time as well.

Honestly, with. few people complaining about little gotchas here and there that I never seem to have, I’m sticking by my approach.

I’m all but positive it’s bluetooth related. Behavior was very erratic --eliminating all 3rd party apps And restarting multiple times was slightly helpful but a pain and didn’t always work.

Eventually I discovered that when I reduced the # and/or type/brand of bluetooth devices from my Mac was nearly always (95%) reliable. (I was using a JellyComb BT keyboard and a " Logitech MX Anywhere 2S Wireless Mouse") – seems the combo of the 2 required too much BT power.
I’m now writing this using my old reliable Apple Wired Keyboard - and have only once lost AirDrop during the 3 or more months since I switched back. Haven’t tried w/ different mouse, and wireless keyboard – but I don’t think I had the problem till I switched to the “recieverless” mouse.
Should it Matter:
Unlike many of the posters I’m running on an 'old" 2014 iMac, which I’ve kept on Mojave. So it’s not likely machine or System version related. – it could however be related to new security constraints added by Apple, rendering BT communication more difficult.
Just my 2 cents

Well, here I was about to say how it’s only happened to me one time ever. And now it’s happening again this morning. I can’t AirDrop from my iPhone to my Mac. I can in the other direction though. And I can AirDrop my my iPhone to another older iPhone I have. I tried the Finder > Go to AirDrop suggestion, but that didn’t fix it.

I still don’t know what fixed it last time.

And it just started working again. Hmm… Maybe the Go to AirDrop did something, but it was a delayed reaction?

AirDrop is one of those magical things that just doesn’t work sometimes…then works again…the. Stops again on another device. Sort of like Time Machine to a remote server…it’s magic and the magic doesn’t always happen. I solved the TM issue by building some CCC jobs and usually do the AirDrop one when it happens via Messages or DropBox depending…

AirDrop has a very interesting behavior. It uses Bluetooth to discover a peer, and then sets up an ad-hoc Wi-Fi network for the actual data transfer. It does this even when it is not necessary (e.g. when the two devices are both connected to the same Wi-Fi network.)

I see this at home. My Mac mini is connected to my LAN via Ethernet. It is reachable via Wi-Fi because my router bridges the Ethernet network to the Wi-Fi network. Despite this, when I want to AirDrop between the Mac and my phone, I need to enable the Mac’s Wi-Fi interface. It won’t work without it even though the phone’s existing Wi-Fi connection can talk directly with the Mac. (I normally leave Wi-Fi disabled on the Mac because it sometimes ends up auto-connecting to my Wi-Fi network despite the fact that it is configured to not do so, and I only want it using Ethernet for LAN connectivity.)

I wonder if some of the AirDrop flakiness might be related. For instance, if the Mac isn’t using Ethernet (meaning it is using Wi-Fi for all of its connectivity) and is actively transferring data, it might not be able to switch itself over to AirDrop’s ad-hoc network fast enough before the phone times out.

1 Like

If you have the Ethernet interface listed above the Wi-Fi one in the network System Preference, your Mac should use Ethernet even if it’s connected to a Wi-Fi network. That is, the interface order in the list on the left is actually the priority order. You can drag to rearrange network interfaces into the order you’d like.