Broken macOS installers

On several occasions, I have attempted to install various MacOS versions using the appropriate installer file (downloaded from the App Store) only to be told they are corrupted and can’t be used. Again, these are the installer files (5 - 6 GB) that I obtained on the App Store and then saved to a thumb drive for future use. I have been successful a couple of times as well using (I think) the same method.

Any idea as to why these files won’t work. Is is related the signing certificates? Is there a way to fix this?

If the problem is the certificate, you can work around that by changing your Mac’s clock. I wrote about this here:

Transmission error is also a likely suspect.

Most have proven to be incomplete downloads (especially these days when the installers are significantly larger) and are easily corrected by deleting and re-downloaded. It’s helpful to know the exact size that the installer should be, but that information tends to only be available from other users who have had a successful experience.

Thanks everyone, I really appreciate the help. Turns out it was outdated signing certificates which Adam had referenced in an earlier post:

I was able to download a current installer and it worked! I also checked out the clock adjustment – great idea as well.

FYI- don’t use previous installers that were saved prior to 2020 (e.g. dated prior to October 2019). Apple released new cert-versions of their installers (good till 4/2029). I know, as I would keep a USB flash drive with 10.11 through 10.15 installers, and combo updates. The funny thing here is, when I am wiping a mac to re-install, one can just do the Cmd-Opt-R (or Opt-Cmd-R) to Internet Recovery and if not Snow Leopard or older, you can install the version that it came with. Startup key commands.

That’s good to know.

So, related to this: There is a page on the Apple site with links to updated installers:

Links to older version (Yosemite, El Capitan, Sierra) download an image file – works great. Links to newer versions however (High Sierra, Mojave, Catalina) send you to the App Store, but I can’t find them there. Any idea how I can get the installers for those “newer” versions?

Just tried the link for High Sierra in Safari, the AppStore app opens (i’m on Mojave) and opens the page for High Siera with an enabled download button in the top right corner. What are you seeing?

That’s it. Just click the download button and the installer will be downloaded to your Applications folder. The installer will try to launch but tell you it’s too old for your version of macOS and display a Quit button. Click the Quit button and the installer will still be in your Applications folder.

Safari is the key. When I try it on Firefox, it asks me to select an app to open the link (defaulting to Music, which doesn’t work). When I tell it to open the link in the App Store app, the App store displays a “Loading” message for a little while and then says it can’t connect to the App Store.

So if I try it in Safari, the app store opens to the High Sierra page. There’s a button that says “Open.” If I click that, I get a message that “This copy of the Install macOS High Sierra.app application is damaged and can’t be used to install macOS.”.

Same thing happens with Mojave.

With Catalina, the “Open” button is replaced by a “Download” button which does work.

So, I’m not sure what this means. Is Apple doing something different with the Mojave and High Sierra installers than they are with Catalina? Does it have something to do with my system (I’m on El Capitan)?

The presence of an “Open” button means the installer is already present, so the App Store tried to open it instead of downloading a new copy. And (since that failed), it looks like the copy you’ve got is either corrupt or has an expired certificate.

Look for and delete the existing installer (look in the Applications folder, or see if you can find it in the Launchpad). Once you do, the App Store should present a “Download” button instead of an “Open” button.

1 Like

Ah-ha! Thank you so much.

Lots of folks have had this problem when downloading previous versions of the Mac OS. They go to launch the installer and they get a message that says that it is damaged and won’t work. This actually isn’t true. The installer has an expired certificate. This is easily fixed:

  1. Go into the Applications folder.

  2. Find the Installer for macOS 10.xx, that you downloaded, in your Applications folder

  3. Right-click (or Control-click) on the installer and choose “Show Package Contents”.

  4. Open the folder named “Contents”.

  5. Open the folder named “SharedSupport”.

  6. Delete the file named “InstallInfo.plist”.

  7. Enter your administer password to confirm.

  8. Now the installer for MacOS 10.xx will work perfectly.

You can also get around an expired certificate by resetting your Mac’s system clock to a date before the certificate expired.

Both methods should work, because the problem is that the installer is time-bombed.

However, the method that I suggested above will remove the time-bomb, not just work around it. So your copy of the installer will now work perfectly in perpetuity.

1 Like

I had a problem with the Catalina installer recently. It appeared that it would say it was corrupted if I tried to launch it from the desktop, but not if I launched it from the Applications folder as Apple expects. I seemed to see this behavior twice with two separate downloads, but I may have jumped to the wrong conclusion.