Bluetooth Will NOT Connect

iPhone 12 Pro (iOS 16.2) and M2 MacBook Air (macOS Ventura 13.1) are paired but will not “Connect” despite:

  1. Turning Bluetooth on/off;
  2. Forgetting and re-pairing;
  3. Rebooting/restarting each device;
  4. Running terminal command sudo pkill bluetoothd

Same devices connected over Bluetooth before the first time I used the iPhone as a webcam via Continuity Camera, which worked fine.

Now they pair just fine but will not connect.

I think that the problem is with the MacBook Air (as opposed to iPhone) since iPhone connects to my Apple Watch (Series 7 watchOS 9.2) but Mac does not even see it so can’t pair (much less connect). Likewise, watch used to connect and supported automatic login on Mac before playing with Continuity Camera.

What else can I try?

UPDATE December 26, 2022 8:18 PM

After searching on TidBITS Talk, I found this post and I it occured to me that perhaps my problem is also asymmetric, which it is.

What I mean by asymmetric is that on the Mac I can Forget the iPhone and re-pair it. Yes, on the iPhone, after Forgetting the Mac, the Mac soon appears in the list of “Other Devices” in the iPhone’s Bluetooth settings. However, why I try to pair the two devices from the iPhone, I get this error message: Pairing Unsuccessful “” is not supported.

Such asymmetry was also reported in this post, but I am not trying to use Sidecar, and, nevertheless, no solution was posted.

This post concluded that a (USB) connection problem between an iPhone and Mac was due to VPN software being installed on the iphone; I don’t have VPN software installed on my iphone.

I posted my problem on discussion.apple.com and will post here any useful responses that I get there.

Thank you for reading this lengthy post.

Sorry if I’m just being dense, but…afaik, you don’t “pair” phones and Macs. Pairing is for connecting a Mac or a phone to external speakers, AirPods, your car, etc. To wit, when I look at the Bluetooth menu on my Mac, or the Bluetooth settings on my phone, neither device appears in the other’s list of paired devices. So I guess (again, unless I’m missing the obvious), my question would be, what is it you actually want to do were you able to establish the connection you’re trying to?

1 Like

From my iPhone, I can see my MacBook Air (named Descartes 2):

Likewise, from my MacBook Air, I can see my iPhone 12 Pro:

AirDrop, Continuity Camera, and many other Monterey and Ventura features require that an iPhone and Mac:

  1. Be logged into the same Apple ID,
  2. Be on the same WiFi network,
  3. Be connected—not just paired—by Bluetooth.

In this particular case, I wanted to transfer pictures from my iPhone to my Mac and the simplest way to transfer them would have been AirDrop.

Yes, Bluetooth needs to be on, but you do not need to pair an iPhone with a Mac to use AirDrop or other Continuity features. I see exactly the same thing you do with my iPhone being discoverable by my Mac and my Mac being discoverable by my iPhone, but they have never been paired and have no trouble using Continuity features.

Thanks for the explanation, and the screen shots. Afraid I’m out of ideas. You’re seeing something I’m not, yet AirDrop works fine for me between my phone and my Mac. :man_shrugging:

After @ace ’s post I did some more testing and discovered that:

With AirDrop discovery on both Mac and iPhone restricted to Contacts:
AirDrop Mac → iPhone works
AirDrop iPhone → Mac does NOT work

With AirDrop restriction on iPhone still limited to Contacts but on Mac changed to Everyone:
AirDrop works both ways.

But that’s when I noticed that when my iPhone AirDrops to the Mac, it displays the name of the Mac, not the name of a contact.

There is something very strange about my Apple ID login.

I wonder if Apple is confused about two different MacBook Airs (MBAs) that have very similar names. My old one (mid 2012) is/was named Descartes before I erased it (in preparation for selling it) while the new M2 is named Descartes 2.

I realized that my picture isn’t displayed on either my M2 MBA or my iPhone at the top of Settings. And then I noticed that there was no way to sign out of Apple ID on either device.

So, I tried resetting the password and couldn’t get that to work on either device. Then the password reset prompted me to try the password reset from another computer logged into the same Apple ID, which would be my iMac.

I succeeded in resetting the password on the iMac, but my M2 MBA doesn’t accept it.

I’ll have to sort it out tomorrow with Apple support.

Thank you for listening.

The problem was …

I use Google contacts and don’t sync them to my MBA so my Contacts were empty and there was no way to connect my macOS account to my Apple ID.

And the solution was …

I created a Contact for myself containing my Apple ID email address; now AirDrop from my iPhone to my MBA works perfectly. :pleading_face::man_facepalming:t2:

2 Likes

I’m really glad you got it working.

I have searched and searched for solutions for a soundbar that shows up in Bluetooth and connects just fine…but does NOT show up in Sound preferences. It used to, before update to Ventura 13.x and iOS 16.2. I’ve tried the steps that worked for others, but no joy for me. I suppose the soundbar’s just too old…?

So Apple needs their AirDrop KB updated to reflect that Bluetooth and Wifi be on, that both devices permit Everyone or Contacts chosen, AND that you have a Contact of your Apple ID on device receiving to.

1 Like

I’m guessing that you tried all the obvious settings.

What the brand and model number of your sound bar? Did you look on their website for drivers or a tech support email address? I had a problem setting up  TV and was impressed with my TV manufacturer’s free telephone support seven years after purchasing it. (It was user errorr, of course. :man_facepalming:t3:)

At your prompting, I posted my solution on discussions.apple.com.

Thank you for the nudge.

I will follow your suggestion to check with the manufacturer, thanks!

The Samsung J-series soundbar has worked fine with both iOS and MacOS for years without drivers (“it just works!”), and still shows up in Bluetooth. AFAIK, nothing has changed with the soundbar, but the phone and computer have been upgraded multiple times to the latest and greatest. So I’m guessing that Apple has changed something.

I found instructions for updating Samsung sound bar firmware on their Bluetooth troubleshooting page.

Have you tried any other Bluetooth speakers (or headphones)? If none work then that makes more likely that the problem is on Apple’s side.

Apparently many other people had the same problem when they upgraded to Monterey but none of them posted a solution.

2 Likes

What, speakers now have firmware?! D’oh, I never even thought of that! All I can say is THANK YOU for going way, way above and beyond. You didn’t just suggest checking for firmware, you actually gave me the link! I wasn’t very hopeful because the filename of the update had “2005” in it, but YES, after updating it is now selectable as a sound source on both iOS and MacOS!

If I were ever to wonder about renewing my TidBITS subscription (I wouldn’t wonder, of course), the quality of discussion and the helpful attitude here would give me a healthy dose of reminder. Thank you again, I’m a happy camper!

3 Likes

Thanx to this discussion, AirDrop is now working again on my Mac. It used to work just fine, but suddenly stopped working some months ago, and I thought I checked everything. My problem turned out to be that somehow my Mac had disabled being discovered by anyone, a setting at the bottom of the Finder’s AirDrop window, which I just now noticed and fixed. Another happy camper!

1 Like