Big network speed drop on my iMac

I’m hoping someone might help solve a mystery regarding my network connectivity.

I have fiber direct to my home for my internet connection and when it was first installed (about four years ago) I ran Speedtest and saw that I was getting ~900 Mbps on a direct ethernet connection to my 2017 27” iMac. I checked the speed intermittently for a couple years and it was always about the same. I don’t do a whole lot of video streaming and because everything continued to work just fine I stopped checking the speed. When I checked it recently, however, it was now only about 90 Mbps! Still not a problem with what I normally do, but really?? Then I checked my wifi speed and found that it was ~400 Mbps, which suggests that the connection to my router was still fast. I checked the ethernet cabling to my desktop and it looked fine. I also took the ethernet directly to my desktop (bypassing the router) and it was still only 90Mbps. So what’s the deal?

In addition, I have an old 2013 MacBook Pro that I only occasionally use, but decided it might help confirm that the problem resides solely in my desktop. I ordered a Thunderbolt to ethernet adapter and when I checked the speed with the direct ethernet connection to the MacBook, lo and behold, it was ~900 Mbps.

Any thoughts about what might be going on would be greatly appreciated.

Here are a couple of things to consider.

In System Preferences > Ethernet > Advanced… > Hardware, Typical good settings include:
Configure: Automatically
Speed: 1000baseT
Duplex: full-duplex, flow-control
MTU: Standard (1500)

There have been some reports of the LastPass browser extension interfering with speed test results as in Network performance weirdness (SOLVED: caused by LastPass extension) - #4 by airwhale - Tech Support - MPU Talk

1 Like

All your tests have been done by visiting speedtest.net? Is this an accurate summary of your tests?

  1. 90Mbps iMac Ethernet (either via personal router or direct to ISP hardware)
  2. 400Mbps WiFi (on iMac?)
  3. 900Mbps MBP Ethernet (direct to ISP hardware)

A cable problem is the most likely explanation for the slowness. Have your iMac Ethernet tests all been done with the same cable or different ones? Was your MBP Ethernet test done with the same cable as the iMac tests? If two computers have very different performance with the same cable, that suggests damage to the Ethernet port on the iMac (same cable in the same location, it’s unlikely but interference can affect cables). If the 400Mbps WiFi test was done on the iMac, that also suggests that the problem is not in software.

Boot the iMac in Safe Mode and retry the Ethernet speed test with a cable shown to be good by a test with the MBP; if it’s fast, the slowness is being caused by software, if it’s still slow, the Ethernet port is probably damaged. If you can boot the iMac from another drive (an external boot drive or by putting the MBP in Target Disk Mode and connecting it by Thunderbolt), that’s an even more sure-fire way to tell whether the iMac has a hardware problem or not.

If you have a Thunderbolt 3 to 2 adapter, you could also try a speed test using the Thunderbolt 2 Ethernet adapter connected to the iMac. If it’s fast, the slowness is being caused by the built-in Ethernet port, if it’s slow, the problem is caused by software (again, assuming you’re using a cable that was fast when used with the MBP).

If the built-in Ethernet port is damaged, it’s probably cheaper to switch to using a Thunderbolt or USB Ethernet adapter than to get it fixed.

2 Likes

Ok, here’s some new information. My connection was set to Configure: Automatically, but it self configures to 100baseT. When I set it manually to 1000baseT, it loses the ethernet connection. But importantly, the ethernet normally runs through a TP-Link AC1900 Gigabit router (providing my wifi). If I bypass the TPLink router and connect the ethernet cable directly to my iMac, I can then set it to 1000baseT. When this is done I DO then get the 900Mbps on my iMac (yay!); but of course I need the wifi too. So maybe there’s something wrong with my TPLink router?

That’s good news. There are multiple “AC1900” TP-Link routers, do you have the Archer A9, Archer C9, or some other model?

Whichever model it is, they probably all have multiple Ethernet ports (not counting the one that connects to the ISP hardware). If you connect the iMac’s cable to a different port on the router, does it autonegotiate 1000 or 100? If you get 100, regardlesss of port, connect the iMac’s end of the cable to the MBP instead, what does it get?

You may need to login to the router, see if it needs a firmware update, and possibly change a setting on it.

1 Like

Yes, my TPLink router has four ports (C9). I did try switching the cables from the router, but the iMac still sets the connection to 100.

So, I guess my question now is: Why would my iMac autoconfigure to 100 while my older MacBook Pro autoconfigures to 1000?

1000baseT requires a cable of minimum of category 5 or 5e. This could contribute to the problem. The workaround for this situation is to set the ethernet port manually to 1000baseT. I’ll note that I used this workaround on previous occasions, but not for several years.

Checking for a firmware update for the router is always appropriate.

Thanks, everyone. I do use only Cat 5 or Cat 5e cables. Setting the port manually to 1000 doesn’t work. (There’s no ethernet connection at all when I do that.) I will check for a firmware update, but I’m still confused as to why the router works fine at 1000 with my old MBP.

Does that cable deliver gigabit speeds when used with the older MacBook Pro?

If not, then the cable may have gotten damaged.

10/100 Ethernet only uses two pairs (four wires) out of the cable’s four pairs (eight wires). Gigabit Ethernet uses all four pairs. If one of the four wires not used by 10/100 got damaged/broken in the cable, then devices will auto-negotiate down to 100M, which is the fastest speed you can get using only two pairs. And forcing Gigabit mode will fail because it won’t be able to pass any data over the damaged wire.

2 Likes

If you have a CAT5 cable with which you see 900 Mbps when plugging it directly into the ISP box and your Mac, then the cable is fine. If that same cable cannot deliver >100 Mbps when plugged between your Mac and the wifi router then the wifi router is garbage (assuming its firmware is up to date and you’ve tested all its ports). Throw it out and get a serious wifi router. They’re not expensive. Not exploiting bandwidth you already paid for is.

Yes, the cable is not the problem. I agree, it’s probably time to get a new router. (It’s running the latest available firmware.) I was just surprised that my old MacBook could get 1000 Mbps and my newer iMac couldn’t. Presumably there’s been some change in the networking hardware/software on my iMac that doesn’t sit well with my router. (The MacBook is still running Catalina, The iMac’s running Monterey.)

Thanks for the router review link. Christmas is coming…

If the router supports gigabit using a different computer and the same cable, then the computer is clearly the culprit. Whether the problem is due to a macOS bug, a hardware failure, or something else, would require a more in-depth analysis.

Have you tried using the Thunderbolt Ethernet adapter with the iMac? If it works, it may not prove anything (still could be a hardware failure or a macOS bug), but at least you’d be back up and running at full speed.

Maybe take a close look inside the iMac’s Ethernet jack. See if any of the 8 wires have gotten bent in some way preventing them from making good contact. As with a bad cable, if one isn’t making good contact, then the Mac won’t be able to establish gigabit connectivity, but might be able to establish 100M connectivity if the bad pin isn’t one of the ones used by 10/100.

2 Likes

Might also be time to run Diagnostics on your iMac.

Have you done repeated speed checks at different times? I have had a similar issue once or twice and suspect an issue with my ISP. At any rate I was getting a slow download of a file, did a speed test and found a slow download speed but good upload, tried again still got slow download, and tried a third time about ten minutes later and speeds were bak to what I would expect. The problem did occur again, but with similar results, and mostly the speed has been fine.

Speedtest is pretty consistent no matter when I run it (and I’ve run it at least 50 times since I started investigating this issue).
I’ve ordered a Thunderbolt to Ethernet adapter, so perhaps that will do it. (The Thunderbolt to Ethernet adapter I had for my MBP is not USB3 type.)
I can’t do it now, but I’ll try the Diagnostics this evening.

A Final Resolution:

So I bought “The Best WiFi Router” as recommended above, but it made no difference. I ran the Diagnostics, but it reported all was well with my ethernet. I ordered the Thunderbolt to Ethernet adapter and today it arrived.

Once connected — Voila! I had my 900+ Mbps back.

There was a bit of temporary confusion because it showed up as Bluetooth PAN, even though it ran at 900 Mbps. A google check for comment suggested I remove the Bluetooth PAN and reboot. After that it showed up as USB 10/100/1000 LAN, which makes more sense.

Not really sure if it was worth all the time, effort, and expense, but it’s fixed!

1 Like

Glad to hear it resolved well. There’s clearly a problem with your iMac’s Ethernet port, and a Thunderbolt adapter is probably going to be a lot cheaper than a repair job on your motherboard.

Yup, the Thunderbolt adapter is a pretty cheap fix. I have no plans to repair the ethernet, since there’s no visible damage to the port, so it’s almost certainly internal.

Thanks everyone for helping me work through this. Happy Holidays!

Just a note that might point to what the problem is. We had issues with these auto-negotiate ethernet ports on routers and PCs where I worked. Strange things with negotiating when one side was set to auto-negotiate and the other set to 100., you had to have both ends configured the same. That’s probably why when you set the one to 1000 it failed. The other end was probably auto. If you set one to fixed it won’t go thru the negotiate phase. There was more insanity that went on but the ‘set both ends the same’ seemed to work.

So your iMac probably has a problem with doing negotiating for some reason which can cause odd symptoms.

Bob