Apple Watch Series 3 Update Workarounds

Originally published at: Apple Watch Series 3 Update Workarounds - TidBITS

Some people with Apple Watch Series 3 models are having trouble installing watchOS 7 updates because they don’t have enough space available. Here are two ways to free up enough space to install the watchOS updates.

On Facebook, Ryan Driscoll suggested that he has been able to work around this problem even more easily. He just deletes the diagnostic logs, which clears up enough space. To do that, open the Watch app on the iPhone and go to My Watch > General > Diagnostics Logs. Then swipe left on each log to delete it.

If you can try this, let us know if it works!

I had the problem. I tried deleting apps first, but didn’t gain significant room. Then I tried your methods: The first method didn’t work - after a couple of nights on the charger with the update set up, it still had not updated. The second method worked, but as you said, it was a bit tedious and time-consuming. There has been another update since then, and it worked just fine from the Watch app on the iPhone.

1 Like

I cleared all of the logs, but it didn’t free any significant space.

I’ve tried the process with a Restore from Backup, but that’s never worked for me. I can only get the update to install successfully if I set it up as a new watch. It’s a pain because I also need to reactivate my debit card for Apple Pay. I actually had my bank flag my card because it was activated too many times in a short time span.

1 Like

I’ve had great success simply restarting my Series 3 Watch and then running the update process as normal from my iPhone. The restart seems to clear up enough memory to allow the update process to complete.

1 Like

What worked for me in the past was to remove all the apps that can be removed, then restart the watch, update and reinstall the apps. Restarting seems to free some storage.

For recent updates, starting the update directly from the watch as explained in the article has done the trick.

1 Like

Your first method worked for me. Updates have been failing for many months. This is on my wifes smaller size series 3 watch. My full size series 3 has never failed to load.

1 Like

The only method that would work for me was unpair/repair. it’s somewhat tedious, but not too bad. Tried everything everyone in this forum tried first.

Over in SlackBITS, Rob Costain had problems installing watchOS 7.4 on his Apple Watch Series 3 that weren’t resolved by any of these ideas. What I suggested, and he later confirmed from Apple Support Communities, is that the final solution is to erase the watch entirely, but instead of restoring the watch from backup when re-pairing, he had to set it up from scratch. (The post he found suggested deleting default apps and additional power cycles, but I suspect they weren’t necessary.)

If you find yourself in this situation, see if, after you complete the update to watchOS that was previously blocked, you can erase the watch again (I know, I know) and when you re-pair it, restore from the backup made before you did the clean setup. I don’t know if that will work, since erasing the watch always triggers a backup and I don’t know if you can get back to the previous one, but it might be an interesting test.

A few years ago, I had some watch issues that did involve doing a restoration from a non-current backup. You can see what backups are available from the iPhone Storage option of the General Setting.

So, go to Settings->General->iPhone Storage and wait until the list of apps populates (having a snack or going for a walk advised). After it fully populates, hit the Search icon (magnifying glass) and look for ‘Watch’. You should find the Watch app with Apple shown as the publisher.There wok be a list of available backups below that with the Watch name and date of the backup. Now, do the Watch restore and point at the appropriate backup when the time comes.

I think your numbers might be off, Adam. The article claims 8 GB of onboard storage. Looking at the General > About for my 3rd Generation, GPS-only Apple Watch (Model MQL12LL/A) I see a capacity of 4.1 GB. With ZERO apps installed, I only have 2.4 GB free and 1.8 GB used. Interestingly, restarting the Watch frees up about 300 MB of storage which is not enough to install this latest update.

The sum total of the data I’m using on the watch is about 40 MB (Contacts 20.4 MB, Photos 12.2 MB, Calendar 4.2 MB, Mail 1.9 MB, and Wallet 57.8 KB).

I can’t explain what you’re seeing, Sandro, but the 8 GB is straight from the horse’s mouth:

https://support.apple.com/kb/sp766

Obviously, some is being taken up by watchOS, so it would be interesting to see what the free space number is right after erasing and setting up from scratch.

That sounds quite normal. On my 32 GB Series 5, Watch app General / About shows a capacity of 26.2 GB, so Apple must have some space reserved and subtracts that from the capacity calculation.

Apple has now published a support note that basically says that you need to unpair, set it up as new, update, unpair again, and then restore.

Well the good news is that I can quit searching for a better method and just keep doing what I’ve been forced to do over the last year or so. But the bad news is the procedure takes a good two hours, and that’s not a “start it and then it’s done two hours later” kind of thing. It requires user actions every 15 minutes or so, and if you happen to miss one - then the full procedure ends up taking way more than two hours. Ugh. Definitely will continue to skip watch updates on my Watch 3!