Apple ID and iMessage/Messages

Hello everyone,

We’ve had more than one phone number attached to our apple ID since iPhone 4-- whenever that was-- and as of a couple months ago, our two current phone numbers were listed on our apple ID page. Nevertheless when I went to buy a new iphone and asked for it to be set up for Verizon, apple told me it didn’t recognized my number, even though it was right there on the site in front of my face.

I didn’t want to spend the time trying to fix it, so I bought the phone from Verizon and updated it using an itunes backup on my 2015 iMac.

I just logged on to our Apple ID trying to figure out how to assign the right phone number to my desktop iMessage/Messages app (which is stuck on some ancient version of my partner’s text contacts), and I find that his number is no longer listed on the site, only mine, even though his name and email are the apple ID.

And BTW, my partner’s desktop iMessage/Messages shows my texts. As if Apple decided arbitrarily that my computer is his and his is mine… I don’t really understand why there’s no way to assign an actual phone number to the desktop iMessage/Messages, which I assume is how texting is decided on our respective phones. Seems like our Apple ID is making random assumptions about us which aren’t particularly useful in this case.

Mostly, I’m mystified as to why things have to be this difficult.

Thanks, Brenda

I don’t know how you weren’t getting each other’s iMessages all along - iMessage is tied to an Apple ID, and any phone numbers attached to the Apple ID will get the same iMessages.

The best way to handle this is to have separate Apple IDs and use Family Sharing for app purchases (or have a third Apple ID that you use for app purchases and subscriptions, and many/most subscriptions cannot be shared with family sharing.) Or turn off iMessage, though I think that means no sharing of messages with a Mac.

As for the rest, ordering a phone and not transferring the number - that you’ll need to talk to Apple about I think. I know when i ordered new phones from Apple, it asked distinctly which number was being upgraded when I placed the order, and I was careful to choose the appropriate number, and it worked out both times (last September and this past April.)

2 Likes

It can be done, although I’m not sure what went wrong on Brenda’s phone, so this may not help her. We have both independently updated our iPhones multiple times through Apple, and it still works.

My wife and I have used the same AppleID since we got iPhones (iPhone 4). (My wife is not technical and does not want to learn most of the ins and outs of iOS.)
She receives her messages and I get mine without any overlap. There is a setting (under Messages) that allows one to choose where messages are sent and received from. In this setting on my iPhone I have checked my cell number and my AppleID email addresses. On hers, her cell phone number is checked and no Apple ID.
I am not advocating this, but it works for us. As for desktops (macOS), there is a similar setting for Message settings/preferences, but I am the only user of the desktops so I set it to receive only my messages.There are a few disadvantages to this setup, but she’s happy so I let it be.

We both share the Photos library and calendar, but not contacts (through iCloud settings on our respective phones). I have thought about setting up a separate ID and then a shared family, but seems like more trouble than is necessary…

1 Like

Looks like I’ve made myself really unclear: We’ve never had any mix-ups or overlaps between the two phones under a single Apple ID, as the iOS lets you select the phone number used for texting and doesn’t protest having more than one phone signed in.

My problem is with the desktop Messages App on our computers which does not let you specify a phone number and arbitrarily (and wrongly) chooses which texting stream to download to which computer.

The other problem that arose recently is that Apple dropped one of our numbers from our Apple ID page, even though both phones are listed with their numbers under “devices.” The Apple ID is listed at the top of the setting app but if I try to log in, it tells me something to the effect that “verification failed.”

We’ve had other mix-ups arising from the Apple ID site over the years, and I’m not sure adding another Apple ID would solve the problem. For example, they once refused to hand over a laptop we left for repair because they claimed it belonged to my daughter who has her own Apple ID, but used to be under ours. The laptop in question had never been under her Apple ID, but we still had to get an authorization from her to pick it up. There was no talking them at the store into realizing it’s a mistake.

I’d like to use the Messages app on my computer, but not so badly that I’d set up a separate Apple ID just for that. Nor do I know what to do about the glitches that crop up every so often on our Apple ID page.

Messages on my MBP has settings similar to my iOS devices, so I can select which phone number and email addresses through which I can be contacted. I’m currently running Ventura, but I think the settings have been the same for several versions of macOS now. Do you not see an iMessages panel in the preferences for Messages?

I see the same thing as Conrad when I go launch iMessage and then click on iMessage settings and the iMessage icon at the top.
It gives me a phone # and the email addresses I can pick as a default for launching.

My wife and I also have separate Apple IDs and I have set up a shared one. I have paid for more storage on my ID and we share that one. I haven’t found having those Apple IDs to be a problem and their was no additional cost except for the additional storage on my ID.
David

Thanks, but it wasn’t that I didn’t choose the right number. Apple says you can tell them who your carrier is, and they would set up the phone for you, but when I chose my number, Apple said it did not recognize it so it couldn’t set it up for the carrier. At the same time, the number existed on our Apple ID page. It’s not a current problem, just one example of another quirk with our Apple ID.

Interesting, I guess it’s what I’d expect, but all I see under the iMessage tab in the preferences is "Apple ID: xyz email address,” a checkbox for "enable this account,” and a grayed out checkbox for “You can be reached for messages at: xyz email address.”

Then, at the bottom of the window it says "Start new conversations from:” with a pull down menu showing the Apple ID email address grayed out – nothing to select.

Same setting on my 7-year old computer running Mojave and an M2 laptop running Monterey. Messages version 12 and 14 respectively. I tried with a new user on both computers and got the same look… No option to select a phone number.

Partner and I have separate Apple IDs. If we wanted to share one Apple ID, how would we add the other’s information? On a Mac running Big Sur, would this be Settings > Apple ID > Name, Phone, Email and then the + button? And then logout of the one account and login to the other account on one phone?

If I recall correctly, the reason we went with two Apple IDs on the two phones is for emergency contact and health info. How would we enter this information if the two phones share an Apple ID? Thanks for any info.

Good! That’s what Apple always recommends. Use Family Sharing to take care of any of your other needs.

Thanks. It’s nice to know I did something right, even if by accident.

I really need to learn more about Family Sharing.

So no one on this illustrious forum knows why I am not seeing phone numbers to be reached at/text from on my computer’s Messages application?

Because googling (or some such) these days mostly sends me to instructions on how to select my number for texting on my phone, and Apple’s instructions gives a matter-of-factly screen shot of phone numbers available to select, assuming I’d see the same thing at my end. Unfortunately, I see not such thing. iMessage preferences on my computer only show the email address, no phone number/s.

Here is a screen shot for what it’s worth:

As far as I’ve been able to determine, only an iPhone can register a phone number as an iMessage destination. Other devices will see an already-registered number and can de-select it, but only a phone can add it.

If your iPhone isn’t giving you the option to select your phone number (Settings → Messages → Send & Receive) alongside all of your iCloud e-mail addresses:

then, see if you can log-out/in to reset the list. If your phone is offering the option, be sure your phone number is selected. It should then appear in the Messages app on any other device logged in to your iCloud account (possibly only after logging out/in on those devices).

2 Likes

I’d guess that Messages on your iPhone isn’t logged into the Apple ID. The only option to reach you is then your Apple ID, so it’s not giving you a list to choose from.

It’s not enough to simply sign in to iCloud on your phone; it must also be enabled in Messages. That should happen automatically, but perhaps it got turned off for some reason.

1 Like

Both phones under our apple ID give us the option to select the phone number, and both “register” their respective number as the iMessage destination. Always have. Other devices (i.e., computers) don’t display either number, as in my screen shot. Never have.

My phone is logged into Apple ID and Messages is enabled in iCloud but the screen shot stands. The other phone is “away” and I can’t figure it out until it comes back home. I have so many other much more pressing problems, I guess this is where I throw up my hands and give up.

Appreciate the feedback. Thank you guys.

I have found that for other devices types, such as iPads and Macs, the phone needs to have Text Message Forwarding enabled for the iPhone’s number to show up. On the phone, go to Settings → Messages → Text Message Forwarding, and turn on the device you want the number to show up on.

If that was already on, try toggling it off, then on again.

1 Like

Thanks, good to know, but I don’t see “Text Message Forwarding” on my phone. Sure sounds familiar like I’ve seen it before, but it’s not there now. On the other hand if I click for the hell of it on “Share Name and Photo”, it says “Sharing Name and Photo is not available because iCloud and iMessage accounts are different or are not signed in.” The plot thickens. Or maybe not. AFAIK I am signed in to iCloud, but I have no idea how to verify that (or does it only tell me when I am NOT signed in?). And what does it mean that the accounts are different? We only have one Apple ID.

Thanks again

iCloud settings should list all your devices that are logged on.

macOS > Settings > iCloud (your picture at the top) > Devices
iOS > Settings > Apple ID (your picture at the top) > device list at bottom

I helped a friend recently with this same thing. We eventually logged out of iCloud on both Mac and iPhone, restarted the iPhone, and then the “Text Message Forwarding” option “miraculously” returned.

On my iPhone (running the latest version of iOS), under the Messages preferences, there’s Send & Receive, which will allow me to see which numbers and addresses I can be contacted at. At the very bottom in very small type, it shows which Apple ID the phone is logged into for iMessage. Tapping on it brings up an option to sign out. On older versions of iOS, there should be something similar.

Try signing out of your Apple ID there and then signing back in. That might fix the apparent confusion Apple’s systems are experiencing. (This is completely separate from signing into iCloud on your phone.)

1 Like