AirPort Utility issues?

I think QC has suffered recently too. Airport Utility has not worked since 13.0 on my iPhone and those quick updates did not resolve it as I had hoped. Are those of us with Apple routers being forgotten along with the router business? Has anyone heard anything about Airport Utility update? A Utility that will not connect to the devices is not very “utilitarian”!

Just a data point: AirPort Utility 1.3.5 (135.24) under iOS 3.1.2 connects without issue to my fourth-generation Time Capsule and my various-vintage collections of AirPort Express stations.

I have had instances in the past when I couldn’t connect to the Time Capsule with AirPort Utility on iOS or macOS when the Time Capsule otherwise appeared to be operating normally. Power-cycling the Time Capsule was required to get connectivity again.

Thanks. However, I have read about power cycling the Apple routers invloved. I have done that on both the TIme Capsule and Airport Extreme and the issue was not resolved. I too have had many of these devices and have never seen an issue like this one before.

Airport works fine on my iPhone with iOS 13.1.2. How does it not work on your phone? Is it not connecting or something else?

Thanks for your reply. The app runs and prompts for password. I provide the correct password. The app quits. No connection. Happens with both routers. I even changed the passwords and it failed. Works fine in the MAC version of Airport Utility.

Perhaps I should have stated all of this initially.

Have you tried uninstalling the Airport Utility app and then reinstalling it from the App Store?

Yes. I really should have stated all that I gave tried. As soon as 13.0 was on this iPhone7 Airport Utility wants the password and quits when correct password is entered. No improvement with any updates since.

Airport Utility has been working flawlessly with my AEBS on both my iPhone 7 and 10.5” iPad Pro since I purchased them.

Airport Utility opens and crashes on my 5th gen IPad running the latest IOS and I have deleted and reinstalled.


My iphone7 worked perfectly with the Airport Utilitu until the IOS 13.0 upgrade. I tried all solutions suggested here previously myself and I have repeated them all today. The Airport Utility still prompts for password and when the correct password is entered the app quits.

Al Varnell wrote:

I have even restarted the phone after each “solution” and the Utility quits every time I launch it and enter the password.

Michael Gillman wrote:

Mine never asks for a password, so perhaps that’s the issue. My WiFi device password has always been stored in my Keychain, so there’s never a need to use it.

I can connect via wifi to the Apple routers from
the iPhone to use them to connect to the Internet. I cannot connect to view or adjust anything using the Airport Utility on the iPhone. The utility shows both routers. I touch either one and the prompt for admin password appears, not the wifi password. I enter the correct admin password for each router. They are different. The app quits.


I just tried on an iPad running iOS 13, and Airport Utility crashed. I do have multiple WiFi devices, perhaps that is a factor. Also, Airport Utility does launch, but if I click on any of the devices, I get the password notice, and once I enter the password, Airport Utility crashes

That is exactly my experience. Stated succinctly!:blush:

After latest iOS update I noticed the same thing. I use the Airport Utility maybe once a year but was trying to check to see if there were any software updates. I experienced exactly the issue related here from my iPad (latest iPadOS). Just tried from my iPhone 7, latest iOS, and after asking if I wanted to save the password it crashed out. iMac Airport Utility works fine, but it remembers my passwords so doesn’t ask for them when logging in.

Sounds like a serious issue with i(Pad)OS versions of Airport Utility.

Jack Clay

Checked it on my IPhone 7 and it crashes there as well. The second it identifies all the routers and access points it crashes.

This does not appear to be a wifi password issue. It is the password for the Aiport device iself that is being prompted for and even if the correct password is entered the Airport Application crashes on devices running iOS 13. No problem with access from a Mac to the same routers using the same correct password.


Yes, that’s why I clarified my reply above by indicating WiFi device… That password is stored in my keychain and I guess, because I only have one such device in my network, there is never a need to enter this password in order to use Airport Utility with my AEBS.


I have only one AEBS on my network and Airport Utility on my iPad running iOS 13.1.2 crashes on entry of router password or on just enter as my iPad is not password protected.