AirPlay Video Blues

I know that there have been useful discussions here over the years of AirPlay and its faults, but I haven’t seen anything recent related to streaming movies from a Mac running Sonoma to an AirPlay-equipped TV set. I’ve tried Apple Discussions but haven’t got anywhere.

What happens is that I have various movies which I’ve bought and which can be played via the Apple TV app on my MacBook Pro. When you start playing one, icons appear which allow AirPlay devices to be connected. Some movies work, some don’t. For the ones that don’t, I get an error message on the Mac “This video is in a format that can’t be streamed to this TV”. This doesn’t seem to be connected to the DRM status of the movies. I also found that an MP4 file bought from an external site (Seven Arts) also gives this message.

One workaround is to treat the TV as an external monitor (presumably still working via AirPlay), This mirrors the MacBook’s screen and in that way I can transmit files such as my MP4 by playing them with the QuickTime player on the Mac. But that still doesn’t work with normal movies, because they are mysteriously included with the Apple TV app - I assume that they’ve been downloaded to the Mac, but I can’t find them and can’t work out what format they’re in.

It’s a mess really. Error messages like that are useless because they don’t give any detail.

Has anyone got any understanding of the current status of AirPlay?

This probably has something to do with Apple devices such as the Apple TV, no longer supporting old versions of the MP4 format.
If so, non-DRM movies can be “updated” by re-coding them with a Mac app such as Handbrake or similar.
DRM movies, such as those bought on the Apple store might be able to be fixed by deleting them from the Mac and downloading them again - after checking that they are still available from the Apple Store.
I had related issues when I updated to a new Apple TV a few years ago.
There are also restrictions on some DRM movies being played via Airplay (supposedly because the receiving device can then be used to copy the content). I find this when trying to Airplay some movies from an iPad but these movies play perfectly directly from an Apple TV.

1 Like

Thanks Michael for that reply. The device I’m trying to AirPlay to is a Sony Android TV with its own AirPlay software. It’s about 3 years old. Your suggestion that some of my movies may need updating is intriguing. It seems I can download any purchased movie, which gives me access to the file, so I will work on seeing if I can fix the ones that don’t play - but that doesn’t explain my other issue where I got a refusal for my MP4 file when trying to play it through the Apple TV app, but was allowed to play it when I designated the TV as a second monitor. It’s even more confusing than that: a test of some random movie files (all mp4) show mixed results. All the named movies have been paid for and I therefore have a licence to bypass the DRM (don’t I?):

Amadeus - won’t play using AirPlay or mirroring
Duck Soup - plays with AirPlay but not mirroring
Ghostbusters (1984) - plays with AirPlay - didn’t try mirroring
The Wrong Trousers - plays with Airplay - didn’t try mirroring
Personal movie created with iMovie (mp4) - doesn’t work on AirPlay or mirroring
Movies from BBC iPlayer - won’t play on AirPlay but OK on mirroring
Amazon Prime movies (via Safari) - no AirPlay link offered, doesn’t work on mirroring
Vermeer Exhibition documentary (Seven Arts) - won’t play on AirPlay but OK on mirroring

All this seems to suggest that the chain of communication from the Mac to the TV has to pass through a number of checkpoints: but in the total absence of any explanation or detailed description, it just remains a mess.

Sounds like Android hasn’t fully implemented AirPlay 2, or hadn’t as of the time your TV was manufactured. A simple “unsupported” message is standard behavior when a device doesn’t understand a request – there’s not much more it can report, really. (Maybe there’s a firmware update for the TV?)