YouTube news videos grayed out in Safari

For the past few days, when I open Safari (Sonoma 14.3, MacBook Pro 16-inch, 2019), visit and click the News category, all the videos (and category buttons) are grayed out. Most, but not all, of the other categories work fine.

I have tried emptying the Safari caches and restarting the computer to no avail. The problem doesn’t occur with Firefox or Chrome.

Any ideas or suggestions?


Any Safari extensions? Try menu View > Reload Without Content Blockers.

Thanks for the reload suggestion, @Simon, but no change.

The only extensions I have are 1Password and Subscribe to Feed.

Are you using Private Relay or any kind of manual DNS settings? I can tell you that I see no such issues here. Can you replicate the behavior on an entirely different network?

No Private Relay or manual DNS settings.

Sorry to be ignorant but how could I use a different network?

Curiously, I’ve been experiencing a similar issue in Safari in the last couple of days. For me it’s been happening randomly with newspapers’ websites:

  • Control-Click on a story link on the front page to open the story in a new tab
  • when I go to that tab, the text of the article is all there but instead of the accompanying photo there’s a light grey box (at the size of the photo would usually be)
  • reload the page, same result
  • page opens fine in Firefox
  • different story from the same website will open normally
  • these are news sites I visit every day so I can confirm it’s only started in the last couple of days
  • haven’t run any software updates

Well, if it’s a MBP I assume you could connect to a wifi somewhere outside your home/business. Even if it’'s a stationary Mac, you could tether it to an iPhone to connect via cellular data network instead of through your home/office router setup. Just to see if it’s related to your network.

I was just getting ready to post an update saying it’s now working fine again when I saw your message.

If it happens again I’ll try tethering to my iPhone, and if that doesn’t make a difference, I might reinstall the system, or just wait until the 14.3.1 update.

Thanks again for your help.