Word to PDF in Monterey

For some years now, I’ve been writing documents in Word using Optima and ITC Esprit fonts. I then produce PDFs (using AppleScript to tell Word to “save as PDF”) which I can email to clients. It’s worked very well and continues to work on my iMac Pro, which is running Big Sur.

I’ve installed Monterey on my 16" MPB (Intel). The Word documents look as they did before. However, although the Optima text in the PDFs looks fine, the text set in Esprit is replaced by a ghastly-looking font I don’t recognise.

Nothing else has changed. Any ideas welcomed.


Try verifying Esprit in FontBook, it’s built into every Mac. Fonts tend to be delicate and fragile creatures, and it might be a problem with the font that developed in the transition. If it’s a PostScript font, the printer font could be a problem and the display font is fine. If there is a problem FontBook can’t fix, remove the whole font and reinstall it from scratch. Don’t write over it.

1 Like

Done that, thanks. And deleted and re-installed it. FontBook says it’s fine. Curiously, italics render properly; only roman fonts (book, medium, bold, black) are ugly.

Is it? It’s not on my Mac (running Big Sur)

Definitely sounds like corrupt font files. If reinstallation from your distribution media didn’t help, can you re-download them from where you got them? Maybe there was an update to fix a bug that Monterey is exposing.

If you downloaded it from a free-font site, it could be that it isn’t a high quality font file. Maybe try purchasing it directly from Linotype.

Update: Or it could just be a macOS bug. Thanks @MMTalker.

I did a quick search, and it looks like you are not the only one having font problems with Monterey. Adobe fonts also are:

1 Like

I was referring to FontBook, which has shipped with every version of Mac since OS X. And if ITC is included in the name of the font, it’s definitely crystal clear it’s not a native Apple font.

1 Like

I’m curious about your workflow; specifically what advantage do you find in using an AppleScript to have Word save a PDF?

I use CMD+P to pop up the print dialog, then select “Open in Preview” in the system print dialog at lower left. The PDF that opens gives me the opportunity to examine the document as it will print; email it through the Share button; drag its icon to an open Finder (or Path Finder in my case) window; or even actually print it. I can also rename the PDF (and if anyone knows how to change the default Preview naming template that prepends the application name and retains the original extension, I’m all ears!).

But I might be misunderstanding the scope of the script you’re using, so I’d like to hear more. Thanks Jeremy!

I just “Save As” pdf directly in Word. I’m using a million year old version of Word on my equally elderly Mac.

Ahhh, that makes sense, and I remember versions of Word that could do that directly. One of my possibly faulty impressions is that when Microsoft started emphasizing cloud services, and a single code base, they made PDF a cloud service. (Also side stepping the fact that Postscript became the native imaging model for Macs post-QuickDraw.)

1 Like

Quick Draw…Quick Time…blasts from the past.

1 Like

My MacBook Pro is not particularly elderly (2019, macOS Monterey 12.1), nor is the version of Word I’m using (16.55). I just use File > Print > PDF > Save as PDF.

Out of curiosity, I just tried using the current Word to create a PDF. (using Office 365). It still has a PDF EXPORT option under Save As (file format). It gives 2 choices - 1) using Microsoft online services (which it says is better for best for electronic distribution and accessibility) and 2) Best for printing (which apparently does not use Microsoft online service).

Of course, it is still easier to save as a PDF from the MacOS print dialog…

Matt, the AppleScript, which is activated by a keystroke, does a number of things: it saves the document as a PDF to the desktop, deleting it if it’s already there; it determines the nature of the document from the last few letters of the name (I have a scheme, such as A for an advice, PoC for Particulars of Claim, Sk for a skeleton argument and so on); it generates an email with the subject taken from the rest of the document name, CCs it to someone who will file it on my Chambers computer system, and sets up body text derived from the nature of the document; and it places the cursor in the body of the email so I can type any additional text. I often do that sequence of actions several times a day.

I have tried “printing” to a PDF - it gives exactly the same awful result as “save as PDF”. I’ve just tried printing to paper (something I almost never do these days) and it too looks dreadful.

I’ve been using this font for nearly 25 years, and have long since lost whatever medium it came on - floppy disks, I imagine.

The oddity is that all this has been happening only after I installed Monterey. When I had Big Sur on the MBP, it worked just fine. Maybe something will be fixed in an updated version of the OS. I don’t really want to blow £100 on a new copy of Esprit.

Thanks for this. I suspected that “save as PDF” was only one small part of this AppleScript. I believe many more people would delve into the possibilities of automating their workflows if they knew the real-world applications, as you show.

As for Esprit: One truism in the long march of computer hardware and software development is that a font package is not issued once and for all time. Developers can and do issue updates when the platforms on which the font is used are revised. I have a small tray of 800K discs with Adobe Type 1 font packages, which would have been “gold standard” 30 years ago. I may plug a standalone floppy drive into my old iMac to see if they will still load (always nice to have more fonts!), but I have a feeling they too will have issues with my current Macs.

I do hope this is simply a Monterey “glitch”…perhaps the .1 update that just came out resolves the problem. And thanks again for sharing your workflow!

1 Like

Welcome! The combination of Keyboard Maestro and AppleScript, with occasional use of FastScripts for speed, is hugely powerful.

I’m hoping it’s a Monterey “thing”. Someone very kindly sent me another copy of Esprit. I jumped through what I think are all the necessary hoops: deleting my copy using FontBook, quitting, clearing the font cache in Terminal, restarting in Safe Mode and then restarting again, then installing the new version of Esprit, but it hasn’t helped.

All the weights (book, medium, bold and black) are fine in italic but not in roman. It’s not a Word problem: it looks just the same in TextEdit.

Ah well. At least my iMac, still running Big Sur, still works fine. I shan’t install Monterey on that machine until I know the issue is fixed.

1 Like

This problem seems to be fixed by MacOS 12.1.