Word opening documents on wrong screen

My setup is an iMacPro (27" monitor) with two 24" monitors, one on either side. The menu bar is on the iMac screen only. Recently, Word has taken to opening all documents on the right-hand monitor, which is irritating: I want them to open on the iMac’s built-in screen.

Any suggestions as to how I can achieve this will be gratefully received.


I have a similar setup with a MacBook Pro + 2 monitors and almost the same issue, but mine is with multiple apps and it’s not just a recent occurrence.

Doesn’t matter which desktop I assign an app to, it will frequently open new windows on another monitor. I should add my laptop screen is rarely involved, new windows typically open on one of the extra monitors instead of the desktop the app is assigned to.

I’ve not been able to track anything down, in part because I don’t know if this issue is caused by the app software, the OS or the monitor software? (both of my extra monitors are Dell)

I get into this situation often. It has to do with the last closed window and the Dock/Task Switcher.

If I was working on, say, Left Monitor and close a window, then switch to Right Monitor to launch a document or an app, it will still open in Left Monitor.

To get things back to Right Monitor, I have to COMD-TAB to another app that’s displaying on Right Monitor, then mouse down to the Dock (on Right Monitor) to reveal the Dock.

That points everything back to Right Monitor.

Hope this helps.


What setting makes your menu bar appear only on one screen? My setup has a menu bar on both screens, and what I see is that apps open, or open a new window, on the screen that has the active menu bar. That’s also the screen that has the window with the keyboard focus, if there is one.

I have a MBP running Monterey with one external screen, with the Dock on the external screen and menu bars on both screens (“Automatically hide and show the menu bar on desktop” is not checked). One menu bar is always active and is shown normally – the other menu bar is dimmed. I can make a menu bar active by clicking anywhere on its screen.

Apps launched by clicking on their icon in the Dock, which is on my external screen, always launch on that screen (since clicking on the icon first makes that screen active, then launches the app). Launching search with Command-space shows the search box on the window with the active menu bar.

@Matt_McCaffrey, that doesn’t work for me. The dock (which I have hidden) appears only when I mouse down on the main monitor. I suspect that’s related to @JKBull’s query, the answer to which is System settings → Desktop & Dock → Displays have separate Spaces, which I have turned off.

1 Like

So, you have one menu bar only (on the main screen) and the dock only pops up on the main screen. (My dock is hidden as well, which my last response took into account.)

The behavior I would expect is that the menu bar of the front most application will show on BOTH displays; the menu bar is dimmed on the inactive display (by which I mean, the display that has an active window running is the active display).

For various reasons my MBPro is still running Monterey as well, and this has been the behavior I’ve observed.

Second question for both @jbr and @bwhite : you both have a set up with two external displays. How are you driving those displays? Is there a third-party driver involved? How does Word “know” which display is active in this scenario?

Only one menu bar, on the main screen. Windows can span more than one screen, which they can’t if each screen has its own space. I think I had “separate spaces” enabled a while ago and something about it irritated me, so I removed it. Can’t remember what.

No third-party driver; I just plug the two displays into USB-C ports on the back of the iMac Pro. Word doesn’t know which display is “active”: that’s the problem.

Sensible behaviour would be for windows for particular documents to open on the main screen unless they’ve previously been moved to another screen and closed. But this is Microsoft…

Okay. So if I understand what you’re actually seeing, you have a single screen stretched across either two or three displays—like a mosaic. There is no “other display” to be active because there is no one-to-one correlation between displays and screens. So, Microsoft Word is simply opening new windows for documents somewhere on the big canvas of a single screen (not display) because it’s all one screen to the application.


If you’ve turned this setting off, I’m wondering if that’s your issue. I don’t use Mission Control the way Apple would like me to, but I did note that this setting seems to be on by default. I see a menu bar on each display because each display has a separate screen (or “space”) and when I move a window from one display to another I’m actually moving it into a different space. That’s a child of multi-display behavior that has been around for a long time, certainly before Mission Control or Spaces.

You might want to try flipping it back on (I’m on my Ventura machine at the moment, so forgive the ugly Preferences panel) and see what Word thinks of it.

Really appreciate the clarification, Jeremy!


I do have that setting turned off. I briefly re-enabled it and am now reminded why I disliked it in the past; it gives huge emphasis to screens as separate entities, rather than as parts of one large desktop. Some might think that’s a Good Thing. I hate it.

For example, I want Safari windows (like Word windows) always to open on my main screen. Without that setting, that’s what happens when I click a link in an email or WhatsApp thread (my mail and WA windows live on my left-hand screen). But when I enable the “separate spaces” setting, the Safari window opens on the same screen as the application that contained the link. I suppose that’s not “wrong”, given the concept of screens as separate spaces. But it’s not how I want my Mac to behave.

I’ve turned it off again. It didn’t help my Word difficulty; if anything, it made it worse.

Well, that sounds frustrating for you.

The engineers in the crowd would likely say that it may not be working the way you’d like, but it’s working as designed.

I recall using utilities in the way-back days of OS9 that managed windows, but I’m not familiar with the current landscape. Perhaps someone else has a suggestion or another idea. If it were me I’d certainly want to feed back to Microsoft a request to have more control over where windows open in its app.

Good luck!

1 Like

I use a small application called Stay that allows you to set which screen an app will open its windows in. Works well. Automatically will move a window if it opens on wrong screen. Runs in the background and has a menu bar item

1 Like

Some apps save the position of their window(s) in their preferences (defaults) so they can be restored to the same place when the app is next launched. If they don’t, or they don’t specify where to put a new window, macOS decides for them and cascades the windows. (Open a few windows inTerminal or TextEdit to see the cascade.)

It might be worth looking at Microsoft Word’s preferences to see if it has a preferred location for windows. If it does, perhaps it could be modified.

To see the preferences properly you can’t read the file that they are backed on; macOS does caching of that file. Instead, use the “defaults” command in Terminal. You will have to figure out the application-bundle-identifier to use in the command to get Word’s defaults. To do that, launch and quit Word, then look in ~/Library/Preferences and sort to get the last modified files first. Near the top there will probably be a file named something like com.microsoft.word.plist or maybe com.microsoft.office.word.plist. Omit the “.plist” when using the defaults command. For example, use something like defaults read com.microsoft.office.word.

The position and size of a window is often stored as a “frame”, consisting of an origin and a size, e.g., "{{989, 488}, {920, 522}}". You’re probably looking for something similar, although the display screen number could also be used. My app stores only those coordinates, which (even when running with Displays Have Separate Spaces) imply which screen the window should reopen on.

I looked on my system and didn’t find such a preference.

On Windows, MS Office opens new documents using the screen/position of the last-accessed document. If there are no open documents, it uses the screen/position of the last-closed document. It’s not always what I want (since I use all three of my screens for documents at various times), but it’s a logical approach that usually works.

I’m surprised the Mac version doesn’t do the same thing. Unfortunately, I only have one display on my Mac, so I can’t run tests to see what’s really going on, and have to rely on what others have written here. And if there’s a hidden preference that only shows up when there are multiple displays, I won’t be able to see it.

Unfortunately, I can’t reproduce what you’re seeing. For me, Word is very consistent. Documents open on the last monitor they were closed from. New documents open on the last monitor a new document was closed on. If I close a document or quit Word with a document straddling the gap between the monitors, the document will re-open on the monitor that had contained the majority of the document (horizontally speaking) previously.

MBP M1 Pro in clamshell mode, two LG 27" monitors, menubar on left monitor, “separate spaces” turned off, Ventura 13.4.1. Similar, but not exactly the same setup as you. I’m running Word 16.74.

There’s nothing of relevance that I can find in any of the possible plist files. It seems that there’s no easy solution. Ah well - it started spontaneously, so maybe it will go away spontaneously.