Word not recognising fonts

Ventura 13.4.1(c), Word 16.75.

Word has started to ignore all the fonts in my home library folder (~/Library/Fonts), as have Excel and PowerPoint. Other applications (Font Book, Notes, TextEdit and so on) continue to see them. I’ve tried quitting Word and relaunching it, logging out, even restarting. Font Book verifies them all as fine, and I’ve changed nothing from a few days ago, when all was fine.

It’s rather a nuisance. Any ideas gratefully received.

Not helpful but my Word 16.75 with Ventura 13.4.1(c) is seeing all my fonts.
Delete and re-install office? It seems like some “look here” function got whacked.

Have you tried the steps listed in this article?

The last time I had something like this happen to me, clearing the font cache solved the problem, though it also was interesting to see how many duplicate fonts of various vintages I had accumulated over time.

1 Like

Since everything worked before and you have changed nothing, I would try resetting font cache first like @josehill had luck with. You delete the cache by starting in Safe Mode. Then when you immediately without logging in restart, the cache is rebuilt.
Apples guide to Safe Mode
If that does not help, you can try the other things in Microsoft’s recommendation.

I’ve tried those things but nothing works. The MS pages refer to a new font, but I’ve been using one in particular (Esprit) since 1993 with no problems (well, there was an issue a couple of years ago, but it was corrected when MS released a new version of Word).

This might be some kind of font conflict. In my experience, you can not always rely on Font Book to report anything wrong and different applications might react or not react to the conflict.

Start by duplicating ~/Library/Fonts so you have a backup in ~/Library/Fonts_bk. Try to remove all the fonts from ~/Library/Fonts and then adding only one. Restart the mac. If this font shows, hunt down the font that makes this happen by adding and removing fonts.

If it does not show, try another font. If that does not show, something else is the matter.

1 Like

Tried that. Interesting result. Word is showing fonts in the folder with extensions .otf and .ttf. Although the font I use a lot (Esprit) is a TrueType font (according to Get Info), it’s not shown, and it remains not shown even if I give it a .ttf extension.

What is particularly weird is that this has suddenly started, for no apparent reason. I haven’t added or removed any fonts. Office updated itself three weeks ago, but that didn’t cause any problems, and all is still working on my MacBook Pro. It’s just the iMac that’s having difficulties.

Mr. Beede’s comment about some “look here” function being whacked may be correct.

After updating to Ventura 13.4.1(c) and Word 16.75, Word no longer displayed the icons for my macros in the Quick Access Bar. All had reverted to empty circles. Very annoying because I relied on the icons to recall what each macro does. Oddly, Word Settings showed that the icons were still linked to the macros.

I replaced Word ver 16.75 with 16.74. Icons restored, i.e., the problem was due to the application. It wasn’t necessary to reinstall Office or any pref file (although the macros are specific to Word). Perhaps doing likewise will fix the font issue? Alternatively, I believe Office apps are updated monthly, so the next iteration might behave properly.

Doesn’t Microsoft have its own Font folder? Can you run a conflict check on all the Font folders at once?

You could try to copy over Esprit from the other mac. If you use a USB stick, just copy it. If you send it to yourself in mail, compress it first. (Some older mac fonts get destroyed by mail.)

I solved the problem by uninstalling Office and reinstalling it from a fresh download. Rather more hassle than might have been considered strictly necessary, but it seems to be working now. Thanks, all, for the various tips.