Why won't photos move from Personal to Shared iCloud Photo Library?

…Instead, they bounce back.

Here’s what happens. I start with the vast majority of my photos in my Shared Library, one of Apple’s best new features (my wife can finally use her own Apple ID on her phone). I had actually moved all my photos to the Shared Library, but somehow these hundreds were still under the Personal:

So I select all of them, “right click”, and then say “Move 467 Items to Shared Library”. After a few seconds of thinking, they’re all gone, and I see this:


But then after about 1-3 minutes, these same photos start popping back in to the Personal Library! Within another 20s, they’re all back, and I’m back where I started. I’ve repeated the process many times, on two different Macs and an iPhone all using the same iCloud ID, and the results are always the same. These photos will not move.

So I tried moving some individual photos, or groups of photos. Interestingly, some of these will move (and stay moved). But others will not: they bounce back. Repeated attempts at the same photos don’t produce different results; it’s not like a temporary failure of some kind. There is clearly something about specific photos that is failing.

Another observation is that things do appear to move or not move as a batch: it seems as though if even one item cannot move, then the whole batch “rolls back”. It’s an atomic transaction. That’s generally good practice in software, though. But it means that it’s trial-and-error to figure out which are the “bad players”.

I took a shot at looking at Errors in Console, and, predictably, Photos shows a bunch of rather unintelligible junk. But I’ve spent enough time in Console to know that errors are spewing all the time, even when things appear to be running great. So that’s not proving helpful to me.

I also don’t see a pattern to what won’t move, such as certain “media types”, although I haven’t done a lot of experiments that way yet.

So this is puzzling and annoying, and I can’t seem to find anyone else discussing it online.


Are the subjects of the ghost photos the same? Do any of them contain your wife? Is there some subject matching and sharing that is going on. I remember in the talk that they talked about new Shared Photos that would automatically be shared when they contain certain people (or am I remembering it wrong). Is there something about those photos that are similar?

I’d strongly suggest a call to Apple on this one.

BTW, I forgot that I still have access to the Media Types “albums” in Personal Library view, which only shows the totals within that library. So I tried “Select All” + Move to Shared Library in each of them, but most of them “bounced back”, suggesting that there are “bad” photos in most of the media types, and hence that’s not the issue.

Planning to reach out to Apple. Looking for a time when I have nothing better to do than that and shooting myself in the head.

Stay tuned.

1 Like

Okay, so I did.

The short answer is that he doesn’t know the reason.

However, he shared something interesting. Noting that I have some 115,000 photos/videos in my library, he said there is a limit of 10,000 photos per-person, per-day that can be moved into the Shared Library.

Now, I explained that basically all but around 500 appeared to move almost immediately a week or two back. Were they now throttling me retroactively?? He thought that would be odd. And he agreed the UX was lousy; if there is a limit, Photos should present a friendly message and suggest I try later.

So I’m going to sit tight and try this for another week. If still failing, I’ll call them back.


Being a massochist, I tried moving photos (and vids) in increasingly-smaller batches until I narrowed down the individual bad actors to 49 photos and 5 vids that would not move from Personal to Shared Libraries: they kept bouncing back.

Then a few days passed with no improvement, so I called Apple today and spent a few hours on the phone with them. At first the one guy thought a specific photo wouldn’t move because a search revealed that the same image was already in the Shared Library; it must be iCloud properly preventing syncing a duplicate that it failed to previously delete. But navigating by date revealed the photo was NOT in the Shared Library, and what the search was seeing was from the Personal Library. Yes, the search apparently spans both libraries. He didn’t know that, and neither did I. But he’s supposed to be the pro :wink:

They kept trying to convince themselves that it was a certain Media Type, or an issue with my iCloud quota, or my device storage, or caused by edits, or media that were imported, etc. A bunch of guesses that people try who really have no idea what they’re doing, but can do some educated investigation. In other words, they didn’t help my situation at all… except that they were my gateway to the engineering staff. That’s why I paid my dues on the phone.

And now they have have opened an internal case with their engineers. I have uploaded some screenshots and a screen recording.

Someone has to take one for the team. I’m here for you people. Let’s see if we can get this fixed. :wink:




This problem has concluded, and the result is lackluster. Apple couldn’t fix it and I had to delete and reimport the photos.


Their engineers went through several rounds of troubleshooting with me (via Support staff). The most significant round was where they installed a special profile on my iPhone to capture diagnostics while I reproduced the situation. The feedback that I got about that today was obscure and didn’t make sense. It sounds like at some point the servers to which they were trying to sync changed. But that doesn’t explain why they CONTINUED to fail (even to today) and why ONLY SOME failed, when most of the others, migrated at the same time, went over fine.

I’m not sure why Apple Support staff constantly need reminding that exporting and reimporting photos to Photos is a lossy operation, but they always do because they often try to suggest it as a solution (really, a workaround), as they did here. And I proved it to him while we screen shared: metadata like Date/Time and Geocodes are embedded in the JPEG EXIF, and survive the round trip. But Keywords and Faces do not, nor do edits if you export the unmodified original. Still, that is their go-to workaround.

So the procedure was:

  1. export unmodified originals
  2. delete the photos from the library
  3. empty the Photos trash
  4. wait 14 days for some “expunge” operation to complete (I don’t get what’s going on behind the scenes in the Cloud, but I waited anyway. But some I did this a couple days ago appear to have stuck without waiting for any expunging)
  5. reimport the photos
  6. move them to the Shared Library

This works: all my photos are now in the Shared Library (and not bouncing back). Of course, I lost the above-mentioned metadata. This wasn’t a big deal considering the number of photos with this problem was relatively small. But it’s scary to think that the problem could have toasted 100,000 photos worth of metadata and there’s nothing Apple could have done to help me.

Anyway, I left myself available to their engineering team to continue to help troubleshoot if they needed. I told them, as I tell my engineers, I hope they at least learned something from the forensics of this problem so that they improve their design going forward! I like to think that my effort here is improving my own experience in the future :grinning:


I suspect that Apple at times is having trouble with keeping things synchronised across computers, and that produces some interesting side effects. I change computer A, so it goes off to the cloud and then tries to change on computer B. Now what happens if Computer B decides that isn’t going to happen, due to some bug. It probably tells the Cloud, nope everything is going to go back the way it was. So the Cloud tells Computer A, move everything back. I would expect that this is a possibility in any system where there isn’t a master. It’s great that I take photos on my iPhone and the end up on my iMac, I import on my iMac and they go to my iPhone and my iPads etc. As you make the system more complex, like adding extra sharing, something will inevitably go wrong.