Weird iMessage thing

(paulc) #1

I see I have made posts about the general topic, but this is a brand new symptom of dysfunction that makes me want to ask one specific question. Before that, here is the prelim stuff:

Get a message from my sister (on her iPhone). On my tablet. Write back, it says not delivered. Boot desktop, my message gets to her from there. I am getting all her messages on the tablet & desktop, she gets mine ONLY if I send on the desktop… we do this many times. I go thoroughly through my stuff, everything is fine. I use a group address on the tablet that she is in, she DOES get that. But not her direct one. Call Apple. Go through an hour of verifying everything I have already done. Then tell me one specific thing that I find kinda hard to believe… but I do NOT have a phone (but use iS on my tablet).

They SAY that someone can block my sending from a specific device but not other devices, this is why desktop gets through but tablet does not. BUT the “group” message to her SAME apple address does get through from the tablet. I DO think there is something on their end… so the question is, were they correct, can someone (inadvertently) block someone from a specific device but not other devices that blocked person may have?

(David) #2

That’s strange. The only thing I can think of, assuming I understand your issue, is that one device (your iPad) is using iMessaging whereas the other is using SMS messaging. I believe that blocking someone in Messages does not block SMS messages from getting through. So, if she accidentally blocked you on her iPhone, she would not receive your message sent from your iPhone. If your desktop is sending a message to her via SMS, the message will go through.

I’m sure others will be able to clarify what I’m clumsily trying to say.

(paulc) #3

For sure I am using wifi as my iPad has no cellular radio (technically it’s a wired connection to my ISP). She is at home, so no real idea exactly what she is using… but I know she has very good wifi there (FiOS).

BTW, a desktop can not send SMS far as I know (no hardware for it). Nor can my tablet (no SMS hardware, which may or may not be part of the cellular radio silicon).

Just had her reboot her phone, same issue. I CAN send a message to her via a group conversation, but not to only her. The rep @apple knew this but still thought she had some setting blocking me… which makes no sense at all. I NOW recall I saw this issue a long time ago… as I recall, in a few days it stopped happening, so I didn’t pursue it further. My sister is no technophreak, she rarely, if ever, visits settings and stuff like that.

(Adam Engst) #4

To clarify some things here:

  • When you say “tablet,” do you mean “iPad”? And when you say “desktop,” do you mean “Mac”?

  • If so, what version of iOS and macOS are those running? (This is relevant only if they’re particularly old—I don’t know of any specific problems, but the older the OS versions, the more likely you are to have problems with cloud-based services.)

  • What version of iOS is your sister’s iPhone running?

  • In Settings > Messages, do both of you have iMessage turned on?

  • When your sister messages you, what address does she use?

  • In Settings > Messages > Send & Receive on your iPad, do you have that address listed? Same question for the Mac, in Messages > Preferences > iMessage?

  • On your sister’s iPhone, in Settings > Messages > Send & Receive, what addresses are listed as being able to receive messages? And what address is checked under Start New Conversations From?

  • How does that list compare to the addresses you send to when you’re replying and what you have in the group message?

  • Does anything change if you send her a new message as opposed to replying to an old one?

Work your way through all those questions and hopefully one of them will pinpoint the mismatch between the systems.

(Richard Rettke) #5

In regards to sending SMS from a Mac desktop. That is not an issue. iMessage automatically sends as SMS if the receiver is not using iMessage (or if it cannot tell).

(Doug Miller) #6

I believe that would only be if you had an iPhone with text message forwarding turned on logged in to the same Apple ID. paulc says that he does not.

(paulc) #7

Adam, you make me smile! I know y’all don’t really know me, but I pretty thoroughly checked everything before I even called apple (I’m generally a pretty type a guy about this stuff, although not to the extent as in the old days when I was obsessive). Of course, they KNOW customers tell them stuff that turns out to be not really true, so they wanted to screen share to SEE everything for themselves. Desktop & tablet.

Yes iPad Pro, last gen, fully iOS up to date. cMP desktop, latest security rev of Sierra (I have an nVidia GPU, can’t do Mohave if I wanted to!). May go to HS if I figure out it is needed fr the later Metal rev. Sister is running latest iOS (12.2 I think).

Yes both our complete addresses are set up in Contacts, and have not changed in years. It is an existing “conversation/thread” that we use. As I said, no issue communicating both ways on my desktop. I can receive her on my tablet, but every attempt at sending results in an almost immediate “not delivered.” Yes we can communicate both ways if I use an old group conversation we almost never use anymore.

I thought about trying a new message, but if I try and address her, it simply bring up the existing conversation. Can’t really see a “start a new conversation” option, as you know, their “mobile apps” are limited. Oh wait, got an idea… gets WEIRDER.

So when I tired to send a new message, I chose the phone number, which was the first thing up. Tried a new message, but used her e-mail, not her phone. It opened a very old convo, one we dropped back in 2015. I sent and it got delivered, she just read it. Seems we can talk in that old convo. EXCEPT on my desktop, it pops up in the conversation that has the probems! THAT old convo seems to not be listed at all on the desktop. AND the desktop can communicate both ways without issues. Gotta start re-scratching my head again…

(Doug Miller) #8

So, if I was going to suggest checking something first, at this point I would have your sister check on her iPhone in Settings / Messages / Send & Receive that her Apple ID email address is listed and checked along with her phone number. I have no idea if this would prevent her from receiving your messages from the iPad/Mac, but this is the first thing that I would check.

(Adam Engst) #9

Great—just making sure. I usually mention those sort of details when posting the first time just to head off any such questions.

Messages is a little funny about how it groups things into conversations—I’ve seen confusing behaviour there too. What I might suggest, though this solution has some negatives, is that you delete all conversations with your sister (you could download them first with something like iMazing or iPhone Backup Extractor I think).

The other variable in play is Messages in iCloud. I’d try toggling that option before deleting anything. That’s Messages > Preferences on the Mac and Settings > yourName > iCloud > Messages in iOS. No clue how that might be related, but the fact that you’re getting different conversations in different scenarios says that there’s some syncing going on.

(James French) #10

I am seeing all sorts of weirdness from Messages. It is so bad, I am falling back on WhatsApp all the time.

  1. I am completely Apple with iPad, iPhone and two Macs. If I try to send a text from my MacBook Pro and the phone number starts with zero, it fails to send. If I replace the zero with +44, it goes just fine. This procedure isn’t necessary on all my other devices.

  2. I also find that messages, particularly texts, do not sync via iCloud properly on the MacBook Pro either. I have everything switched on and even the Sync Now button doesn’t help. Very frustrating! This behaviour is now well over 18 months old and has survived OS updates and replacement MacBook Pro. I performed a clean install a while back, which didn’t help, and that was what caused 1. above to start happening.

(paulc) #11

Yup, have definitely done all that. Just did it again! They are jumbling up bits and pieces from 2 “convos.” The desktop shows one convo, the tablet shows 2. My desktop shows only one on-going convo, my tablet shows 2, one of which I can NOT send from… It’s a complete mess.

(gib) #12

First, since you have no iPhone, you cannot message her via the cellular system. So she must (and EVERYONE should!) ensure that she can optionally be reached by her Apple ID (email) address, as well as her cell number and any other email addresses she might have. These are set in Messages/Preferences (“You can be reached for messages at:”).

She should also set the “Start new calls from:” to her Apple ID or some other email address; otherwise, you may not be able to reply if she starts a new message from her cell number! The “Blocked” tab is also worth checking.

In the addressee box at the top middle of the Messages window, click the pop-up and make sure you are NOT using her phone number; instead, choose her email address.

(paulc) #13

That works on my desktop, not my ipad. The issue has nothing to do with her reaching me, it’s me sending to her. ONLY became an issue 3 weeks or so ago (something outside of both our control had to have happened then, neither of us changing anything)). Only in one “convo.” NOW, that convo doesn’t even show on my desktop, but does on the ipad… I switched there to another convo and we can talk back and forth both on the desktop and the ipad. While it’s not the end of the world, a multi year convo seems gone from the desktop, but lives on the ipad.

BUT that old convo MAY have originally started via me going to her phone number (which very much is an intimate part of her apple id) and has worked just fine for years. When I tried a new message, it went to that old convo (that I receive from her but can’t send to her) UNTIL I explicitly used her apple id e-mail. Indeed, good advice about her setting so she only uses her apple id to send… but I am curious how that may affect and new SMS texts she may send to a non-apple user.

Sorry to sound grumpy, but for 30+ years I mocked winblowz and m$ for this kind of stuff and now I am eating my words.

(Adam Engst) #14

I really think there’s something corrupt within the conversations and how different devices see them. Deleting them might fix it, but as I said before, does come with the downside of losing all that data from within Messages.

(paulc) #15

These are pretty long threads… it used to be messages appeared in both because it was the same conversation, her part was always from her phone, mine from macOS or iOS. It definitely went off the rails… what was a separate very short conversation that worked both ways we started using; it has apparently somehow gotten what looks like at least most of the content from the broken thread (my guess is the cloud stuff somehow merged them). This one does NOT appear at all on my desktop, I operate IN the original “borked on iPad” thread). Oh, none of the specific message dates match even just looking back a few screenfulls.

I even went looking to see about archiving the “broken” conversation, say to a text file. Oh boy, MANY questions posed in a number of places, specifically asking about ENTIRE conversations and even single response was about saving off a single message! AND if the questioner actually SAID it was from a phone, most of the answers were how to deal on desktops… BUT I suspect you have seen this way more than I have! Someone did kind of mention PhoneView… of course, can’t be found anywhere on the app store.

As this is really just family stuff, NOT that big a deal. The ironic thing is that IF I still had a career, I’d be sure to never use this software for any mission or business critical needs… but those days are LONG over, so no need to face that choice.

SO thanks everyone for trying to help a guy out, I appreciate the time and effort y’all put into it.

(Ray Kloss) #16

iMazing will let you save the text as a PDF, but deleting will lose the context, if you need that.

(paulc) #17

Got on my iPad… trying to find anything in the store is… ! I can only search by iPad ONLY or iPhone ONLY, never either. Neither brings up this app. Top hit (after Game of the Day, which was listed first in search results) is Wallpapers HD… followed by Water Slide.

(gastropod) #18

On Fri, May 3, 2019, at 5:17 PM, paulc wrote: “Neither brings up this app.”

iMazing and Phoneview are programs that run on the mac, and talk to the phone directly over the usb cable. They aren’t in the Mac App Store–you need to get them directly from the developers. I don’t remember if there are limitations in the demo versions. iMazing is possibly the better one to buy. It’s more expensive ($45 vs $30) but does a lot more, especially versioned device backups. There are lots of others out there too, but I don’t have experience with them.

https://imazing.com

https://www.ecamm.com/mac/phoneview/

(paulc) #20

Ah… trying imazing… they never say what the limitations of the free version are, guess a lot of developers do this, but I find the practice seriously off-putting. Got it, ran the app, interesting, to connected to my backups automatically! Said to hook up my device and refresh, but when I did that nothing happened. Visited prefs, don’t launch itunes was off BUT iTunes didn’t launch… ok. Quit and relaunched it, NOW it sees my plugged in device. EXCEPT it seems to insist on ONLY backup up my entire device, something I do not want or need. Somehow I get to having a list of the stuff on my iPad so I click on messages, and it launches into an operation to backup what appears to be everything. Yet I know that it LOOKED like I COULD pick one conversation when looking at the backup copy. BUT the whole wireless backup has been broken for years, I had "reconnected it a while back, got to do 1-2 backups wirelessly, but none since then. Plug it in, launch iTunes, NOW it sees it… except it’s telling me it has NEVER been backed up! WTF?

I am SO furious that I must abandon this until I calm down… 30+ years as a Mac user and I have never, ever found I had to fight their crap as much as it seems I have to now.

So I got out to do my mrketing, hoping to clear my head a bit and think (I’m at the age where things don’t instantly think themsleves through…). MAYBE this imazing somehow deleted my itunes backups because it wanted to take over? So I run it, and see my backup is still there. Back to itunes and NOW it is NOT claiming I have never backed up, so I do that. Back to imazing, they DO seem to know that I had just backed it up. The iPad has connected to THEM via WiFi (something itunes seems unable to do more than once before failing). Same thing, if I try and just extract one convo, it MUST back the whole thing up… so I go to the backup which SEEMS to have an option to do just that. I get all the way to it being about to dum mit to a text file when FINALLY, the restriction they NEVER talk about pops up… 25 items. I mean, I can ;t really object to them HAVING some restriction, but I have gone through hell to get to even find out about WHAT it is.

Fortunately, to their credit, ecamm provided a very straightforward way to send them a message asking about “free version” restrictions. My bet is it’s going to preclude what I am trying to do… and it just is NOT worth it for 30 or 40 bucks to do it.

So that should close out this saga… except thanks for listening to my rambling and you’re trying to help.

Dayum, it seems this story will just NOT go way… thought it was over because we had a common convo on both devices where we CAN talk to each other. So she was at the dentist this morning and we exchanged some words (and an image she sent me). She’s on her phone, I’m on my tablet. Boot my desktop, go to write her one more thought I had and guess what? NONE of the conversation we had this morning is showing on the desktop! I write her that thhoght and it DOES appear on the tabet.