watchOS 7.3, iOS 14.4, iPadOS 14.4, and tvOS 14.4 Address Serious Security Exploit

Originally published at: watchOS 7.3, iOS 14.4, iPadOS 14.4, and tvOS 14.4 Address Serious Security Exploit - TidBITS

Apple has updated watchOS, iOS, iPadOS, and tvOS to fix a troubling security vulnerability that may have been actively exploited in the wild and deal with a few nagging bugs. Plus, watchOS 7.3 adds a new African-themed face for Black History Month. The HomePod mini also gets U1-enhanced handoffs from recent iPhones.

1 Like

Just updated an Apple TV 4K and stereo Homepods to 14.4. They all seem stable. I have tested whether iOS devices can reliably Airplay directly to the Homepods when the ATV has them as default output but they can still only Airplay via the ATV.

I suppose this makes sense because the ATV cannot be used for any other audio output at these times. I just tried a weather radar app on the ATV and the iPad music kept playing through the Homepods but using the Channels app to watch over-the-air TV caused the iPad music to pause.

I have been looking for a way to play a Tai Chi workout video on the ATV but play my own music on an iPad through the Homepods but this is not possible, since the video’s audio output overrides the iPad music. I prefer to not change the default audio output for the ATV because the home theatre function is working so well.

Update: I just tried Airplaying a movie from iTunes on a Mac (Mojave) to the ATV by selecting the ATV in the Mac’s Display Preferences. I was pleased to see that the video played on the ATV with stereo sound from the Homepods. However not all movie formats successfully play video with this setup - although they stream OK with Homesharing using the Computers app on the ATV.
Strangely I don’t seem to be able to do the same with playing music to the ATV by setting the Mac audio output to the ATV (not the iTunes Airplay setting). The album art appears on the ATV but no sound!

Update2: I just used good ol’ Quicktime 7 to replace the tai chi (talking) audio with an mp3 music track. Simple copy and paste (Edit/Add) actions. Another reason to stick with Mojave!

It’s WAY past time for Apple to pay some attention to use cases with Apple TV and Homepods. I get frustrated every time I try to use the homepods (in a second room) and the home theater setup that contains the Apple TV. Oh, for the days of ‘it just works’! Of course, '”It” gets more complex as life goes on…

An odd thing has happened after updating an iPhone and iPad to 14.4 - I can no longer sign into my amazon.com.au account on those devices. It still works with Safari on a Mac. It seems to be the OTP process because I enter a user name and password and it then asks for an OTP code (which is sent to my phone as an SMS so it knows who I am) but when I enter that code I get a password error message.

I recently updated the iPadOS to 14.4 and my Photos no longer sync’s with iCloud and thus with the Photos on my iMac running Mac OS Mojave 10.14.6. If anyone has any advice on how to restore the sync, I would be grateful.

Also, the iOS update completely wiped out my calendar events and settings from the iOS BusyCal app and when I launched it, I got a “Welcome” message as though the BusyCal app was newly downloaded. I’ve been using the BusyCal iOS app for years, so it seems to me that the iOS update to 14.4 broke the app somehow.

For Photos syncing, I would restart both your iPhone and your Mac and see if that kicks it. Also make sure that you have iCloud Photos enabled in Settings > Photos, just in case it got turned off in the upgrade.

As far as BusyCal goes, it’s just tying into the same data that Apple’s Calendar app relies on, so it’s very unlikely that anything has actually been wiped out. I would hazard a guess that BusyCal’s authentication to your iCloud account has been interrupted, such that you need to connect it again.

I’m just catching up via Twitter, but apparently, there were major problems on Wednesday, February 3 with various Apple Internet Sevices throughout the day. See Apple’s System Status page. My experience is that there can be issues with the page showing no problem, but if the page shows problems, they really exist.

Warning for updating to iOS 14.4. Since updating my iPhone 6S 128 GB (80 GB free), several Apps dont play streams any longer, either audio and video. In some cases this is true with downloaded media as well. I first noticed a grey cycling wheel on all Twitter videos.

Then I found that Internet Radio had stopped working for public german radio stations in their official common Podcast App “ARD Audiothek”. There are no error messages, the stream seems to start, but no sound. I tried to download episodes, but they dont pla either. Controller toggles between play and pause, but timecode remains at 0:00.

The same thing is true for sound messages in WhatsApp and for stored older videos in the media view of a chat. In Youtube App, the controller toggles between play and pause, but no sound, no motion and the timecode remains fixed. When scrolling to a different position within the video, I see preview images change, but starting the stream at the new position behaves exactly the same as described.

Streaming audio samples or videos within iTunes Store works fine.

Checked many general settings in iOS as well as App specific settings. Toggled Bluetooth to prevent the phone from inadvertently connecting with the sound system of my car in front of the house. Restarted the App. Removed the App and reinstalled. Tried different radio stations.

Feels bad.

Have you tried restarting the iPhone? That’s what I’d try next.

Hallo,

after writing down every step I had done so far, it finally came to my mind to try this. Hadn’t forced my phone to shut off in ages. Or more precisely any iOS device. And yes, it worked. Forgot to mention, sorry. So thanks for advice. And still, this is weird, isnt it?

Bye, Christian

1 Like

It is weird, but the way I see it is that iPhones are still computers, and every now and then, every computer needs to be power cycled to get a fresh start.