watchOS 5 fails to update play count


(crun) #1

i commented previously on this issue and was hoping someone else could validate it, especially as i’m trying to get apple support/engineering to take it seriously.

i have some 200gb of tunes in my itunes library. created a smart playlist for my phone that, amongst other criteria, looks for least recently played tracks. when the phone plays the track, it’s no longer least recently played. it’s removed from the playlist when the phone syncs to the computer.

after getting a watch (watchos 4.x), i duplicated this playlist and tweaked it to fit in the 2gb of watch storage. then i’d go for a hike leaving the phone at home. the playlist would update as above.

updated to watchos 5 and this broke. the watch only sometimes marks tracks as played. watch is currently running watchos 5.0.1. still doesn’t consistently mark tracks as played, as in mostly doesn’t.

initially i had a series 3 watch but recently replaced it with a series 4. thus it’s not hardware. both watches fail to mark tracks the same way.

if someone could replicate this issue, i’d really appreciate it.


Americans Can Now Download Their Apple Data
(Seth Anderson) #2

I don’t have an Apple Watch, but this same behaviour happens if I stream iTunes music via AirPlay to external speakers such as a HomePod. If I turn of the streaming, playcounts get updated, if I turn it on, playcounts are updated haphazardly (some songs are updated, some are not).

So I can confirm there is some sort of bug, and I’ve reported to Apple a while ago, but they haven’t fixed it yet.


(crun) #3

thanks seth. i’ve also had a number of times where a track or two don’t get marked as played on my phone, but it’s never been as pathological as the total failure on my watch: a couple hours of tracks don’t get marked. if it hadn’t mostly worked with watchos 4.x, i’d probably not be complaining, or asking others if they’ve experienced the issue.


(Steve Johgart) #4

I just had a similar but not identical issue. On my drive home today, I played some songs on my car sound system via Bluetooth CarPlay. All songs updated on the phone and appear in the default Recently Played playlist. However, after connecting the phone (iPhone 10sMax) to my Mac, on the Mac only the first song played shows a play count and date and appears in the Recently Played playlist there.


(crun) #5

i had a call from apple support today. we’d gone back and forth over several calls attempting to explain the problem. sysdiagnose (their filename, not my typo) was extracted from the watch a few days ago and apple engineering did their forensics. as suspected there’s some regression error in the watchos5 music player.

but who knows when they’ll have a fix …

thanks to everyone who looked at this tale of woe.