Ventura won't register my DVD-drive

I’ve been using an Asus usb DVD-drive for some time. Worked fine until recently. Now the drive is seen by the system (it shows up in System Information) but is not visible to apps, loaded CD’s or DVD’s don’t get mounted or start their designated players and diskutil doesn’t see it.

If I dive a little deeper with ioreg, I see the drive, but twice and as unregistered and unmatched:

  +-o AppleT8112USBXHCI@00000000  <class AppleT8112USBXHCI, id 0x100000471, registered, matched, active, busy 1 (1446813 ms), retain 47>
    +-o Portable Super Multi Drive@00100000  <class IOUSBHostDevice, id 0x100008fe7, !registered, !matched, inactive, busy 2 (3078 ms), retain 17>
    +-o Portable Super Multi Drive@00100000  <class IOUSBHostDevice, id 0x100009026, !registered, !matched, inactive, busy 2 (471 ms), retain 20>

I suspect the latest Ventura update caused this. I noticed the pop-up asking for permission when plugging in a usb-device only after the update, so my gut tells me that might be related.

I’m stuck at this point. Does anyone know what to look for in console or how to force macos to ‘register’ and ‘match’ the device?



Hmm, you’ve reminded me that I’ve not tried connecting my Samsung external CD/DVD drive to my Mac since upgrading to Ventura… I don’t use it often, only to occasionally rip a music CD. Will try that tomorrow.

Same here, rarely us it nowadays. Hope yours doesn’t cause issues. But, if you encounter similar issues, let me know.

I connected my external drive this morning, reinstalled XLD and tested it using a music CD. Interesting wrinkle: XLD wouldn’t scan the CD initially, I had to manually open it on XLD then give permission for the app to access the external volume. But touch wood, it’s working, so that’s good.

Just a thought, but have you checked in System Settings to make sure you’ve got a CD & DVD option there with the drive plugged in? If so, you may want to double-check what the settings are for various media types.

Good to hear yours is fine. Checked System Settings and no CD/DVD option is shown. The CD/DVD sharing option is hidden. Probably since the device isn’t ‘registered’.